Problem With UEFI Time

Essom

n00b
Joined
Jul 27, 2021
Messages
2
The time on my UEFI is always five hours ahead when I turn the computer off and on again (or vice-versa) or after a certain time of use if I do a restart to observe the time it is wrong.

I must say that this issue started occurring a few days ago: I was trying to install an operating system but the computer didn't recognize the bootable usb, so I simply removed the memory stick while the system was in UEFI mode, after doing this the image got "stuck" and I had to press the restart button. I'm fairly new to this whole PC building thing. I shouldn't have done that. Lesson learned.

Do you think I've damaged the hardware and it shows through the time on UEFI mode? Everything else seems to work normally and the clock on the OS is not mismatched.
Is there any way to fix this?
My motherboard is an ASUS Prime B460M-A.
I'm using a GNU-Linux based OS.

Thank you very much for your time and hope you are well.
 

NattyKathy

Gawd
Joined
Jan 20, 2019
Messages
910
Are you in a timezone that's 5 hours behind UTC by chance? I vaguely remember this from when I was using Linux awhile ago... IIRC Linux distros set the system time to UTC/GMT and apply an offset in software as opposed to Windows which sets the system time to local time.
 

GiGaBiTe

[H]ard|Gawd
Joined
Apr 26, 2013
Messages
1,937
Most Linux Distros have the option to use UTC time, but don't explicitly enable it unless you tell it to. In Fedora, Debian and OpenSUSE, there's a tickbox somewhere in setup to turn on UTC time, else it will go with whatever time zone you set. I haven't seen any distro yet that explicitly enables UTC time, but that doesn't mean they don't exist.
 

SmokeRngs

[H]ard|DCer of the Month - April 2008
Joined
Aug 9, 2001
Messages
17,418
Most Linux Distros have the option to use UTC time, but don't explicitly enable it unless you tell it to. In Fedora, Debian and OpenSUSE, there's a tickbox somewhere in setup to turn on UTC time, else it will go with whatever time zone you set. I haven't seen any distro yet that explicitly enables UTC time, but that doesn't mean they don't exist.
The last time I installed openSUSE it set the BIOS clock to UTC and used an offset for the OS itself to show local time. I think there was an option to stop it from doing that but it was the default. Manjaro also sets the BIOS clock to UTC and uses an offset for the OS. At this point I figured it was the default behavior for most distros.

I know anytime I boot from Manjaro into Windows the OS is showing UTC time until Windows updates the time at which point it sets the BIOS clock to local time. When I boot back into Manjaro from Windows it shows local time in the OS likely because of the time update being done during boot instead of after the OS is completely loaded.
 

Denpepe

[H]ard|Gawd
Joined
Oct 26, 2015
Messages
1,904
Check the battery on the motherboard to see if it is still good.
 

Essom

n00b
Joined
Jul 27, 2021
Messages
2
I'm sorry: for various reasons I had not been able to connect. Thanks to everyone for your replies. I think the "problem" is, precisely, that many Linux based OS are configured by default to display UTC time. I'll change the battery anyway, just in case. I'd like to know if having different times between UEFI and OS can cause inconveniences; I guess not, it's just a detail that bothers me a little.
 

lopoetve

Fully [H]
Joined
Oct 11, 2001
Messages
31,831
I'm sorry: for various reasons I had not been able to connect. Thanks to everyone for your replies. I think the "problem" is, precisely, that many Linux based OS are configured by default to display UTC time. I'll change the battery anyway, just in case. I'd like to know if having different times between UEFI and OS can cause inconveniences; I guess not, it's just a detail that bothers me a little.
Yes, depending on what all you run, it definitely can.
 
Top