port forwarding with d-link dir-655 router



i've been trying to get remote desktop to work with vista ultimate. i know how to forward ports so i ruled that out until i tested the port i was trying to use and found that it was not open like i thought. i have 1 port open for torrents and it works, but none of the others i have open work. here's a screenshot form my router setup page. is my computer's static ip.


can you guess which one works? its 58498. none of the others work. now if i change it to the common remote desktop port 3389 it will work. i'm completely confused why its not working and could use some guidance. i don't to use 3389 because its the common port so its less secure.
You can just set RD to cancel requests after 3x failed attempts...so you don't have to worry about outsiders trying to hack the common ports.

BUT....when you change the default RDC port....you must make a custom rule in the Windows firewall for it. The normal "exception" checkbox for remote desktop is only for 3389.
for testing i have all firewalls disabled.

my problem is that i can't get any port to forward correctly except for that 1. and whats what i'm trying to figure out whats going on. not so much worried about the remote desktop at this time.

i just called comcast to make sure they arn't blocking anything, they arn't. i didn't think they were but i had to check.

edit: haha. the general customer service person said they weren't blocking any ports except for the one for their mail server. then to make sure he get's me over to the level 2.5 support. the first 2 people i talk to have no clue what i'm talking about or what a port is.
Do you have another PC on the LAN to test this with...locally? Connect to

This way you can determine that the host PC is indeed functioning correctly.

How are you testing this connection to determine that it's failing?
I don't use Vista so I am just assuming here.

I'll assume you change the ports the same way you do it in previous versions which you change a registry value. My suggestion is to make sure you're changing the right registry entry (and it is in decimal) because I was doing this one time and I found out that I was editing what appeared to be the right entry but in the wrong hive.
sorry for the delay, i was out for a few days.

in the registry the default entry was in hex. so i've been changing it to decimal, entering the port, then changing it back to hex. i've been trying to use port 23456, its easy.

i just tried connecting to over the network and it didn't work. then i tried connecting to, without the port on it and it worked. //sheep also works to connect to. yes sheep is my computer name.

ok, when i change the port in the registry its like its not going through. i changed it to 23456, but it still lets me connect on port 3389. changes in the registry go through instantly right?