PC Crashing while Playing or starting games

Aug 14, 2021
I got the Problem that my PC is crashing while playing Rust and also that my PC is crashing when I start Call of Duty. If i play GTA 5 it works normally and fine.

My specs are : AMD Ryzen 5950X / corsair vengence 32gb Ram / Geforce GTX 1070
PSU : Thermaltake Tough Power Grand Series RGB 1050W 80 Plus Platinum
CPU cooler : Corsair H150I Pro

Temp while running Cinebench and Userbenchmark are around 60 to a max of 65

Probably also good to know i mostly have Discord / Logitech G HUB / Steam / Teamspeak / Voicemeeter open while playing games

I tried to activate DOCP but if i activate it my PC doesnt start anymore and i get an organge Ram light on my Mainboard. I than have to pull out the Bios Battery to reset my Bios and after that my PCworked again fine but still with only 2133mhz.

I already tried to update all drivers / downloaded newest windows version / locked at the tempretures who where normal / Deactivated all overclocking

i ran out of ideas so i need some help. The confusing part is that GTA works fine Rust works only a bit after than crashing while playing and call of duty works not at all because it crashes and mostly i cant even see the first call of duty text that it starts.

So if you got any ideas i woud be thankfull.
up your ram voltage to 1.4v and try docp again. every set of corsair i have ever used needed extra voltage. start there and see if it helps. also, you can drag and drop pics into the message body here, no need for imgur, which i cant seem to open... and finally, welcome to [H]!
Didnt worked it still is at 2133mhz

And if i put DOSP in and set frequency to 3600mhz than my pc doesnt start and a yellow ram light goes on. After than pulling out bios battery and so resetting bios than it works again.
Have you checked to ensure that your BIOS are updated to support said CPU? What about the voltage to the CPU?

I run into the same issue with my recent build using a 5600x. PC would randomly power off when playing games. Boots up just fine. Thinking is something to do with voltage being delivered to the CPU but since it was a gift build, I have to wait for it to be here to further troubleshoot.
try 1.4v and 1.15v on the vsoc.
or try 3200, that is the official supported speed for that cpu.
and as just suggested, make sure your bios is up to date(run 2133 to update it).