Nvidia GeForce GTX TITAN X Owners Club

xorbe

Supreme [H]ardness
Joined
Sep 26, 2008
Messages
6,028
Why would you waste a microfiber cloth wiping paste off? That's like using silk to wipe your ass. I use one slice of TP or bit of paper towel to get the bulk, then a couple q-tips + rubbing alcohol to shine up. On the chip, not my butt ...
 
Last edited:

phorkz

Limp Gawd
Joined
Nov 5, 2012
Messages
368
Ok i have another question(3),

When raising the fan speed in say MSI Afterburner, does that raise just the stock fans speed and not that of the one on the radiator?

If so, i assume you plug the radiator fan into the mobo instead?

Does the I/O bracket have to be removed for the Titan X?, i am assuming so.
 
Last edited:

Seyba

Limp Gawd
Joined
Mar 11, 2006
Messages
134
That's a good point. If there is a considerable difference in TW3 performance with the Titan X vs the 980... I can't say no.
 

skypine27

Gawd
Joined
Apr 18, 2008
Messages
732
Also have pre bought Witcher 3. Expecting it to run pretty smooth with 2 x Titan X's at 3440 x 1440 (60fps)
 

EvilViking

I Drank All Your Beer
Joined
Mar 7, 2005
Messages
1,327
So my 2 week old titan x with the evga aio cooler never hits temps over 50c. Just recently the card started ramping the fan to 100%. Afterburner would still show the default 32% speed and the only way to lower it was to perform a reboot. Uninstalled afterburner and I can still occasionally hear the card "try" to speed up for a split second..... Wtf? Is it software related or do I need to rma it?
 

Dawill

Limp Gawd
Joined
Mar 26, 2006
Messages
397
Ok i have another question(3),

When raising the fan speed in say MSI Afterburner, does that raise just the stock fans speed and not that of the one on the radiator?

If so, i assume you plug the radiator fan into the mobo instead?

Does the I/O bracket have to be removed for the Titan X?, i am assuming so.

AIO cooler has a y splitter for the watercool and the fan. You unplug the fan, plug in the watercooler's power cable and the plug the old fan cable into the watercooler's splitter. Then there is another adapter for the fan on the radiator. You can plug it into that or into a standard motherboard fan connector. I just kept it all attached to the gpu for now. I'm not really sure on the impact of MSI afterburner or evga precision on the radiator fan. It definitely gets louder as it heats up, but not much. Highest I've seen so far is 51c which is still pretty low on my fan curve. I've manually set the fan to 100% and it's louder for sure, but nowhere near as loud as the stock cooler. I'm not sure why though. Possibly less turbulence from the heatsink being gone?
 

phorkz

Limp Gawd
Joined
Nov 5, 2012
Messages
368
AIO cooler has a y splitter for the watercool and the fan. You unplug the fan, plug in the watercooler's power cable and the plug the old fan cable into the watercooler's splitter. Then there is another adapter for the fan on the radiator. You can plug it into that or into a standard motherboard fan connector. I just kept it all attached to the gpu for now. I'm not really sure on the impact of MSI afterburner or evga precision on the radiator fan. It definitely gets louder as it heats up, but not much. Highest I've seen so far is 51c which is still pretty low on my fan curve. I've manually set the fan to 100% and it's louder for sure, but nowhere near as loud as the stock cooler. I'm not sure why though. Possibly less turbulence from the heatsink being gone?

Thanks, i might just leave it attached to GPU and run my overclock see what temps i end up with, if all good i will just leave it that way.
 

NotJay

2[H]4U
Joined
Jul 15, 2007
Messages
2,662
witcher 3 @ 3440x1440 with single titan x oced to 1391/8000
it dips down to mid 35's with everything maxed out in open field
had to turn hairworks off and put foliage distance down to high from ultra
now i'm getting high 40's to 60 ( vsync on)
 

pandora's box

Supreme [H]ardness
Joined
Sep 7, 2004
Messages
4,733
witcher 3 @ 3440x1440 with single titan x oced to 1391/8000
it dips down to mid 35's with everything maxed out in open field
had to turn hairworks off and put foliage distance down to high from ultra
now i'm getting high 40's to 60 ( vsync on)

3440x1440 Titan X SLI at 1291MHz/7000mhz mem: 60fps locked, max settings in game.
 

phorkz

Limp Gawd
Joined
Nov 5, 2012
Messages
368
Any 2560x1440 info for W3 with Titan X?

Sounds like can be all but maxed out.
 

Seyba

Limp Gawd
Joined
Mar 11, 2006
Messages
134
I wouldn't mind knowing if this card, or a 980, could keep a consistent 60fps at 1080p for TW3.
 
Last edited:

deasnutz

Limp Gawd
Joined
Feb 9, 2012
Messages
377
That is awesome. Bypass the retail party.

Sounds like the code may be sellable after redeeming it, no? Get the code from GeForce Experience, someone else can apply it to their GOG account? I own it already.
 

Dawill

Limp Gawd
Joined
Mar 26, 2006
Messages
397
Yay! I was all pissed I didn't get it for free like the 980. Now I can give it a whirl on my pc. I was going to just play it on the ps4 as I already pre-ordered a long time back.

Curious to compare titan-x vs my ps4. Videos online of pc vs ps4 have been underwhelming to say the least.
 

bodine1231

Limp Gawd
Joined
May 10, 2005
Messages
364
Any 2560x1440 info for W3 with Titan X?

Sounds like can be all but maxed out.

I just got my Titan in today and ran a couple tests in the first town. With EVERYTHING maxed @1440p I'm getting between 50-60+ fps but there is some hitching,even with Gsync,seems like it happens when there is alot of grass and you spin the camera really fast. With Hairworks off there is less hitching and frames are in the high 70/low 80's. There is the occasional dip to 60 in one part of the town,maybe because of the shadows and grass. There is still some hitching but its way less with Hairworks off.

Again,this was just the first town after the tutorial. I don't know what major cities or countryside will look like.
 

convexion

Gawd
Joined
Jun 15, 2004
Messages
946
I just got my Titan in today and ran a couple tests in the first town. With EVERYTHING maxed @1440p I'm getting between 50-60+ fps but there is some hitching,even with Gsync,seems like it happens when there is alot of grass and you spin the camera really fast. With Hairworks off there is less hitching and frames are in the high 70/low 80's. There is the occasional dip to 60 in one part of the town,maybe because of the shadows and grass. There is still some hitching but its way less with Hairworks off.

Again,this was just the first town after the tutorial. I don't know what major cities or countryside will look like.


I'm using a 750 ti for physx alongside my T-X and I'm not seeing these issues with gsync and everything on ultra @ 1440p. The only slight hitching I see is when horseback riding regardless of gallop speed or fps, but on foot everything is very smooth.
 

Seyba

Limp Gawd
Joined
Mar 11, 2006
Messages
134
I just got my Titan in today and ran a couple tests in the first town. With EVERYTHING maxed @1440p I'm getting between 50-60+ fps but there is some hitching,even with Gsync,seems like it happens when there is alot of grass and you spin the camera really fast. With Hairworks off there is less hitching and frames are in the high 70/low 80's. There is the occasional dip to 60 in one part of the town,maybe because of the shadows and grass. There is still some hitching but its way less with Hairworks off.

Again,this was just the first town after the tutorial. I don't know what major cities or countryside will look like.

Would you mind doing some minor testing at 1080p as well?
 

Dawill

Limp Gawd
Joined
Mar 26, 2006
Messages
397
Maybe I'm crazy, but does anybody else notice an occasional graininess to the textures? I noticed this on witcher 2 all the time. On witcher 3 it's much less often, although I've only played for ~2hrs. I think it might be their texture compression algorithm or possibly some other optimization, but I'm not sure. I've only ever seen this on witcher games. Honestly it made witcher 2 look like crap IMO, as it was almost always there. On witcher 3, I've seen it maybe 1-2 times.

Anybody else notice this or am I seeing things (quiet possible)?
 

Armenius

Fully [H]
Joined
Jan 28, 2014
Messages
28,189
I'm using a 750 ti for physx alongside my T-X and I'm not seeing these issues with gsync and everything on ultra @ 1440p. The only slight hitching I see is when horseback riding regardless of gallop speed or fps, but on foot everything is very smooth.
I thought that TW3 was only using CPU PhysX? If it is using the GPU for PhysX that is awesome news. I'm using one of my "old" 970s as a PhysX card :cool:.

pCARS is also using CPU PhysX and I see no usage from the 970 during gameplay with the 970 dedicated to PhysX in the NVIDIA CP.
 

convexion

Gawd
Joined
Jun 15, 2004
Messages
946
I thought that TW3 was only using CPU PhysX? If it is using the GPU for PhysX that is awesome news. I'm using one of my "old" 970s as a PhysX card :cool:.

pCARS is also using CPU PhysX and I see no usage from the 970 during gameplay with the 970 dedicated to PhysX in the NVIDIA CP.


That's a good point, I'll look at the utilization of the physx card later to see if it's being used. If it's not then CDPR has done a very good job with optimizing the physics effects.

EDIT: You're right, no utilization of the dedicated card. I'm at a loss as to why others with a Titan-X are seeing hitching.
 
Last edited:

pandora's box

Supreme [H]ardness
Joined
Sep 7, 2004
Messages
4,733
PXHVApC.jpg





Just need to get a back plate for the second Titan X.
Before anyone says "should have gone custom water": I take my PC to LAN parties fairly often, not moving a custom watercooled rig.
 

lee0539

[H]ard|Gawd
Joined
Nov 17, 2001
Messages
1,804
Might be an option for bottom sli card with top card water cooled if the noise isn't bad. Not everyone has a massive case with multiple radiator room without sacrificing airflow.
 

Etherton

Will Bang for Poof
Joined
Aug 7, 2006
Messages
6,997
Well, just picked up a EVGA Superclocked Titan X from B&H. It'll be here Wednesday! Also, ordered the EK waterblock & backplate from Perfromance-PC's... :D
 

JayteeBates

[H]ard|Poof
Joined
Jul 21, 2007
Messages
4,889
Well kudos to EVGA for upgrading me from a titan superclocked to titan x on my recent rma.
 
Last edited:
Top