NVIDIA card w/ FreeSync - Pixelated graphics (especially hair)

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
I've noticed it just on a few games - Marvel's Avengers, Modern Warfare Warzone, Red Dead Redemption 2 and Mafia 1 Definitive Edition. It's generally more perceptible on hair (beard), lines and detailed environments (high LOD). Dunno if is it a bug because of the nvidia freesync combination.
Card: GTX 1070
Monitor: AG323FWG3R3 (165hz FreeSync)

Screenshots of Marvel's Avengers (Very High preset wiht 70fps-90fps):
20210801182458_1.jpg

20210801182502_1.jpg

20210801182650_1.jpg

20210801182701_1.jpg

20210801182704_1.jpg

Ingame it doesn't look as jaggy as on these screenshots.
Just so you can see, 2 screenshots with little to no pixels (taken on the same playthrough).
20210801163443_1.jpg

20210801175651_1.jpg
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
Try posting screenshots from some of the other games. Not many have played the avengers game, and honestly, hair in games sometimes just looks like that. Like shit.
Ikr, if I had those I would post, but I've beaten and uninstalled mafia and rdr2. The hair sure looks like shit, but notice how the forest also has a pixelated look on those screenshots, also bruce's arm/hand is pixelated and the shadow on his torso also looks strange. I'm thinking it's a side effect of activating gsync with a freesync monitor and having the fps too far from 165.
 

gesicht

Gawd
Joined
Jun 25, 2004
Messages
864
i got this with RDR2 horses that had dark tail/mane no freesync/no gsync
i adjusted soft shadows, i forgot what i did, either turned it down or to max and it went away.
 

grumperfish

Weaksauce
Joined
Apr 19, 2014
Messages
112
They used that dithering effect for shadow edges in Witcher 3 and once I noticed it I couldn't stop myself from seeing it everywhere. Less noticeable on higher resolutions but still present. It looks like they used it for all the vegetation in those screenshots, but if it gives you the option to bump up shadow resolution or soft shadow rendering quality it might improve at the cost of performance. Freesync/G-sync compatible settings won't have anything to do with it.
 

DanNeely

Supreme [H]ardness
Joined
Aug 26, 2005
Messages
4,140
It seems like the simplest way to test this would be to disable freesync on your GPU/Monitor and see if the hair rendering changes or not.
 

cybereality

[H]F Junkie
Joined
Mar 22, 2008
Messages
8,789
Might just be how the games are rendered, I don't think it is related to FreeSync. I've definitely seen that kind of effect on all sorts of games, usually with hair.

What you might want to do is render at a lower render resolution scale. I find putting it at 80 or 90% sometimes smooths out that look (also increases performance). FSR would also help.
 

jobert

Gawd
Joined
Dec 13, 2020
Messages
535
So people are actually saying this is normal? That is nonsense as looking at walkthroughs if you dont own the game will show Marvel's Avengers looks nothing like that garbage being shown here in the first few screenshots.
 

jmilcher

Supreme [H]ardness
Joined
Feb 3, 2008
Messages
5,411
So people are actually saying this is normal? That is nonsense as looking at walkthroughs if you dont own the game will show Marvel's Avengers looks nothing like that garbage being shown here in the first few screenshots.
This would be expected performance from a 1070 imo with these titles.

OP it’s not a freesync/nvidia issue.
 
Last edited:

noko

Supreme [H]ardness
Joined
Apr 14, 2010
Messages
6,669
So people are actually saying this is normal? That is nonsense as looking at walkthroughs if you dont own the game will show Marvel's Avengers looks nothing like that garbage being shown here in the first few screenshots.
I've seen this with 1080Ti's using FreeSync 4K display, I was able to correct by going into the drivers and under "Change Resolution" "Use Nvidia color settings"
  • Desktop Color depth: Highest (32 bit)
  • Output color depth (8bit or 10bit is you have a 10bit monitor which I did)
  • Output color format: RGB
  • Output dynamic range: Full
Nvidia drivers at the time was pushing 6bit + FRC with my 10bit monitor: WTF I thought but yes games would have this pixelated look. Not sure if that is the same problem after a few years of Nvidia drivers! Also do you have GeForce Experience Optimizing your games (more like destroying them)? If so, turn that shit off and go to defaults in 3d Settings and Program settings in the drivers besides the color settings. Best I can think of.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
I've seen this with 1080Ti's using FreeSync 4K display, I was able to correct by going into the drivers and under "Change Resolution" "Use Nvidia color settings"
  • Desktop Color depth: Highest (32 bit)
  • Output color depth (8bit or 10bit is you have a 10bit monitor which I did)
  • Output color format: RGB
  • Output dynamic range: Full
Nvidia drivers at the time was pushing 6bit + FRC with my 10bit monitor: WTF I thought but yes games would have this pixelated look. Not sure if that is the same problem after a few years of Nvidia drivers! Also do you have GeForce Experience Optimizing your games (more like destroying them)? If so, turn that shit off and go to defaults in 3d Settings and Program settings in the drivers besides the color settings. Best I can think of.
I'm afraid I already use these settings, and no, none of my games are "optmized" by GeForce Experience
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
Might just be how the games are rendered, I don't think it is related to FreeSync. I've definitely seen that kind of effect on all sorts of games, usually with hair.

What you might want to do is render at a lower render resolution scale. I find putting it at 80 or 90% sometimes smooths out that look (also increases performance). FSR would also help.
I would definitively try this out but unfortunately I was playing Marvel's Avengers on a Steam free weekend. I guess I'll try this when I find another game that has the same problem, thanks anyway.
 

GoodBoy

2[H]4U
Joined
Nov 29, 2004
Messages
2,195
That isn't caused by freesync (or any sync), it's likely one of the AA settings. Might be an in-game setting conflicting with a forced setting in the nVidia control panel.

If you haven't applied the GeForce experience optimization settings for this game, then that is worth a try.

You didn't list the resolution, or if that game has variable resolution (upscaling/downscaling) to guarantee performance.

1070 is 5 years old, it's time to upgrade. You can find 2080Ti's on ebay for around $440.
 

cybereality

[H]F Junkie
Joined
Mar 22, 2008
Messages
8,789
I do agree that the GTX 1070 is a little older now, but should be good enough for the time being (considering the market).

In any case, I'm not even sure a faster card would fix this, I just think that is how the game looks.
 
Joined
Jun 15, 2005
Messages
882
Being nunvidia what's the hair option called in their control panel? Try turning that off and allow it to simply raster and you won't notice it as much?
 

NattyKathy

[H]ard|Gawd
Joined
Jan 20, 2019
Messages
1,040
I've noticed this in a number of games recently as well on both AMD (Vega 64) and NV (1050 & 2070S)... Cyberpunk 2077, Metro Exodus, Control, I think another I'm not remembering rn.
From what I can tell it has to do with the way the hair is rendered in a separate pass and possibly at a lower resolution and doesn't get AA applied the same way. It's less noticeable at higher resolutions and in certain lighting conditions but it seems to be (speculation) a limitation in how the hair shader effects work. It's not a simple deforming mesh effect, there's something else at work there and the way it's layered on causes these artifacts. IMO there's a 0% chance it has anything to do with sync of refresh rate.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
That isn't caused by freesync (or any sync), it's likely one of the AA settings. Might be an in-game setting conflicting with a forced setting in the nVidia control panel.

If you haven't applied the GeForce experience optimization settings for this game, then that is worth a try.

You didn't list the resolution, or if that game has variable resolution (upscaling/downscaling) to guarantee performance.

1070 is 5 years old, it's time to upgrade. You can find 2080Ti's on ebay for around $440.
My image settings are the Quality preset. The only modification is that I have enabled DSR (just to mention, this problem occurs regardless of enabling or disabling DSR). About GeForce Experience, I have tried this before, but didn't help aswell. I play all games at 100% 1080p resolution scale at 165hz. About the 2080Ti, in Brazil this card is nowhere to be seen, the only available card (better than the 1070) is the 3090 (which costs the equivalent of 18 months of work considering Brazil's minimum wage). Even though I can afford it, there's no chance I'll be doing this insanity. So I guess I'm (for the time being) stuck with the 1070 and this annoying problem haha
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
Being nunvidia what's the hair option called in their control panel? Try turning that off and allow it to simply raster and you won't notice it as much?
I'll try this out, but the problem occurs with not only hair but shadows aswell. I'm gonna post a screenshot with this problem with shadows on GTAV.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
I've noticed this in a number of games recently as well on both AMD (Vega 64) and NV (1050 & 2070S)... Cyberpunk 2077, Metro Exodus, Control, I think another I'm not remembering rn.
From what I can tell it has to do with the way the hair is rendered in a separate pass and possibly at a lower resolution and doesn't get AA applied the same way. It's less noticeable at higher resolutions and in certain lighting conditions but it seems to be (speculation) a limitation in how the hair shader effects work. It's not a simple deforming mesh effect, there's something else at work there and the way it's layered on causes these artifacts. IMO there's a 0% chance it has anything to do with sync of refresh rate.
The thing is, this happens with other stuff, such as shadows and some lines (e.g. electrical wires on a light pole). Check the screenshot I'll post on GTAV. About my thoughts that refresh rate might be a problem, there is a chance of artifacts being shown on screen when the game is being played on a framerate too far from the refresh rate. I play at 165hz, but most (if not all) newer AAA games run at 60fps-90fps, a 105fps-75fps gap between refresh rate and fps.
 

ChosenUno

[H]ard|Gawd
Joined
Aug 26, 2011
Messages
1,288
In nVidia Control Panel there's Antialiasing - Transparency. IIRC that's supposed to help with things like this, maybe turn it on and see how it goes.
 

jobert

Gawd
Joined
Dec 13, 2020
Messages
535
I do agree that the GTX 1070 is a little older now, but should be good enough for the time being (considering the market).

In any case, I'm not even sure a faster card would fix this, I just think that is how the game looks.
Again, that is NOT how the game looks. I am the only one here capable of either firing up the game or looking at videos of the game? What he is showing looks like pure shit and is in no way shape or form anything like the videos and screenshots I have seen.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
Differently from Marvel's Avengers, on GTA the screenshots look better than the game I see on my monitor, but the problem is the same. Doesn't happen on hair though, but on some shadows and vegetations. I've marked the most noticeable parts. It's like there are a lot of dots/pixels (if you can't see it directly through the screenshots, zoom in a little).
Inked20210810004852_1_LI.jpg

Inked20210810004901_1_LI.jpg

Inked20210810004911_1_LI.jpg
 

GoodBoy

2[H]4U
Joined
Nov 29, 2004
Messages
2,195
My image settings are the Quality preset. The only modification is that I have enabled DSR (just to mention, this problem occurs regardless of enabling or disabling DSR). About GeForce Experience, I have tried this before, but didn't help aswell. I play all games at 100% 1080p resolution scale at 165hz. About the 2080Ti, in Brazil this card is nowhere to be seen, the only available card (better than the 1070) is the 3090 (which costs the equivalent of 18 months of work considering Brazil's minimum wage). Even though I can afford it, there's no chance I'll be doing this insanity. So I guess I'm (for the time being) stuck with the 1070 and this annoying problem haha

I'm not familiar with that game, but assuming that Quality is one of the top presets?

Since you mentioned you also see it on things like power lines, that again makes me think it is an AA setting. You would think that the AA would be set fairly high on a "Quality" preset, but who knows. Go into the settings and customize them, what options does it have for AA? Can you crank them up?
Also go look in your nVidia control panel - 3D Settings - Manage 3D settings
1628567851248.png

Try various options, one at a time.
Also scroll down and try various settings for these:
1628568109537.png


Generally, you would want "Application controlled", but if the game doesn't have a lot of options, you can create a profile for the specific game under the "Program Settings" that will override the in-game available settings.
You might also be overriding the in-game setting with a Global setting.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
Again, that is NOT how the game looks. I am the only one here capable of either firing up the game or looking at videos of the game? What he is showing looks like pure shit and is in no way shape or form anything like the videos and screenshots I have seen.
Thanks for taking alook around, I too don't think those games look like this.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
I'm not familiar with that game, but assuming that Quality is one of the top presets?

Since you mentioned you also see it on things like power lines, that again makes me think it is an AA setting. You would think that the AA would be set fairly high on a "Quality" preset, but who knows. Go into the settings and customize them, what options does it have for AA? Can you crank them up?
Also go look in your nVidia control panel - 3D Settings - Manage 3D settings
View attachment 383314
Try various options, one at a time.
Also scroll down and try various settings for these:
View attachment 383319

Generally, you would want "Application controlled", but if the game doesn't have a lot of options, you can create a profile for the specific game under the "Program Settings" that will override the in-game available settings.
You might also be overriding the in-game setting with a Global setting.
Unfortunately GTAV (the only game I have installed right now that has this problem) takes a lot of time to start (due to my old HDD) hahah. Will be messing with these settings around, thanks. I'll post an update after making these changes.
 

cybereality

[H]F Junkie
Joined
Mar 22, 2008
Messages
8,789
Sorry, I don't have Avengers and I don't plan to play that game. But I have seen similar look to hair in games like Devil May Cry 5 and more on a 2080 Ti and also a 6800 XT, so I don't think it's a bug.
 

jobert

Gawd
Joined
Dec 13, 2020
Messages
535
Sorry, I don't have Avengers and I don't plan to play that game. But I have seen similar look to hair in games like Devil May Cry 5 and more on a 2080 Ti and also a 6800 XT, so I don't think it's a bug.
Instead of just guessing or talking out my rear end I spent a few minutes looking through some of the videos and they clearly show that grid looking shit is NOT the game.
 

im_shadows

n00b
Joined
Feb 17, 2018
Messages
32
I'm not familiar with that game, but assuming that Quality is one of the top presets?

Since you mentioned you also see it on things like power lines, that again makes me think it is an AA setting. You would think that the AA would be set fairly high on a "Quality" preset, but who knows. Go into the settings and customize them, what options does it have for AA? Can you crank them up?
Also go look in your nVidia control panel - 3D Settings - Manage 3D settings
View attachment 383314
Try various options, one at a time.
Also scroll down and try various settings for these:
View attachment 383319

Generally, you would want "Application controlled", but if the game doesn't have a lot of options, you can create a profile for the specific game under the "Program Settings" that will override the in-game available settings.
You might also be overriding the in-game setting with a Global setting.
I've turned gsync on and off, messed up with my monitor's resolution (it displays its native resolution as 1080p on the Ultra HD, HD, SD section of NVIDIA's Control Panel, but like this the maximum refresh rate is 120hz, so I usually use the 1920x1080 resolution, displayed on the PC section of the panel, so that the monitor can go up to 165hz -- anyways, I've tested using both resolutions), changed all settings highlighted by you, changed refresh rate and maxed MSAA and all AA options available in game, tried optimizing the game via GeForce Experience (again), and, unfortunately, nothing changed (didn't even get better or worse). I really can't think of how am I gonna fix this.
 

jobert

Gawd
Joined
Dec 13, 2020
Messages
535
Well, okay. I did a quick Google search and lots of people have the same issue "avengers pc game hair":
https://www.google.com/search?channel=fs&q=avengers+pc+game+hair

Some people said enabling TAA helps (rather than SMAA). It's the game.
Not a single video shows anything like what the OP posted. And I only see a few threads complaining about the hair and none of them have any screenshots like what the OP is showing. Feel free to post a link to something if you see it as I must be blind.
 

jobert

Gawd
Joined
Dec 13, 2020
Messages
535
Also this from the Steam community. Not trying to be a jerk or anything, but I really think it's just the game.
You are not being a jerk. I did not even see that pic in the first link so its my fault. That said it looks nothing like that in 99% of the screenshots I see and again there is nothing like that in the gameplay videos so I dont know.
 
Top