NF7-S with a 2500+ work?


Mar 31, 2003
ok today I just bought a new Athalon XP 2500+ Processor and I checked on the AMD site to make sure that my mother board was compatible with it and it showed it as it is...(I have a Abit NF7-S) the compatibility chart told me it is compatible. But, I installed the new processor and made sure everything was connected properly and tried to turn it on, and it will not turn on at all, I have power to the motherboard so its not the power supply. So I thought I might check with the Abit site to see if the processor is compatible, and to my surprise it shows it as not compatible. So, my question here is... Is my new AMD Athalon XP 2500+ Processor compatible with my Abit NF7-S Motherboard or not? Each website shows contradicting statements. :( Thanks for your help
The Abit NF7-S with an AthlonXP 2500+ is by far the most common rig combo on the [H]ard. I am running this setup right now. Trust me, the two are compatible.
This is like the absolute most popular OC setup for AMD processors. It's compatible. YOu have some other problem somewhere in the line. Try the standard troubleshooting steps first. Take the mobo off the mounting tray, put it on a table with just the CPU/HSF, memory, and video card connected, connect power supply and power switch, and turn it on.

Make sure your PSU switch is on if you have one, make sure your switch is connected to the header the right way, and try it again. If you have another switch, use it. If none of that works, your PSU may be dead, so try another one, or your existing one with a known working if you have the spare parts. If your PSU doesn't have the 4 pin ATX 12v connector, try one that does have it. Just stay calm, go step by step, and you'll get it figured out. Basic troubleshooting can solve a whole lot of problems.

EDIT: Also, I'd be interested to see where the Abit site said it wouldn't work. Please link if you can.
oh yeah also I was wondering if I should clear the CMOS aswell?
hmm, well I have the basics connected... CPU/HSF, Memory, Vid card, and the PSU is connected and the on switch is on... The red light on my mobo is on as usuall, but it will not turn on at all, no fans turn or anything, so this probably means its my PSU correct?
TO answer the other question, yeah, when you build a new machine, I've found it's generally good practice to clear the CMOS the first time you fire it up. As for the PSU, try testing it in another machine that you know works. Keep in mind that it could also be your power switch, but it's more likely that it's your PSU. Try hooking the reset switch to the power switch headers and hit that button. Swap everything you can before deciding something's bad. Sometimes you get lucky and it's some really small thing that's an easy fix. Also, double check to make sure your switches are connected to the proper headers, then check them all again.

Oh yeah, and yes, you should use the 4 pin 12V connector also.
well I just ran into yet another problem... I took out my psu and tried it on my other working comp, and it worked fine. So maybe its not my PSU. I also tried putting back my old CPU that I know works in my mobo, with that psu and it did'nt work again. soo :confused: My PSU works just not with this comp. Can it be the switches then? I tried rotating them around, and I triple checked that they were all in the correct headers, it still wont turn on. Also, when I press the on switch I do see my lil red light in my mobo dim a little bit, if that means anything or not I dont know.

Also on a side note, everything on my comp is exactly the same hardware wise. All that I upgraded was my CPU. And this PSU that I have in there did work earlier...
well holy crap... I just went away for a few minutes to grab some snacks, and I tried to turn on my comp again, and it WORKED :p ................for 2 seconds and then shut off :mad: everything went on, and then just poof it just turned off... I wonder what can be the problem. So now it turns on and then turns off just as fast as it went on w/out pressing any thing.
I would say it's almost undoubtedly a heatsink issue. Make sure it's seated properly and that you applied the thermal paste or pad correctly.

When you say it turns on, do you mean it just powers on, or do you actually see something on the screen, or not enough time to tell?
sounds like a heat sink issue to me too. try reseating your heat sink
this may sound stupid........but did u check to see if the mobo is touching the case? thats what happened to me when i built my comp
Decay said:

heres that link where it does not list the 2500+

thanks for your help in advance... my current PSU has the 4 PIN atx as well, I never used that connector b4, should I go ahead and try that connector aswell?
That was an old page. That chart was made when the Thoroughbred processors were just beginning to be shipped with a 333MHz FSB. Bartons were still quite a ways off at the time that chart was made.
Anarchonixx said:
When you say it turns on, do you mean it just powers on, or do you actually see something on the screen, or not enough time to tell?

it just powers on, nothing on the screen at all... Ill reset my HS hopefully it works
well Iam still crap out of luck as of yet, I got the HS reseated and every component is how it should be. But now the same problem as before is happening again. I can't turn on the comp at all yet again. I think my Computer hates me
Do you have any usb headers? If you do, unplug them from the motherboard then try turning your system on.
yes I have usb headers, they are all unplugged the only things pluged into my mobo are my processor, memory, vid card, power switch, and HD
If you are comfortable..Unplugg your PS, take your motherboard out of your case with CPU, RAM, and PS header plugged in but not the frontpanel headers. Make sure your motherboard is lying on something nonconductive. Then turn your PS on (or just plug it if you don't have a switch on your PS). Then short the two pins where the power button header is plugged in. If it boots then something is shorting out your board in your case.
This might be a dumb question, but did you get the board new, or as a refurb? If it's a refurb, that could be your problem right there, if you bought it new, it's probably still under warranty.

Also, if you reset the CMOS jumper, make sure you put it back to the default before trying to boot again.
how would I short the power switch headers?

and yes my mother board is new, and the board is'nt the problem, cuz it was working before I bought my new processor today... and the CMOS jumper is in its correct position
Decay said:
how would I short the power switch headers?

and yes my mother board is new, and the board is'nt the problem, cuz it was working before I bought my new processor today... and the CMOS jumper is in its correct position

Just because it worked before doesn't necessarily mean it'll work now. Sometimes stuff just goes bad, sometimes you kill parts without knowing it. You may have scratched an etch when you mounted the heatsink, any number of things could happen. I'm out of ideas, but good luck to you, hope you figure it out.
sure you didnt over bend any resistors? Anything chipped? Another possibility is the thermal sensor under the cpu core. Usually if its compressed low enough that it doesnt touch the proc when it is installed, your comp wont boot, so try stretching it out a lil (be gentle though!) Bad ram? If you reset your CMOS, did you put the jumper back into its original setting? Is the power switch on your case working correctly? If the switch is staying depressed for 4 seconds, it will cause your computer to shut down.
To short the pins grab a flat head screwdriver and touch it to the two pins. You should definitely as others have said bench test it though (aka run it on a flat surface), you said you have the HD connected, disconnect it, this is probably not the problem, but for the sake of troubleshooting you should only have CPU/HSF, RAM, and PSU connected .... short the power headers with a screwdriver, if the hsf starts spinning up and its obvious the mobo has power then add the vid card to the setup. If you can, try the cpu in a different board, I doubt it is the CPU but this might put your mind at ease and remove one of the possible problems. Also, if you've tried all these things and are COMPLETELY stumped try physically removing the CMOS battery for a while, then replace it and try all this again ... and once again doing all this outside of the case. Goodluck.