New, secondary drive disappears after wakeup from sleep mode

Joined
Feb 6, 2003
Messages
831
So I've swapped from my Hitachi 2TB hard drive to 6TB Toshiba. Drive is gone as soon as I wake it up from sleep(Windows 10) and returns every time I reboot. I'm on a replacement after returning the first one, and this one does the same thing, so it's not likely a bad drive. Swapped out SATA cable, no change. I can put my Hitachi back in and it's always there. Hot swap is disabled in BIOS, as I read that could be a possible issue, but it's always been set that way with the old drive. Any ideas before I move on to another brand?
 

auntjemima

Supreme [H]ardness
Joined
Mar 1, 2014
Messages
7,256
If you go to disk management when the drive disappears, is it still there at least? Or in device manager?
 

likeman

Gawd
Joined
Aug 17, 2011
Messages
764
seems very odd, maybe try enabling hot swap

always make sure Fast start-up is disabled in Classic power options (wish Microsoft would remove it, causes loads of problems because a shutdown is a Hybrid hibernate shutdown when fast start up is ticked)
 

Zedicus

Gawd
Joined
Nov 2, 2010
Messages
745
Disable sleep. I don't understand why anyone with an ssd still has sleep enabled. Boot times are maybe 5 seconds now.
 

Zepher

[H]ipster Replacement
Joined
Sep 29, 2001
Messages
18,149
Two Toshiba drives doing it, and the Hitachi working fine, I would swap brands.
 
Joined
Feb 6, 2003
Messages
831
Disable sleep. I don't understand why anyone with an ssd still has sleep enabled. Boot times are maybe 5 seconds now.
That really doesn't solve the issue now, does it? I just don't need my to run my PC when not using it for a period of time.......simple enough. I used to run the water the whole time I was brushing my teeth as well...........

That said. I put the drive in my HTPC and it wakes out of sleep no problem, so must be a mobo issue. Current BIOS' are beta, so waiting for the next final release. I have a WD Black arriving today, we'll see if it plays nice like the Hitachi I've been running for a few years with no issue.
 

Zedicus

Gawd
Joined
Nov 2, 2010
Messages
745
set a scheduled task to shutdown after 15 min inactivity. when you want to use the PC, hit the power button instead of the enter key, or config bios to power up with keyboard.

sleep, standby, hibernate, all suck.
 
Top