Need serious help: No sound after installing Sound Blaster ZxR to new PC

Happy Hopping

Supreme [H]ardness
Joined
Jul 1, 2004
Messages
7,026
I caught the Nvivida control panel is goofing around w/ the HMDI audio setting, so last night I disable that nvivida audio as well, so far, it works
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
31,873
I caught the Nvivida control panel is goofing around w/ the HMDI audio setting, so last night I disable that nvivida audio as well, so far, it works
you just disabled it?! it had been suggested several times, by myself on the 6th...
hopefully thats it.
 
  • Like
Reactions: travm
like this

travm

[H]ard|Gawd
Joined
Feb 26, 2016
Messages
1,253
One thing I've seen with my Z is Windows has a "really" annoying habit of changing my default output device to my NVIDIA HDMI connection for whatever reason. Make sure the default (and preferred) output device is "Speakers (Sound Blaster ZxR)". I recommend doing this through Control Panel->Sound so you can manually set the preferred output device.

The fact you are getting audio at boot means the sound card is connected correctly, and it's likely audio is getting re-routed somewhere else after startup. It's also possible (though unlikely) that some programs may be overriding the audio output device; for testing just use the built in audio output utility from the Sound Blaster Pro Studio.
So windows does something, and you blame your soundblaster?
 

Happy Hopping

Supreme [H]ardness
Joined
Jul 1, 2004
Messages
7,026
You got me. I totally miss that. In the old days, when I install an older driver of nvidia, they allow me the option of NOT to install the other stuff, such as their audio, so I just grab the basic driver back a no. of yr. ago in the old PC.

This new PC, when I download the nvidia latest driver, it doesn't give me that option. I totally forgot they screw around w/ my audio too.

Coincidentally, today I finish off putting together this new PC, w/ a good part of it : scratch build
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
31,873
You got me. I totally miss that. In the old days, when I install an older driver of nvidia, they allow me the option of NOT to install the other stuff, such as their audio, so I just grab the basic driver back a no. of yr. ago in the old PC.

This new PC, when I download the nvidia latest driver, it doesn't give me that option. I totally forgot they screw around w/ my audio too.

Coincidentally, today I finish off putting together this new PC, w/ a good part of it : scratch build
i think with the new nvidia driver you click custom and then you can untick the audio.
 

grumperfish

Weaksauce
Joined
Apr 19, 2014
Messages
91
I've disabled the audio install in the driver and Windows 10 will sometimes install it anyways, so it's better to just disable the Nvidia audio device(s) in Windows directly if it's not being used.
 
Top