Need Help with Playstation 5 and PFSense

kamikazi

Gawd
Joined
Jan 19, 2006
Messages
921
I can not for the life of my to get my PS5 to work correctly with PFSense. I've had a PS4 since that launch and have never had an issue doing anything I want with it while using pfsense. I don't game against others or use chat or anything like that. I've always been able to go to the store and download whatever apps I want and get to anything I want. With the PS5 on the same network, I get messages all over the place about not being able to connect to the server, connections timing out, etc. I can't even download the youtube TV app because when I do to media, I can't search, it insta-fails. I've checked the Internet settings on both the PS4 and PS5 and they both showed NAT 3. I've searched quite a bit and understand this is not good, but like I said, I've never had any of this kind of issue with the PS4.

To fix this on the PS5, I've given it a static IP address and forwarded all the ports that have been brought up (TCP/UDP 80, 443, 3478-3480) which did nothing. Then I also went in and set Outbound NAT to hybrid mode and allowed the PS5 to communicate by adding the IP. This got me to NAT 2, but I still have the same issues. Finally, I followed the advice shown in this link: https://www.tweaking4all.com/network-internet/pfsense-strict-nat-xbox-one/ (this involves using restricted UPNP and NAT-PMP as well as hybrid mode Outbound NAT) which again got me to NAT 2 with similar issues, albeit, a few more things opened up, like I could see more available media, but still couldn't search. At this point, I thought maybe there was a problem with the PS5 OS, so I wiped it and started over. Same issues. So, I then thought maybe my PS5 is just screwed. I hooked it directly to my modem and got NAT 1 and everything worked. I put it back behind the pfsense firewall and I'm back to square 1 with NAT 2 and all kinds of stuff blocked. Anyone have any ideas on how to fix this?

Something that shouldn't matter but now I question is: I'm using my firewall as my DNS and I don't have a secondary DNS defined.

Edit: Here is actually a very good video tutorial that shows all the steps I've taken (not my video):
 
Last edited:
Top