My Linksys router is making a buzzing noise.

Joined
Mar 9, 2011
Messages
2
My linksys router would stop working when a buzzing noise was made.
It worked for a little bit but then the power light would flash and the buzzing would start.
I took it apart and took a picture of the whole board and then narrowed it down to pieces on the board. I took a picture of the two identical pieces and wonder if its something that needs to be soldered or if I could replace the parts. Or if its a major part of the power supply thats fried and don't waste my time. So the picture links are below if you can give me info that would be great.
http://img222.imageshack.us/f/dsc02153v.jpg
http://img228.imageshack.us/f/dsc02154h.jpg
 
Last edited:

ghost6303

2[H]4U
Joined
Jul 24, 2004
Messages
2,291
what model is it? if its cheap, just replace it.

in the second picture, those two black pieces with the 3 wires looping thru them are called ferrite beads or coil chokes. they filter high frequency signals in the circuit like switching noise. they dont really ever "fail". the reason they are making noise is probably because another component is introducing a lot of noise and they are working hard (or maybe it hit just the right resonant frequency). it could be a failing power supply, because one of them looks like its filtering the GND circuit and one is on the V+ circuit.
 

hawk82

[H]ard|Gawd
Joined
Oct 2, 2001
Messages
1,471
I had this problem a long long time ago with a Linksys BEFSR41 router. I simply returned it to the store, since the unit was brand new and still under the store return policy. If your router isn't store returnable, you could contact Linksys for warranty repair/replacement. Outside of that, most routers are very inexpensive and have become basically throwaway devices. You could buy a new one, probably one with more features than your current router has.
 

Chevelle

Limp Gawd
Joined
Jan 21, 2004
Messages
260
It looks like, in the first picture, the capacitor is bulging up.It should be flat on top.
 
Joined
Aug 21, 2012
Messages
1
I know this thread is over a year old at this point but I was searching for the same problem and ran across it. I have seen many posts out there about similar problems and many suggestions but no definitive answers or others' actual experiences attempting to fix the problem. There must be others out there looking for answers too.

Anyway, I have a WRT54G v2 that was doing the exact same thing. The choke coils ("ferrite beads") as mentioned before were vibrating at an audible frequency. As ghost6303 mentioned, there is nothing wrong with the choke coils themselves, rather another component is generating some sort of stress on the coils which causes them to function other than expected.

Some have suggested replacing the power supply unit. I have tried three different PSUs to no avail.

I saw mentions on other forums of using some sort of glue/RTV/enamel on the torroid choke (doughnut with copper wire wrapped around further down on the board) so I though maybe I could do the same to the ferrite beads. However, holding the wires within the bead still by hand stopped the buzzing, but still allowed a high pitch squeal. I decided that the glue idea would be messy and probably not fix the high pitch noise. Also, I would rather correct the root cause than try to cover up the symptoms.

Upon further inspection of the board, I noticed that the capacitor immediately downstream from the beads was extremely hot to the touch. It is a 25v, 220uF. I tore apart an old BEFSR41 I had and found a capacitor on that board that matched the specifications of the suspected problem cap in the WRT. Soldered it in and no more buzzing and the cap doesn't get hot. Easy fix; only required minimal soldering skills.

It makes sense that replacing the PSU made no difference since it had nothing to do with the problem.

someonetesting, I used the picture you took of your board to show where the problem was and what I replaced.


http://img820.imageshack.us/img820/4724/dsc02153v1.jpg

I'm sure the capacitor would have eventually failed, but probably not before my head exploded from the annoyance of the noise! On a side note, I soldered the "bad cap" back into the BEFSR41 and it didn't cause any buzzing in the choke coils in it. Possibly because the BEFSR41 operates at 9V instead of 12, causing less stress on the capacitor.
 
Last edited:

dashpuppy

Supreme [H]ardness
Joined
May 5, 2010
Messages
6,163
Replace your psu, those are chokes. it should use a standard 12@1 amp psu..
 
Last edited:
Top