Move Dialog Buttons in Nautilus Back to the Bottom of the Dialog

MWM

n00b
Joined
Feb 14, 2017
Messages
13
Does anyone know how to move dialog buttons in Nautilus to the bottom of the dialog?

I am using Arch Linux, with Xfce as my desktop environment. Thunar is the default for this DE, but I have Nautilus set as my file manager (I like the search function). Recently, the 'Cancel' and 'Save' buttons in save dialogs from Nautilus (such as when downloading a file) have been moved from the bottom of the dialog to the top. My muscle memory directs me to the bottom of the dialog. While I obviously can just retrain myself, I would prefer to have the buttons where I am used to them being.

I found this post after the same goal:
https://askubuntu.com/questions/1031665/move-gnome-file-dialog-buttons

However, the solution did not work for me. I installed the GNOME Settings Daemon with "sudo pacman -S gnome-settings-daemon" and the command
Code:
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader':<0>}"
was accepted, but made no difference (maybe because I am not using GNOME?).
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
8,992
Does anyone know how to move dialog buttons in Nautilus to the bottom of the dialog?

I am using Arch Linux, with Xfce as my desktop environment. Thunar is the default for this DE, but I have Nautilus set as my file manager (I like the search function). Recently, the 'Cancel' and 'Save' buttons in save dialogs from Nautilus (such as when downloading a file) have been moved from the bottom of the dialog to the top. My muscle memory directs me to the bottom of the dialog. While I obviously can just retrain myself, I would prefer to have the buttons where I am used to them being.

I found this post after the same goal:
https://askubuntu.com/questions/1031665/move-gnome-file-dialog-buttons

However, the solution did not work for me. I installed the GNOME Settings Daemon with "sudo pacman -S gnome-settings-daemon" and the command
Code:
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader':<0>}"
was accepted, but made no difference (maybe because I am not using GNOME?).
If you're using Xfce, you're not using Gnome obviously. You might have to make your own custom theme in order to achieve this: http://www.fifi.org/doc/gnome-users-guide/html/gnome-users-guide/C/custom.html
 

MWM

n00b
Joined
Feb 14, 2017
Messages
13
If you're using Xfce, you're not using Gnome obviously. You might have to make your own custom theme in order to achieve this: http://www.fifi.org/doc/gnome-users-guide/html/gnome-users-guide/C/custom.html
Thank you for your prompt reply. An interesting idea, given that Nautilus does respond to the Xfce Appearance preference tool for changing themes. However, I could not find anything to change button placement there.

I did find by launching "xfwm4-settings" (or clicking "Window Manager" in the "Settings" menu of Xfce) I can access a "Button layout" settings area. In this, I can change the order of title bar objects (title, minimize, maximize, close) and Nautilus does respond. Alas, this does not seem to have any options for buttons pertaining to dialog boxes.

Reading here:
https://developer.gnome.org/gtk3/unstable//GtkSettings.html#GtkSettings--gtk-dialogs-use-header
explains how the property modified in the command I tried determines "Whether builtin GTK+ dialogs such as the file chooser [...] will use a header bar at the top to show action widgets, or an action area at the bottom". This certainly is what I want to change. It also mentions that this property will not affect dialogs that use "GtkDialog directly". Perhaps in Xfce the Nautilus dialogs are using GtkDialog directly; although this speculation lacks detailed understanding on my part. I had never herd of GtkDialog before now.

This page:
https://simon.shimmerproject.org/2020/01/14/xfce-4-14-maintenance-and-4-15-updates/
mentions "packing the dialog’s action buttons in the action area at the bottom of the dialog (vs. the standard GtkDialog behavior of packing them in the GtkHeaderBar". Which means that I am fighting against the default behaviour of GtkDialog.
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
8,992
Thank you for your prompt reply. An interesting idea, given that Nautilus does respond to the Xfce Appearance preference tool for changing themes. However, I could not find anything to change button placement there.

I did find by launching "xfwm4-settings" (or clicking "Window Manager" in the "Settings" menu of Xfce) I can access a "Button layout" settings area. In this, I can change the order of title bar objects (title, minimize, maximize, close) and Nautilus does respond. Alas, this does not seem to have any options for buttons pertaining to dialog boxes.

Reading here:
https://developer.gnome.org/gtk3/unstable//GtkSettings.html#GtkSettings--gtk-dialogs-use-header
explains how the property modified in the command I tried determines "Whether builtin GTK+ dialogs such as the file chooser [...] will use a header bar at the top to show action widgets, or an action area at the bottom". This certainly is what I want to change. It also mentions that this property will not affect dialogs that use "GtkDialog directly". Perhaps in Xfce the Nautilus dialogs are using GtkDialog directly; although this speculation lacks detailed understanding on my part. I had never herd of GtkDialog before now.

This page:
https://simon.shimmerproject.org/2020/01/14/xfce-4-14-maintenance-and-4-15-updates/
mentions "packing the dialog’s action buttons in the action area at the bottom of the dialog (vs. the standard GtkDialog behavior of packing them in the GtkHeaderBar". Which means that I am fighting against the default behaviour of GtkDialog.
I also know nothing about theming Nautilus but since it's open source you should be able to modify and compile your own version of it. I would start to Google that if the issue is so pressing for you.
 

drsudo

n00b
Joined
Feb 1, 2021
Messages
1
I haven't tested this with Nautilus specifically, but I was irked by this with some other applications (eg Firefox, Inkscape). I found this solution:

Open "XFCE Settings" > "Xfconf Settings Editor" > "xsettings" and click the "+ Add" button. In the dialog enter "Gtk/DialogsUseHeader" as a boolean and set it to false. I didn't have to restart anything. It just went back to "normal" right away.

I found this solution after reading https://gitlab.xfce.org/xfce/xfce4-settings/-/issues/235 I might take a stab at making a PR for that issue because I would really like to have it disabled. I'm not opposed to placing things in the title bar (and sometimes like that it is a better use of space), but I don't like changing such well established UI patterns when there is no real benefit.

Hope that helps.
 
Top