Mouse LED's Still On After Shutdown On ASRock Z390 Phantom Gaming SLI/ac Mobo....

Discussion in 'Motherboards' started by Sithtiger, Dec 27, 2018.

  1. Sithtiger

    Sithtiger [H]Lite

    Messages:
    70
    Joined:
    Jun 23, 2016
    Could someone help me out here on how to turn off my mouse LED's after my PC has been shut down, please? I have an ASRock Z390 Phantom Gaming SLI/ac mobo. I don't have "Wake On Lan" enabled for mouse or keyboard. I don't want my cat turning my PC on while it covered with a towel (to keep dust off when not in use). I've tried enabling Deep Sleep option in CPU configuration in the UEFI. I've enabled CPU C4 - C5. I don't see C7. I've also plugged my mouse into a different USB port. Nothing works. I know if I turned the PSU off that'd do it, but that's also the quickest way to wear out a PSU switch too. I know there's got to be a way to do this.
    So, I don't care about charging devices while the PC is off. I just plug them directly into my surge suppressor. Thanks in advance.
     
  2. SvenBent

    SvenBent 2[H]4U

    Messages:
    2,485
    Joined:
    Sep 13, 2008
    cpu power options only effect the cpu.. nothing system wise so doing any thin C is irrelevant. wake on lan irrelevant.


    You might want to see if you can change your usb to go to +5v instaed of beeing powered from +5vsb
    wake from kb/mouse etc


    Try looking at page 81 of your manual i believe it pretty much stated there
     
  3. iwhocorrupts

    iwhocorrupts [H]Lite

    Messages:
    127
    Joined:
    Dec 30, 2012
    Deep Sleep should have done the trick. May not be possible to cut USB power on your board.
     
  4. Araxie

    Araxie [H]ardness Supreme

    Messages:
    6,331
    Joined:
    Feb 11, 2013
    just disable Windodws fast boot and that's all..

    Since windows 8.1 windows use a hybrid-hibernate/shutdown technique to help with the boot process (doesn't affect restart).. one of the side effects of that method is the issue you are facing, (overall with illuminated keyboard/mice..). so the way to prevent this happen is by disabling fastboot in power management options.
     
    Sithtiger likes this.
  5. Sithtiger

    Sithtiger [H]Lite

    Messages:
    70
    Joined:
    Jun 23, 2016

    I found a solution. I believe this will work with most if not all motherboards too regardless of brand or generation. There are many ways to get to this (well more than three, but here are three easy ways). Anyway, try method #1. Go to Cortana search and type in Power and Sleep. You'll see the Power icon. Click on it and in the Settings window that pops up, click on "Additional Power Settings" (under Related Settings) on the right side. The Power Options window will come up. On the left side under "Control Panel Home", click on "Choose What the Power Buttons Do". Now, the new window that comes up has a setting you want to disable called "Turn On Fast Startup". If it's checked (which it probably is), you'll want to uncheck it. If it's greyed out, simply click "Change Settings That Are Currently Unavailable" in blue and then uncheck "Turn On Fast Startup" and click Save Changes at the bottom.
    Method #2 Click the Start Button (The Windows Icon in the bottom left-hand corner) and then click "Settings" which is the Gear icon. Then click "Power and Sleep" on the left side of the window. Then just follow the rest from the 1st method, because it's exactly the same way.
    Method #3 Go to Cortana search and type in Power. There should be the Best Match at the very top called "Choose a Power Plan". Click that and in the window that pops up, click on "Choose What the Power Buttons Do" on the left-hand side. Then click on "Turn On Fast Startup" to uncheck it. If it's greyed out, just click on "Change Settings that are Currently Unavailable" at the top in blue, then uncheck Turn on Fast Startup and then click Save.
    These are all different ways to get to the same solution. It should be noted that if you wish to charge devices (like phones) via USB when the PC is shut down, you will no longer be able to do that if disable Turn on Fast Startup.

    Sorry, I found this solution almost immediately after I posted it...figures. Then, got sidetracked trying to explain why. The reason I wrote such a lengthy response on how to do the same thing 3 different ways was because before I found the answer, most posts had to do with the BIOS/UEFI, which I would have said that as well, but in this case, is wrong....for my situation anyway.
     
  6. Sithtiger

    Sithtiger [H]Lite

    Messages:
    70
    Joined:
    Jun 23, 2016
    I could see how that might have worked, but not this time. Thanks anyway SvenBent!

    Yeah, I thought that as well, but it has to do with disabling Windows Fast Boot, found in Power Options. Thanks for your response though!

    Yes, Araxie, you are correct! I found this earlier, but thanks. Had I not, you would have led me to the answer. I can't believe this was a Windows situation?!? But it was.
     
    Araxie and SvenBent like this.
  7. Jandor

    Jandor n00bie

    Messages:
    38
    Joined:
    Dec 30, 2018
    I had that problem with some boards since Windows 95. Sometime there is no solution. The board powers the usb port and you're screwed. In that case, find some PCI usb board and put your mouse on it.
     
  8. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,768
    Joined:
    Oct 4, 2007
    That is weird, considering the computer is 100% powered off. (It is not in hibernation mode, it is fully off.) That said, it worked so good to know.
     
  9. Araxie

    Araxie [H]ardness Supreme

    Messages:
    6,331
    Joined:
    Feb 11, 2013
    since windows 8, machines aren't entirely powered off.. they are in a deep sleep state for fast boot, in a 100% UEFI compatible system, the OS pre-loaded cache it's stored in GPU and system RAM for a faster boot operation, the downside of that, is +5V and +3.3V work together with +5SB powering all peripheral even when turned off, that's why some keyboards and mice may remain with the lights turned on.. and some will remain off but pressing one key will turn on the lights. it really depend on the motherboard behavior.
     
  10. Nenu

    Nenu [H]ardened

    Messages:
    18,282
    Joined:
    Apr 28, 2007
    There used to be a USB +5V power option that could be enabled in the bios when the machine was powered off
    Perhaps you have this.
     
    ManofGod likes this.
  11. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,768
    Joined:
    Oct 4, 2007
    No, they are 100% powered off. If I pull the power cord, wait a few seconds, plug it back in and boot it up, it still boots equally as fast because of hybrid shutdown mode. Even hibernation mode is fully shutdown. Deep sleep and other sleep modes are not fully shut off though.