Minecraft server

Soarin

2[H]4U
Joined
Jul 23, 2010
Messages
2,489
Hey guys me and my friend started playing minecraft and I read through a lot of pages saying how to setup a server, but ever time I try it fails. I watched youtube videos and nothing.

I had hamachi and nothing. I turned off firewalls tried to port forward and nothing.( I do not think i did that right)

Server ip is 5.9.52.21 on the default port
I edited the server properties file list and set it to offline. Entered my IP. started the client and the host pc that is running the client can see the server but this pc cannot.

Any help?
 
If the minecraft client running on the host machine can connect, but one running on another machine can't connect, the most likely answer is that the port forwarding isn't set up right. I won't be around anymore tonight but I'm guessing people will suggest looking up a guide for port forwarding on your specific router, and may want to know which router you have. Remember if it asks you for a server ip address somewhere, you have to go to the start menu, enter cmd, enter ipconfig, and use the ipv4addres. Do this on the server obviously.

Good luck.
 
If the minecraft client running on the host machine can connect, but one running on another machine can't connect, the most likely answer is that the port forwarding isn't set up right. I won't be around anymore tonight but I'm guessing people will suggest looking up a guide for port forwarding on your specific router, and may want to know which router you have. Remember if it asks you for a server ip address somewhere, you have to go to the start menu, enter cmd, enter ipconfig, and use the ipv4addres. Do this on the server obviously.

Good luck.


I did all that. what I think I am having issues on is port fowarding, which i followed a guide on the website. I know the inbound port port is the 25565 but what would be the private port? The same thing?

Okay I went into firewall settings (XP PRO) Add program>Minecraft>change scope>port name port number 25565 TCP.
Then went into Hamchi settings within the firewall menu and allowed all services to be ran and added minecraft and external port and internal port of 25565. But firewall is disabled on this pc anyways
 
Last edited:
check. Router is setup for port forwarding (virtural servers on belkin n150) inbound and outbound port both same and TCP&UDP is selected. being forwarded to 192.168.2.8. But would I need to put the Hamachie address in here instead of the IPV4? Or we can cut hamachi out and just use the IPV4 because it is just the 2 of us offline mode.
 
okay gpt it working with this pc the xp pro as server. trying the windows 7 machine next
 
I may have figured it out. The win 7 machine is connected to network wireless...


nope same issue
I switched to the exe for the win 7 machine and used compatablity mode and nothing
 
Last edited:
Anyone have a fix? Been at this for 2 days
I can get a windows xp server running and have the windows 7 machine see it BUT the xp machine has only 2 gigs memory
 
If you have Hamachi installed, it's possible you need to bind the server to the right IP address..

in server.properties, the server-ip= line should be your hamachi's interface IP if your going to be connected via hamachi or your local interface IP if you're going through the normal internets. I think.. I've never had a problem with having a minecraft server work..
 
Last edited:
If you have Hamachi installed, it's possible you need to bind the server to the right IP address..

in server.properties, the server-ip= line should be your hamachi's interface IP if your going to be connected via hamachi or your local interface IP if you're going through the normal internets. I think.. I've never had a problem with having a minecraft server work..

I have done that. I tried Hamchi and it still wasn't working even with my ip address in the server properties file. For now the server will be the xp machine because we decided to buy more ddr2 800 for the system and put 7 on it.


If it's just the two of you why use Hamachi? Just setup a vanilla server and turn on the whitelist.
Tried it. Didn't work going from 7 to xp but xp to 7 does.
 
Back
Top