mce and audio from .mkv/.ogm

dualblade

Supreme [H]ardness
Joined
Nov 19, 2000
Messages
4,180
i'm using haali's media splitter for mkv/ogm with multiple audio tracks. it almost works well in media center, except for the language priority option. in other video players it works fine, but when i set my default audio language to jpn, it just ignores it and uses the first one in the file (usually english). i know this is a pretty specific question, but i'm hoping someone has come across this and can tell me if either there's a setting i can change or a different media splitter to do the job

thanks
 
Joined
Feb 25, 2004
Messages
564
dl the mastroka tool pack thingy, and make sure that the jpn streams are labeled correctly, if at all. if you are never going to listen to the english track just get rid of it completely so that the only audio track you have is the jpn one. re-authoring .mkv's is so easy, just select what you want to include and then it just combines them into the .mkv. i'm not at my main rig right now so i don't have all the details but remember google is your friend.
 

i5hawn

n00b
Joined
Dec 7, 2005
Messages
17
beforewarned that the matroksa pack will fubar your TV functionality. it can be resolved by disabling all the audio codecs, then reenabling the ones you need. it differs for everyone but just a heads up. you'll get an error message saying tv application has failed and media center will restart but it won't resolve the problem.
 

dualblade

Supreme [H]ardness
Joined
Nov 19, 2000
Messages
4,180
th3 godfather said:
dl the mastroka tool pack thingy, and make sure that the jpn streams are labeled correctly, if at all. if you are never going to listen to the english track just get rid of it completely so that the only audio track you have is the jpn one. re-authoring .mkv's is so easy, just select what you want to include and then it just combines them into the .mkv. i'm not at my main rig right now so i don't have all the details but remember google is your friend.

is there a way to batch language extract? i'd be perfectly happy not wasting hd space on audio tracks i won't use but if i have to go file by file that will take forever
 

CrimandEvil

Dick with a heart of gold
Joined
Oct 22, 2003
Messages
19,670
Using the Haali's pack myself, anyone have problems with it not rendering subtitles every now and then?
 

dualblade

Supreme [H]ardness
Joined
Nov 19, 2000
Messages
4,180
except for this one issue, i've found that the combined community codec pack is awesome. doesn't install tons of stuff - just ffdshow and a few filters. ffdshow can decode divx and xvid now, so you don't need the external decoders. it's a pack that was made by one of the anime sub groups to combat the large packs that often have conflicting codecs and settings. it includes haali and mpc so it pretty much takes care of everything

before installing, just make sure to remove any other codecs/codec packs you might have installed previously
 
Joined
Feb 25, 2004
Messages
564
i5hawn said:
beforewarned that the matroksa pack will fubar your TV functionality. it can be resolved by disabling all the audio codecs, then reenabling the ones you need. it differs for everyone but just a heads up. you'll get an error message saying tv application has failed and media center will restart but it won't resolve the problem.

that problem doesnt exist for me....

In regards to getting rid of the languages you dont use, go wild! here's how you do it:

1. download the mastroka pack, and mkvtoolnix
2. launch mkvmerge GUI
3. add an input file (the .mkv that you are editing). notice the tracks that appear. simply deselect the tracks that you do not wish to have
4. click on each of the tracks and you will see a language option. in the case of anime, change the audio language to jpn and the subtitle text to eng, or just make them the default tracks.
5. edit the output filename to your likings
6. click "start muxing" at the bottom of the window
7. there you have it, your new .mkv with only the streams you want as well as the language option correctly selected. now go into your haali media splitter and set your default audio and subtitle languages and you'll never have to right click in the taskbar to select teh right tracks (perfect for mce)

Now to get .mkv's to work properly in MCE you need to do a reghack, which i've pasted below. Add the following to a .txt file, save it as mkv.reg, then double click it

START COPY BELOW THIS LINE

REGEDIT4

[HKEY_CLASSES_ROOT\.ogg]
"PerceivedType"="audio"
"Content Type"="audio/x-ogg"

[HKEY_CLASSES_ROOT\.ogm]
"PerceivedType"="video"
"Content Type"="video/x-ogg"

[HKEY_CLASSES_ROOT\.m2v]
"PerceivedType"="video"
"Content Type"="video/mpeg"

[HKEY_CLASSES_ROOT\.mka]
"PerceivedType"="audio"
"Content Type"="audio/x-matroska"

[HKEY_CLASSES_ROOT\.mkv]
"PerceivedType"="video"
"Content Type"="video/x-matroska"

[HKEY_CLASSES_ROOT\.mp4]
"PerceivedType"="video"
"Content Type"="video/mp4"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.ogg]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.ogm]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.m2v]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mka]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mkv]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Multimedia\WMPlayer\Extensions\.mp4]
"Runtime"=dword:00000007
"Permissions"=dword:0000000f
"UserApprovedOwning"="yes"
 
Top