LSI 9361-8i and HP SAS expander 468406-B21 Issues Enumerating Drives

corbis

n00b
Joined
Dec 22, 2013
Messages
4
Hello All,

I am building my Dream PC that will also serve as a storage box for the house. I've gone all out on this build and my parts list includes:

1. Intel Hexacore i7 4960X Extreme (LGA2011) Intel i7-4960X Extreme Edition LGA 2011 Processors BX80633I74960X

2. Corsair Dominator Platinum 64GB 2133MHZ DDR3 (8x8GB) Corsair Dominator Platinum 64 GB (8x8 GB) DDR3 2133MHz (PC3 17066)

3. ASUS Rampage IV ExtremeASUS Rampage IV Extreme LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 Extended ATX Intel Motherboard

4. EVGA GeForce Titan w/ 6GB GDDR5 each, in SLI(2x) EVGA EVGA GeForce GTX TITAN SuperClocked 6GB GDDR5 384bit, Dual-Link DVI-I, DVI-D, HDMI,DP, SLI Ready Graphics Card Graphics Cards 06G-P4-2791-KR

5. Corsair 1200W AXI series PSUCorsair Professional Series AX 1200 Watt Digital ATX/EPS Modular 80 PLUS Platinum (AX1200i)

6. Pioneer (BDR-208DBK) BD/DVD writer Pioneer BDR-208DBK 15x Internal Blu-ray BD/DVD/CD

7. NZXT IO PanelNZXT Aperture M Internal 5.25-Inch Mesh Card Reader with 2x USB 3.0 (8c-aper000-w0b)

8. NZXT Illumination LED & Controls NZXT Technologies 5.25-Inch Hue RGB LED Color Changing Controller (8c-hue0000-00b)

9. 2x Samsung 840 EVO 1TB SSD's RAID 0 (boot drive)Samsung Electronics 840 EVO-Series 1TB 2.5-Inch SATA III Single Unit Version Internal Solid State Drive MZ-7TE1T0BW <--- going to be RAID 0 on 12GB/s LSI Raid Card.

10. 6x 7200RPM Seagate 3TB HDD's in RAID6 Seagate Barracuda 3 TB HDD SATA 6 Gb/s NCQ 64MB Cache 7200 RPM 3.5-Inch Internal Bare Drive ST3000DM001

11. Corsair H100i CPU Water cooling,Corsair Hydro Series Extreme Performance Liquid CPU Cooler H100i

12. Logitech Logitech MK710 Wireless Desktop Mouse and Keyboard Combo

13. Seiki Digital SE39UY04 39-Inch 4K Ultra HD 120Hz LED TV

14. HP SAS/SATA Expander 468406-B21, HP 24 Bay 6Gb SAS Expander Card

15. LSI MegaRAID SAS 9361-8i (LSI00417) PCI-Express 3.0 12GB/s SATA/SAS RAID CARD, RAID 0, 1, 5, 6, 10, 50, 60 supports 128 drives with SAS expander



At present, I am at the point where I've gotten windows installed, booting from my 2x 1TB Samsung SATA SSD's RAID 0, and I'm now trying to configure some arrays on my Six 3TB Seagate Baracuda's and 8x 1.2TB HP SAS 10K drives. The issue I'm seeing is the drives that i connect to the HP SAS expander dont get enumerated on my RAID controller in the MegaRAID BIOS. Only the drives on one of the ports (Port 9C) on the SAS Expander seem to lead to enumerated drives, which is very strange to me right now.

I am using the ICY Dock 5in3 SATA backplanes (2 of them) which hold 10x 3.5" drives, and I only have 6 of the 10 slots populated right now. I purchased these at newegg

So i have 2x: ICY DOCK MB455SPF-B 5 in 3 SATA I, II & III Hot-Swap Internal Backplane Raid Cage Module

and 2x: ICY DOCK ToughArmor MB994SP-4S Full Metal 4 x 2.5" SAS/SATA 6Gb/s SSD/HDD Hot Swap Mobile Rack Backplane Cage Module for 5.25" Bay (Fits 7, 9.5, 12.5, 15mm height drive)

But I can only get the drives connected to port 9C to be enumerated by my RAID controller. Please tell me that I'm not an idiot, and I am going to be able to use these Backplanes with this card :( It seems that my SAS card is definitely designed to connect to backplanes with an SFF-8087, but I have the SFF-8087 connectors -> 4x 7PIN SATA cables, and was planning to use those off the SAS expander card and connect them to the individual slots on the back of the ICY DOCK backplanes.

Anyone have similar experience or can tell me what I am doing wrong?

When i look at the drives connected to all ports except 9C in MEGARAID BIOS, I see:

P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB
P1:01:00 READY : 1.09 TB

(I will see the above for all my 1.2TB 10K SAS drives, unless i connect one set to PORT 9C)

And i would see the 3TB drives the same way, unless they are also connected to 9C.
 

corbis

n00b
Joined
Dec 22, 2013
Messages
4
Update to this...

It looks like I can create Logical Drives within the MegaRAID utility in windows, but I cannot for the drives connected to the Expander on a non PORT 9C connection through the MegaRAID BIOS. I imagine this is normal...
 

mp3turbo

n00b
Joined
Dec 25, 2013
Messages
16
I might be completely off, but I'm really convinced I saw issue like you describe related to either your adapter or HP enclosure.

The solution was to upgrade firmware. No warranty on that, please, but you can check firmware on your RAID/HP extremely quickly and compare it to latest version available on web. Wouldn't hurt.
 

corbis

n00b
Joined
Dec 22, 2013
Messages
4
Yup, got it all working...

This was a stupid question, but it may actually come in handy for someone else later?

I have my two Raid groups online Raid 1 with 8x 1.2TB 10K Drives (4.36TB Useable) and RAID 6 with 3TB 7.2K RPM drives (10.9TB Useable)
 

corbis

n00b
Joined
Dec 22, 2013
Messages
4
It looks like i have the most recent firmware on my LSI 9361-8i, i just went to download and apply, and i already have the version it was going to apply. (March 2013)
 

kleox64

[H]ard|Gawd
Joined
Sep 21, 2004
Messages
1,467
You should really be using an LSI expander.
 
Last edited:
Top