linux X configure

Discussion in 'Operating Systems' started by nameless_centurian, Mar 26, 2004.

  1. nameless_centurian

    nameless_centurian Gawd

    Apr 4, 2003
    hey, all.

    before i ask this question, i'd like to thank all of you in this community for answering my questions. it is helpful, especially when the HOWTOS don't work for me or i screwed something up.

    it's also fun to read posts and replies and learn, and to answer other people's questions.

    okay... group hug :rolleyes: that we have that out of the way.

    i am beginning to use linux on a more regular basis, now. i found versions of my chat clients and such. and you'll be proud to know that i am in CLI more often than X ;) ...well... that is until my chat clients worked. now i am constantly in X, only i use CLI to get around and do stuff.

    2 questions that i haven't found an answer for because i either don't know the terminology of what i am trying to do, or it just isn't out there in my sight on the net.

    1)how do i set X up so that everything is displayed sharply and such? right now, my X display looks like windows loaded in safe mode with no video no it isn't that bad, but it's not so great. maybe the video driver is configured incorrectly?

    2)i downloaded netscape, and will probably download mozilla as well to replace netscape. anyway, netscape installed fine and runs well.... but i have to launch it from CLI. i don't feel like navigating through CLI to get on the web when i know i could just place an icon or something on the desktop or in the "Start" menu. how do i do this?

    3)okay, a third quesion. some commands in linux are just THERE. you are in your shell, and you type a command like PING. the OS knows where to locate that program no matter what folder you are in.... how can i make other commands do this, such as my AMSN client, i just type "AMSN" instead of navigating to the folder inside of a folder inside of a folder inside of a folder to run it?


    edit: i am running Vector Linux, based on slackware, and ICEWM...if it makes a difference.
  2. eloj

    eloj 2[H]4U

    Dec 31, 2000
    1) Either means you have a font problem or you're running at a too low resolution. Try pressing CTRL+ALT+NUM_PLUS/NUM_MINUS to change the resolution and/or check your /etc/X11/XF86Config-4 file. As for fonts, well there's many How-To's on that, too.

    2) Depends on what window-manager/desktop you're running. Just Icewm.. well, I guess there's a menu-file you can edit. 'man icewm'?

    3) You'd have to add the path to the binary to your PATH environment-variable, or create a link from a pathed directory to the binary.
  3. [H]EMI_426

    [H]EMI_426 2[H]4U

    Feb 19, 2001
    1) Time to look at your /etc/X11/XF86Config. What did you use to initially configure XFree? You can either try editing the file by hand (look at DefaultDepth and the resolution lines for each color depth) or you can try re-running a config tool. You can also try pressing control+alt+numpad plus to see if you can switch to a different video mode.

    2) I don't use IceWM, but chances are good there's some sort of configuration information in your home directory. Look in there for how to add things to the menus, how to put icons where you need them to go, etc. There may be a handy tool to do this for you already, but you'll need to start reading IceWM docs to find out.

    3) Look at the PATH environment variable.That variable determines where the OS looks for executables that match the name you type...Well, the process is a bit more complex than that, but that's a good approximation.

    How you change the PATH variable will depend on your shell. For sh and derivatives, it'll be something like export PATH=$PATH:/new/things/to/add. For csh and derivatives, it'll be something like setenv PATH $PATH:/new/things/to/add. The man page for your shell will tell you how to set environment variables.

    You'll probably want to make the change permanent by setting the PATH var in your shell's rc script.
  4. cloaked

    cloaked Limp Gawd

    Oct 7, 2003
    the menu config file will probably something like ~/.icewm or ~/.icewm/blah
  5. ameoba

    ameoba [H]ardness Supreme

    Jan 9, 2001
    What kind of video card are you running?

    If it's not nvidia or ATI (or you don't really care about 3d), setting up X is pretty simple, just run xf86cfg and save the file to /etc/X11/XF86Config (I don't understand why it defaults to another location...).

    There's also a slackware setup utility, but I can't remember what it's called. Look at the outputs of

    locate setup |grep -i x |grep bin
    locate conf|grep -i x |grep bin
    locate cfg|grep -i x |grep bin

    and see if anything looks promising.