Is there a way to test that a 980 Ti is operating correctly?

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
740
In Grim Dawn, my frame rate seems lower than normal and once in a while the game will pause for a fraction of a second and then continue normally.

Everything looks fine in GPU-Z regarding clock rate, temperature, and fan speed.

If it matters, it is a Gigabyte G1 Gaming. Thanks.
 

Ocellaris

Ginger @le, an alcoholic's best friend.
Joined
Jan 1, 2008
Messages
18,882
Run 3D Mark and compare your results to others.
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
740
Run 3D Mark and compare your results to others.
These are the results. The CPU is an i7-6700k. Nothing is overclocked.

Time Spy: 5469
- Graphics: 5598
- 36.71 FPS
- 31.92 FPS
- CPU: 4841
- 16.27 FPS

Fire Strike: 15058
- Graphics: 18546
- 89.69 FPS
- 73.24 FPS
 

arestavo

[H]ard|Gawd
Joined
Mar 25, 2013
Messages
1,510
How are your CPU temps? A downclock of the CPU because it is getting too hot can account for those pauses (framerate dips, hitching, aka "stuttering").

Also (I'm on a mobile so can't see specs if you have them in your sig) if you are using a SATA drive be sure you update those SATA / motherboard drivers. Some folks with game hitching have solved it by updating.

Also, is your motherboard's BIOS updated? If not, take pictures of your BIOS settings (if needed) and update, then clear the CMOS - sometimes settings get stuck, slowing down your motherboard/CPU and a CMOS clear will fix that. After the CMOS reset be sure to change your BIOS settings back as needed.

Actually, doing a CMOS clear even if your motherboard BIOS is up to date would be a good step to take. Sometimes things get messed up in a BIOS slowing things down/making things unstable, and only a CMOS clear will fix it. (Ran into that problem several times with my main rig).

Have you used Geforce Experience to optimize that game? If so, it likely has things all jacked up. Try step 5 in this guide: Basic troubleshooting steps. Windows clean boot, clean driver install, debug mode, etc. - EVGA Forums

Using that same guide, you might want to try step 2 and do a driver uninstall using DDU in safe mode. Get the latest drivers for your OS after you reboot and install them using CUSTOM and only check Driver and PhysX.
 
Last edited:

Nenu

[H]ardened
Joined
Apr 28, 2007
Messages
19,338
Use MSI Afterburner to monitor temps, GPU use and CPU use (per core).
See which of those is limiting performance.
 

Elf_Boy

2[H]4U
Joined
Nov 16, 2007
Messages
2,386
In Grim Dawn, my frame rate seems lower than normal and once in a while the game will pause for a fraction of a second and then continue normally.

Everything looks fine in GPU-Z regarding clock rate, temperature, and fan speed.

If it matters, it is a Gigabyte G1 Gaming. Thanks.
What is the framerate?

What are you in game settings?

Not that Grim Dawn is super Demanding.

-edit-

Just played for a few minutes.

See sig

I needed to turn aa/af down from 8/16 to 4/8 and enable vsync to get smooth game play. I didnt spend too much time optimising settings.

I have not played in some time and the game has definitely improved and evolved. Maybe time for me to look at it again.

Very pretty good looking game world.
 
Last edited:

Ieldra

I Promise to RTFM
Joined
Mar 28, 2016
Messages
3,543
These are the results. The CPU is an i7-6700k. Nothing is overclocked.

Time Spy: 5469
- Graphics: 5598
- 36.71 FPS
- 31.92 FPS
- CPU: 4841
- 16.27 FPS

Fire Strike: 15058
- Graphics: 18546
- 89.69 FPS
- 73.24 FPS
this is totally fine
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
740
The problem seems to be that Grim Dawn is limiting itself to one CPU core, which is maxing out at 100%. There is an options.txt file where you can set it to utilize all of the CPU cores. This has gotten the framerate much higher. It was apparently being CPU bound.


How are your CPU temps? A downclock of the CPU because it is getting too hot can account for those pauses (framerate dips, hitching, aka "stuttering").

Also (I'm on a mobile so can't see specs if you have them in your sig) if you are using a SATA drive be sure you update those SATA / motherboard drivers. Some folks with game hitching have solved it by updating.

Also, is your motherboard's BIOS updated? If not, take pictures of your BIOS settings (if needed) and update, then clear the CMOS - sometimes settings get stuck, slowing down your motherboard/CPU and a CMOS clear will fix that. After the CMOS reset be sure to change your BIOS settings back as needed.

Actually, doing a CMOS clear even if your motherboard BIOS is up to date would be a good step to take. Sometimes things get messed up in a BIOS slowing things down/making things unstable, and only a CMOS clear will fix it. (Ran into that problem several times with my main rig).

Have you used Geforce Experience to optimize that game? If so, it likely has things all jacked up. Try step 5 in this guide: Basic troubleshooting steps. Windows clean boot, clean driver install, debug mode, etc. - EVGA Forums

Using that same guide, you might want to try step 2 and do a driver uninstall using DDU in safe mode. Get the latest drivers for your OS after you reboot and install them using CUSTOM and only check Driver and PhysX.
I did not check CPU temps before discovering the single core issue mentioned above. The BIOS and motherboard drivers haven't been touched since I put the PC together last fall. I have not used GeForce experience to optimize anything. thanks for all of the suggestions and help.

Use MSI Afterburner to monitor temps, GPU use and CPU use (per core).
See which of those is limiting performance.
GPU temps are good. CPU 0 was pegged.

What is the framerate?

What are you in game settings?

Not that Grim Dawn is super Demanding.

-edit-

Just played for a few minutes.

See sig

I needed to turn aa/af down from 8/16 to 4/8 and enable vsync to get smooth game play. I didnt spend too much time optimising settings.

I have not played in some time and the game has definitely improved and evolved. Maybe time for me to look at it again.

Very pretty good looking game world.
In game setting are everything maxed, and resolution at 2560x1440. Framerates were getting down into the forties.

this is totally fine
Thanks.

What resolution do you play with?
2560 x 1440.
 

arestavo

[H]ard|Gawd
Joined
Mar 25, 2013
Messages
1,510
Glad you got it sorted!

Gotta say that was a weird choice for the game devs to disable multi-thread capability in the config.
 

Elf_Boy

2[H]4U
Joined
Nov 16, 2007
Messages
2,386
Are you talking about this part?

forceSingleProcessorMode = false
maxResourceThreads = 1

I just found it based on your post. I will try 8 and see how it works.
 

Armenius

Fully [H]
Joined
Jan 28, 2014
Messages
22,819
The problem seems to be that Grim Dawn is limiting itself to one CPU core, which is maxing out at 100%. There is an options.txt file where you can set it to utilize all of the CPU cores. This has gotten the framerate much higher. It was apparently being CPU bound.




I did not check CPU temps before discovering the single core issue mentioned above. The BIOS and motherboard drivers haven't been touched since I put the PC together last fall. I have not used GeForce experience to optimize anything. thanks for all of the suggestions and help.



GPU temps are good. CPU 0 was pegged.



In game setting are everything maxed, and resolution at 2560x1440. Framerates were getting down into the forties.



Thanks.



2560 x 1440.
Grim Dawn is still built on the original Titan Quest engine (circa 2006), so any performance issues with modern systems in that game can translate to the new.
Are you talking about this part?

forceSingleProcessorMode = false
maxResourceThreads = 1

I just found it based on your post. I will try 8 and see how it works.
In Titan Quest this change caused more issues than it fixed. It works pretty well up to 4 threads, but physics and animations will start to get funky above that. They could have improved multithreaded syncing in Grim Dawn, but just be aware of this if you run into anything weird.
 

Nenu

[H]ardened
Joined
Apr 28, 2007
Messages
19,338
Thanks to the mention of Grim Dawn here, I checked some reviews and...
Great game, more Diablo :)
It gives me the want to play itch more than the Witcher 3 does oddly.

Its easy to play passively, there is no direct keyboard control just point and click.
You can use keys to access stats, inventory etc but it can all be done via on screen icons.
Great when chilling in front of the TV.
 
Top