Is BitDefender always SLOW?

Rustynuts

[H]F Junkie
Joined
Feb 6, 2003
Messages
10,348
OK, after reading a lot of glowing reviews of BD, I decided to switch after using AVG and ESET. I've ALWAYS run these AV products with others to augment security, like MBAM and Comodo firewall, and in the past superantispyware (not recently as they seem to have gone downhill?). Well immediately after installing BD and putting up with their audacity of removing every other security program, my system has been total CRAP in the browsing speed department. Never had a problem with ESET or AVG running with MBAM professional. Do I shitcan BD or not?
 

xnikx

[H]ard|Gawd
Joined
Oct 25, 2006
Messages
1,730
i just uninstalled bitdefender.
while it does an amazing job of protecting your system, i could not live with the slow down you are speaking off.

not being able to use youtube, because of bitdefender, sucks.

i just made a thread about this myself and others on this forum have suggested eset.
 

Kai

[H]ard|DCer of the Month - February 2014
Joined
May 31, 2005
Messages
1,006
That's interesting because I run Bitdefender with MBAM and it runs just fine. No issues whatsoever. Are you sure the other programs were uninstalled properly? It sounds more like a problem with your systems. I have it on all my systems and it works just splendidly. No slow downs like you're speaking of.
 

xnikx

[H]ard|Gawd
Joined
Oct 25, 2006
Messages
1,730
That's interesting because I run Bitdefender with MBAM and it runs just fine. No issues whatsoever. Are you sure the other programs were uninstalled properly? It sounds more like a problem with your systems. I have it on all my systems and it works just splendidly. No slow downs like you're speaking of.

did a fresh install of windows, everything running fine.
soon as i install bitdefender, chrome goes to shit.

uninstall bitdefender, chrome works fine again.
 

Metraon

Limp Gawd
Joined
Feb 23, 2011
Messages
307
I disabled the widgets and some other things like link scanning and bank account vault.
 

DeChache

Supreme [H]ardness
Joined
Oct 30, 2005
Messages
7,088
That's interesting because I run Bitdefender with MBAM and it runs just fine. No issues whatsoever. Are you sure the other programs were uninstalled properly? It sounds more like a problem with your systems. I have it on all my systems and it works just splendidly. No slow downs like you're speaking of.

I'm in the same boat. I have Bitdefender on my personal systems and don't seem to have performance issues.
 

Yakk

Supreme [H]ardness
Joined
Nov 5, 2010
Messages
5,810
While i liked running BD for a few weeks, unfortunately I had to remove bit defender from all my systems due to slowdowns and various incompatibilities happening. It was costing me a ton of time troubleshooting. Removed it and everything went back to normal. Currently running another AV, which I won't promote, just talking about BD here.
 

cortexodus

[H]ard|Gawd
Joined
Feb 20, 2009
Messages
1,614
Bitdefender has been a performance succubus since its release years ago. I always liked its catch-rate; it seems to be very effective. However, I only ever ran it on storage machines whose entire purpose was pulling data from drives that were suspected of infection. Running it on any kind of machine that intended to actually use for day-to-day things was akin to spinning nickels on a mirror coated in honey. Frustrating, and ultimately a waste of time.
 
Top