Internal error: powerdvd sucks

veedubfreak

2[H]4U
Joined
Dec 10, 2007
Messages
2,070
Ok so i bought this player here.
http://www.newegg.com/Product/Product.aspx?Item=N82E16827136137

I installed the drive and the power dvd hd suite that came with the drive. Every time i try to watch a movie i get an "interal error" 8876086a. I have tried everything from uninstalling everything, reinstalling, anydvdhd, everything is fully updated. I'm seriously about to pull this drive and kill someone with it. What the fuck is going on.

Specs are windows 7 RC 64bit.
nvidia 8500gt with hdim/dvi output
samsung dlp tv using hdmi out from the 8500.
I did a clean install of windows 7 last friday, then installed the powerdvd hd suite and this shit has refused to work from the start.

Media player plays my sd dvds just fine, but no matter what i do i get the internal error and i am completely out of ideas. At this point i'm about read to just return the drive and buy a freaking ps3.
 

Helicopter

Limp Gawd
Joined
Jul 10, 2009
Messages
271
Did you install it as administrator? If not, uninstall it, and then run it as administrator.
 

veedubfreak

2[H]4U
Joined
Dec 10, 2007
Messages
2,070
Ya i did. I got it figured out, finally. Apparently between the time i installed and today there has been a new video driver out for the 8500. When i installed win7 last weekend nvidia.com told me i was up to date.
 

Helicopter

Limp Gawd
Joined
Jul 10, 2009
Messages
271
Glad to hear it is resolved, nothings worse than having a kick ass piece of hardware that doesn't work right.
 
Top