Intermittent Lagging on Xeon E5-2696 V3 QS build

Discussion in 'General Hardware' started by commissioneranthony, Jan 9, 2020.

  1. commissioneranthony

    commissioneranthony [H]ard|Gawd

    Messages:
    1,104
    Joined:
    Jul 2, 2008
    Background:
    I built a 18 core machine 2 years ago to serve as my CAD render workstation. It works great for rendering, but there is this weird irregular errata that happens with the machine. I have been trying to pin point it ever since. It seems to come up every few days.

    machine specs:
    -Xeon E5-2696 V3 QS (it's an engineering sample, latest revision before retail shipment)
    -intel 1.2tb p3600 nvme ssd
    -32gb (4x8gb) PC4-17000 2133mhz ECC samsung hp certified ram
    -quadro p2000
    -silencer 750 psu
    -asrock x99 extreme4 motherboard
    -samsung 305t 2560x1600 lcd
    -dell u2410 lcd
    -windows 8.1 pro

    Problem:
    I will have 40 or so tabs open in the latest firefox, photoshop or Kicad running, and it will lag for about 2-3 seconds on clicking between firefox tabs. There is also distinct line tearing when scrolling down a page of text. Sometimes there is a delay between clicking windows. As you can imagine, there is only so much of this a man can stand before it drives drives him insane.

    The problem seemed to go away after a restart and them come back in a few hours or in a few days. I originally thought it was the quadro, so I used DDU and did a fresh driver install. That would occasionally, help, but the problem would keep coming back.

    I decided to give the system a windows memory test and it came back clean.
    I ran memtest64 and so far it has passed 3 rounds of testing with zero errors.

    I'm picking at straws here. I don't quite know what is causing this problem

    It seems that the ram is indeed ok. I am thinking my GPU might be problematic, but I don't have another gpu even close to the quadro to replace it with (last modern gpu I have is a radeon HD 5400).

    I am thinking of buying another gpu but I fear that the cpu itself may be suspect.

    A few weeks back, I was looking for xeon chips on ebay. One seller mentioned his E5 2696 v3 engineering sample had a "bad memory channel A" I have no idea how he came to this conclusion.
    https://www.ebay.com/itm/123980585136
    Is it possible the integrated memory controller in my xeon is problematic or not finalized?
    Is there anyway to tell?
    If anyone has any input, that would be fantastic.
    Thanks Guys!
     
    Last edited: Jan 9, 2020
  2. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    15,265
    Joined:
    Oct 7, 2000
    try not having 40+ tabs open in firefox or try another browser if you insist on doing that.
     
  3. Deadjasper

    Deadjasper [H]ard|Gawd

    Messages:
    1,752
    Joined:
    Oct 28, 2001
    With that many tabs open it take time for Windows to upload your info to MS.
     
  4. Spartacus

    Spartacus [H]ard|Gawd

    Messages:
    1,948
    Joined:
    Apr 29, 2005
    Agree with pendragon1 that is a ton of open tabs.
    You can't open an insane number of tabs and expect instant response.

    Does not sound like a hardware issue.

    Do what you can to improve performance on Windows itself.

    Clean up temp files, browser caches, defrag, turn off Superfetch, etc.
    Uninstall all crap.... toolbars, hw monitors, OneDrive, Google Sync, etc.

    Look at Taskmanager/Services and try to justify everything that is running.
    If it's not needed, turn it off. (Be careful on OS services that are needed though).

    Do you have iTunes and Apple software installed? That can be a big performance hit.

    Scan with MalwareBytes.

    .
     
    Deadjasper likes this.
  5. commissioneranthony

    commissioneranthony [H]ard|Gawd

    Messages:
    1,104
    Joined:
    Jul 2, 2008
    Thanks for the suggestions guys
    To be honest, 40 tabs is really not that much. My old sandybridge laptop could handle 60-80 tabs on firefox with virtually no lag when switching between tabs.

    I ran memtest86 and the zero errors were reported.

    I ran malwarebytes and security essentials and there's no issues that came up.

    I don't use iTunes or any Apple software. I don't run any toolbars, one drive, google sync etc..

    I'll try clearing the browser history and cache. Maybe it's something that simple.
    I have not cleaned out my temp folder in a while and i probably left superfetch on. Will report back if anything changes.

    I will give latencymon a try as well. Thanks.
     
  6. commissioneranthony

    commissioneranthony [H]ard|Gawd

    Messages:
    1,104
    Joined:
    Jul 2, 2008
    You guys are not going to believe this.
    The problems I had with the intermittent lagging seems to be caused my my logitech m705 mouse.
    removed my mouse, plugged in my other logitech g400s, no lagging whatsoever.
    I stopped using the g400s because the mouse becomes gummy in your hand.
    Screw soft touch plastics.

    I used NIMH batteries in the m705. I am still investigating whether that may be the issue or it's just the m705 throwing in the towel.

    I can't believe this guys.
    Holy crap.
     
    Spartacus and auntjemima like this.
  7. cjcox

    cjcox [H]ard|Gawd

    Messages:
    1,386
    Joined:
    Jun 7, 2004
    Personally, I have a problem with keyboard and mice without cords. I mean, why?
     
    Mega6 likes this.
  8. Mega6

    Mega6 2[H]4U

    Messages:
    2,646
    Joined:
    Aug 13, 2017
    Unless in the living room and your box is 25 feet away, I don't get it either.
     
  9. commissioneranthony

    commissioneranthony [H]ard|Gawd

    Messages:
    1,104
    Joined:
    Jul 2, 2008
    I hear you guys loud and clear now. I purchased the M705 for my laptop a long time ago. I just kept using it and reused it on my desktop.
    Never again.
    Now all I have to decide is whether I take the 2lb or 5lb sledge to the M705.
    I'm leaning toward the 5lb.
     
    Mega6 likes this.
  10. auntjemima

    auntjemima [H]ardness Supreme

    Messages:
    5,515
    Joined:
    Mar 1, 2014
    I've had failing usb devices with the same general thing you're mentioning.
     
  11. Spartacus

    Spartacus [H]ard|Gawd

    Messages:
    1,948
    Joined:
    Apr 29, 2005
    Disable the Windows Error Reporting Service and see if that fixes it.

    The service name is "WerSvc".


    Edit: NVM just saw that your mouse was causing it. Good find!


    .