I'm having some touble with an old Socket 939 board...

Not open for further replies.

The Wayfarer

Aug 16, 2004
I've got a little home-automationy project I've been tinkering on, and a kind forum member gave me an old Asus A8V-VM socket 939 motherboard to use for the control system. Unfortunately the board is giving me some trouble (although it worked fine for the original owner), and I'm having difficulty tracking down the source of the issue. TBH, I'm a bit embarrassed to ask for help on this one (because I feel like it's probably something glaringly obvious that I'm somehow not seeing), but F me, I'm stumped.

The problem seems to be centered around onboard video. The board POSTs just fine, and I can get things like Clonezilla and Memtest86 to boot and run without issue. But Windows installers (10, 8, 7...haven't tried XP though) crash/hang when starting the GUI, and while I can get both Ubuntu and Mint to run and install, they do so in "software rendering mode" only, thus dramatically limiting resolution and performance. Normally I would write this off as a defect with the onboard video, but here's the real head-scratcher: the problem persists even when using a discreet video card. This board uses the VIA Chrome9 IGP -- which I know was a pretty unpopular, short-lived component -- but I don't think this would have any effect on the use of a stand-alone video card...right?

Anyway, here's what I've done trying to track down the problem so far:

* Flashed the most recent BIOS
* Tested/swapped out every other component (except the CPU; I have no other 939 CPUs on hand)
* Pulled old CMOS battery, let board sit for a bit, put in new CMOS battery
* Used every combination of memory slots/modules imaginable
* Used both USB and PS/2 peripherals (I've heard rumors about some old mobos not liking USB peripherals)
* Tried other versions of the aforementioned OSs (older releases, 32-bit versions, etc.)
* Used 100% default BIOS settings
* Use every possible permutation of BIOS settings I can imagine, paying special attention to default video source (Integrated, Discreet, etc)
* Cursed creatively

Even though I'm (necessarily) doing this project on a shoestring budget, by this point I probably would have been better off just buying a new bargain-basement mobo instead of scrounging something from the Perpetual Freebies thread. But, you know, I already had the memory lying around, and a big-ass 939 cooler, and... Plus, I was really looking forward to OCing an Opteron once I got the system up and running. Sigh.

So, any thoughts before I take this thing to the recycler?


TL;DR: Asus A8V-VM. Onboard video no work, discreet video no work. What do?
Last edited:
May have to go back to XP. Definitely something with Video and Windows, so I don't think it's a hardware issue per say.

As far as Linux only using Software mode - that is a bit of a head scratcher.

Not to be Captain MOTO or insult your intelligence, but just to make sure since you list just about everything else - you did switch the monitor between the motherboard IGP and the discrete card? And the video displayed fine in Linux via the discrete output (albeit with the software renderer)?
you did switch the monitor between the motherboard IGP and the discrete card?
I did.

And the video displayed fine in Linux via the discrete output (albeit with the software renderer)?
Correct. There was literally no change when I used a discreet video card.

Not to be Captain MOTO or insult your intelligence,
No offense taken; I think we've all done dumbass things like that once in a while. :)

Thanks for your thoughts, though.
I see Windows 7 and 8 drivers for that IGP. I have seen older motherboards (older than 939) that would have issues with IGP/Discrete conflicting - usually that was "black screen", or monitor only works if plugged into the motherboard port - and it required disabling the IGP in a couple of odd places in the BIOS.

What discrete video card are you dropping in there? Maybe that's the problem and it's having some compatibility issues. It really sounds like the mobo/CPU are working ok.
Sounds like a head scratcher. Have you disabled the onboard video?

I once had an issue with installing W7 where the computer would crash constantly on the installation GUI. The solution was a strange one, unplugging all of the USB peripherals except the installing USB drive, worked. Stupid Dell computers...
Check the caps on the board. Budget boards from that era weren't known to use good quality components, and bad caps will cause a system to do all sorts of funny things.

Disable/remove everything not needed to boot to the OS (nic, audio, USB, unused SATA/IDE controllers, etc)
Thanks for the thoughts everybody, but this puzzle has exceeded its capacity to amuse; the board is headed for the recycler.
Not open for further replies.