HP G56 laptop won't boot with SSD in

  • Thread starter Deleted member 79192
  • Start date

Deleted member 79192

I have an older HP G56 laptop which I wanted to upgrade. So I took my Kingston SSDNOW V100 64GB SSD and put it into the laptop, figuring it would be an easy process to just reformat during installation of Windows 7. But with the SSD in the laptop, it doesn't proceed past the very first screen with the black background, blue and white HP logo in the middle, and "Press esc for more boot options" in the lower left hand corner. It is completely unresponsive. Pressing any key does nothing, but after having pressed 5-10 keys it will start beeping with each key press. Swapping back to the old HDD works fine.

Strangely, it's just a matter of getting into the BIOS then it's bootable. If I have the HDD plugged in, and begin booting but go into BIOS, and then hot swap to the SDD while in BIOS, I can boot from the SSD. I then exit the BIOS, get the blinking underscore in the upper left hand corner of the screen (as it begins looking for boot devices) and it boots into the Windows 7 that was already on the SSD. The laptop works perfectly fine with it once it can actually get a chance to boot from it.

I checked into SSD firmware and by comparing the numbers to those on Kingston's website it would appear mine does not have the older firmware causing failure, mine came from the factory with the latest firmware.

This isn't feasible... I can't bring a screwdriver and a spare HDD with me every time I want to boot up my laptop. I can't just keep it in sleep 24/7 because of the battery being older and weaker. It would be way too easy to have it accidentally run empty.

Has anybody ever experienced anything like this? What did you do to resolve it? Is this an issue with the laptop not supporting booting from SSDs? Would a newer SSD work better, worse? I've tried searching the net and these forums and haven't been able to turn up anyone in this scenario. Before buying another SSD I wanted to see if I could find out what to expect.

Thanks in advance.
Do you have the latest BIOS on the G56? That's the first thing to check.

I have seen issues with some desktop/laptops not booting properly with SSDs. My wife's 7 year old Sony with an SSD will often hang at a cold boot just like yours, but if I Ctrl+Alt+Del in will boot back up just fine. My old desktop would often hang at boot as well, until I found a hacked BIOS online that fixed it.

In both cases, it's was the old Intel SATA chipset not working properly with the SSDs. More specifically, it was the Intel option ROM inside the BIOS that was the problem, so the hacked BIOS with an updated option ROM did the trick.

So only fix is probably to find an updated BIOS from HP that fixes it, or the slim chance someone has a hacked BIOS for your laptop that has the fix.
Thought about updating the BIOS but didn't do it because I've never done that before on a computer and didn't feel like learning. I checked and found my BIOS was from 2010, the manufacturer had one from 2011. So I updated to that newest version, which I do see in the BIOS now showing that new version, but exact same behavior.

So at this point we can assume that this laptop just will not support SSD's and my only hope is a hacked BIOS? How would I go about finding that?
most older hp machines in which they have NOT updated the bios, are locked per say to only allow sata2 ssd drives.

look into a older intel x25m 80, 120 or 160GBP. those should work, and are pretty cheap. certainly not as fast at the current ssd drives, but still significantly snappier than any standard mechanical drive.

I have a few g62 laptops that had the same issue, and the x25m solves my boot problem. good luck
Is the Kingston SSD not sata 2? Would it be sata 3?
it appears that the drive is sata2, without a hacked bios to allow for the bios to read the proper boot sector, would be to try the x25m.

might also want to download a copy of the Windows 8.1 preview, and see if you can install the ssd using 8.1, it may have the proper boot loading drivers for that machine already archived on the install disk