How to disable annoying mouse middle-click "autoscroll" function?

Coldblackice

[H]ard|Gawd
Joined
Aug 14, 2010
Messages
1,151
Is there a way to disable the utterly annoying mouse middle-click autoscroll function? It's activated by pressing the middle mouse button, usually in web browsers (but also other programs). When pressed, it changes the mouse cursor to an omnidirectional free-flow cursor, and wherever the pointer moves, the window smoothly scrolls in that direction.

This isn't the commonly referred to "smooth scrolling" feature, which Googling shows frequently suggested as the solution which it's not.


tl;dr

I have a G502 with a now busted middle button. I can still use the middle button, but it doesn't have a click anymore, essentially stuck in the down position just barely above the click threshold. I slammed the mouse down out of frustration the other day -- uncharacteristic of me, it was the game's fault -- I assume I either broke or dislodged some lever or spring tied to the wheel.

Free-spinning still works fine, but in non-free/click scroll mode, each ridged scroll activates the middle mouse button as if I'm holding it down, similar to a keyboard key when something gets stuck below it.

I assume it's a broken part vs. something dislodged, but if anyone familiar with the G502 knows its inner layout and the likelihood of it being a broke part vs. dislodged, I will disassemble the mouse to fix it. Otherwise I assume something broke and chalk it up to a foolish loss on my part.
 

Zepher

[H]ipster Replacement
Joined
Sep 29, 2001
Messages
19,390
If you are using logitech's software, just disable the middle click and assign it to a side button if you have one and need a middle click.
I just tested it with my G604 and it can be disabled,
logitech-middle-click.jpg
 

Mr Evil

Weaksauce
Joined
Jul 11, 2015
Messages
116
As far as I know, this is a feature that's implemented by applications, so you can only disable it per-application, not globally.

I dislike it too, so I know that in Firefox it's right there in the settings as "Use Autoscrolling". I think there's a corresponding setting in Chrome somewhere too.
 
Top