How do I get HDR to work in games?

Discussion in 'nVidia Flavor' started by Wag, Jul 16, 2017.

  1. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    I have a 1080Ti and a Samsung 4k TV and I'm trying to get HDR mode working on ME Andromeda (free trial). I have the latest drivers: 384.76. I've tried everything I can think of and the TV doesn't switch into HDR mode.

    Do I need to have HDR mode "On" in the Win10 display settings? In the Nvidia control panel I've tried setting it to YCbCr422 10bit. Didn't work. What am I missing?
     
  2. MMitch

    MMitch Limp Gawd

    Messages:
    142
    Joined:
    Nov 29, 2016
    I would suggest reading the TV manual and search on google. I had to enable supersampling on my Vizio TV (HDMI Setting) to make it work.
    Also, make sure you do not use any splitter of some sort... most of them will end reporting the lowest HDCP device in the chain...

    Please list you TV model number, we could help more

    EDIT :: My experience is with the PS4 Pro + PSVR, so I will not be able to help on Win10 side.
     
  3. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    I have UN48JU6700 which had HDR support added in a firmware update. It's 8-bit HDR so it can't take full advantage of HDR10, but it does work. I've played back HDR content just fine from USB and Nvidia Shield, PS4 Pro and it switches into HDR mode just fine.
     
  4. MMitch

    MMitch Limp Gawd

    Messages:
    142
    Joined:
    Nov 29, 2016
  5. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    I'm always in HDMI UHD Color mode.
     
  6. Armenius

    Armenius [H]ardForum Junkie

    Messages:
    11,362
    Joined:
    Jan 28, 2014
    If you're on the Creators Update (1703), then yes, you need to turn HDR mode on in the W10 display settings. You can turn it off when you're not playing so you don't have to deal with the messed up colors on desktop applications.
     
  7. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    It could be my TV. As I said it doesn't support "true" HDR10, so it looks terrible, colors all washed out and muted. Funny because the Netflix and Amazon HDR content looks great. In any event I just turned HDR off and changed it back to YCbCr444 8bit and it looks fine. I'm going to leave it that way.
     
  8. Armenius

    Armenius [H]ardForum Junkie

    Messages:
    11,362
    Joined:
    Jan 28, 2014
    I agree with you. I have a KU6500 and tried it once, but the contrast got blown out so I went back to normal. Looks great in PS4 games, though. Maybe it's just the way it's being handled on PC right now. NVIDIA implemented their own solution for HDR and then Microsoft went ahead and overrode that in the last update without telling anyone. So HDR support on PC right now is generally in a bad place.
     
  9. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    I have a PS4 Pro and tried Horizon on my JU6700 and it looked awesome. Sure it's not 10bit HDR but it still looked better than normal 4k.

    Hopefully when the 65" TCL P comes out it will improve things. That TV will have DV, 10bit full color gamut support.
     
    Armenius likes this.
  10. wickfut

    wickfut [H]Lite

    Messages:
    93
    Joined:
    Sep 14, 2004
    PC settings :-

    Nvidia - Use default settings

    Display settings - HDR + advance colour = ON

    and with Samsung TV's they keep auto switching the device type to PC. You need to manually change this to something else like Games Console or Bluray player. Do this in the source menu.

    Also make sure your backlight is set to maximum, HDMI UHD Colour is turned on for your HDMI socket.

    Mass effect appears to look like it's lost a lot of colour saturation but the colours are more natural and less in your face.

    lastly, I don't get the HDR10 ON notification with PC like I do with the PS4. You;ll know it's on by the fact your screen loses some brightness on the desktop. If it looks brighter then you need to try a different TV screen device type and make sure game mode is on.

    Don't touch the HDR+ setting on the TV, that isn't real HDR.

    The bright one with over bloomed purples is HDR off
    https://**************/i1Jh5Q/IMAG0141.jpg
    https://**************/dUv6X5/IMAG0142.jpg
     
    Last edited: Jul 19, 2017
  11. Wag

    Wag Gawd

    Messages:
    693
    Joined:
    Aug 29, 2006
    Thanks! I assume the Nvidia color space setting needs to be 442 10 or 12bit?
     
  12. wickfut

    wickfut [H]Lite

    Messages:
    93
    Joined:
    Sep 14, 2004
    I leave it at default colour settings so the 4:4:2 setting is greyed out.

    The main bit is the TV setting to get it off PC mode and the enabling HDR in the display settings.

    You need to adjust the HDR brightness setting within game.

    Some parts of the game look bad with HDR, I don't think it's been implemented very well. The Krogan desert planet looks excellent, as does the start area.

    edit:
    Just read the post above that your TV is a As JU6700 which is an 8bit panel. You might get it to accept the HDR signal but it won't output a 10bit HDR picture.
     
    Last edited: Jul 19, 2017
  13. cybereality

    cybereality 2[H]4U

    Messages:
    2,445
    Joined:
    Mar 22, 2008
    Check the HDMI port. I know on my Samsung TV it can only do HDR on HDMI 1.