How do I get Gigabyte RMA to respond?

kent

2[H]4U
Joined
Apr 8, 2001
Messages
2,599
I've used the RMA portal twice now and completed a request for service. It's been 7 and 5 days respectively. No e-mails back, nothing approved.

What am I doing wrong? Thanks for the help <3
 

Starfalcon

Gawd
Joined
Jan 7, 2020
Messages
669
You just need to wait until they get back to you. I had to do a RMA for a leadtek card 10 years ago, and it took 3 weeks for them to get back to me with my RMA number and where to send the card back.
 

polonyc2

Fully [H]
Joined
Oct 25, 2004
Messages
20,096
look for an official Gigabyte rep either here on [H] or another forum like Reddit and send them a message

You just need to wait until they get back to you. I had to do a RMA for a leadtek card 10 years ago, and it took 3 weeks for them to get back to me with my RMA number and where to send the card back.

3 weeks just for them to respond?...that's terrible...
 

Lakados

2[H]4U
Joined
Feb 3, 2014
Messages
4,032
Well if they are anything like Asus service or Dell service just throw the item away.
Asus responds within 24h and Dell within 2h.... Or just call them never had to spend more than 30m on the phone to get a resolution from either of them and that often included the time to verify my shipping address for the return box.

For Gigabyte just call them, I don’t know who manages their website but it’s trash.

US number 9-5 Mon-Fri: 1-626-854-9338
 

l88bastard

2[H]4U
Joined
Oct 25, 2009
Messages
3,036
Asus responds within 24h and Dell within 2h.... Or just call them never had to spend more than 30m on the phone to get a resolution from either of them and that often included the time to verify my shipping address for the return box.

For Gigabyte just call them, I don’t know who manages their website but it’s trash.

US number 9-5 Mon-Fri: 1-626-854-9338

Don't even get me started on Dell, they outsource CSR to India and its beyond shit.
I will never purchase ANYTHING Dell again....Fuck that!

I bought a Rog 2 phone, it died @ 10 months with two months warranty left.
Asus says I need to pay $70 for diagnostic test and then send phone in.
I pay $70 thru paypal and Asus then says DO NOT SEND your phone as its China region!
Asus says its a China region phone and says I need to contact China for warranty repair.
I ask for my $70 back and Asus says it will take A MONTH to refund!
I ask how to contact china and a day later they email me a link to a page all in chinese.
After google translate, the page produces a chinese phone number.
Chinese Phone number does not work.
Contact US Asus again and they tell me there is nothing they can do.

So after two weeks of CSR hell. I am left with a broken Rog 2 phone and still don't have my $70 back.

At this point I am leaning to never buying Asus again.....when I think back I have had
nothing but problems with Asus products. Rampage Extreme III and IV motherboards were trash.
X27 monitor had fucked up fan, Asus gaming laptop was a POS and Rog Phone 2 died quicker than hot garbage.
 
Last edited:

Starfalcon

Gawd
Joined
Jan 7, 2020
Messages
669
look for an official Gigabyte rep either here on [H] or another forum like Reddit and send them a message



3 weeks just for them to respond?...that's terrible...

Oh I agree with you that it was terrible, but wasnt a whole lot I could do. Plus it took 2 months to get my replacement card back, fortunately I had a spare for that computer to get me by while I waited. That was by far the worst RMA I had. Best by far was netgear for my FVS 338 router that died, it was considered enterprise class and they overnighted me one the next day after I submited my RMA ticket. Replaced it again a couple years later when it got firmware bricked same way with overnight replacement.
 

EnderW

[H]F Junkie
Joined
Sep 25, 2003
Messages
11,054
Shit....I’ve been buying gigabyte boards cause I thought they had good customer service
 

pendragon1

Fully [H]
Joined
Oct 7, 2000
Messages
28,199
Shit....I’ve been buying gigabyte boards cause I thought they had good customer service
i honestly dont know how their cs is as i have never had a gb part die that i wasnt the cause of.
 
Last edited:
Joined
Jan 16, 2013
Messages
2,313
You just need to wait until they get back to you. I had to do a RMA for a leadtek card 10 years ago, and it took 3 weeks for them to get back to me with my RMA number and where to send the card back.

It typically takes a few days, you should have taken action if a week passed and no response. Also agree with oldmanbal, that might be a good way to get their attention.
 
Joined
Apr 16, 2018
Messages
1,018
Call them. I had to rma a 980ti a few years ago and they were solid. The entire process took less than 2 weeks to get a replacement.
 

Nimisys

Fully [H]
Joined
Jun 20, 2000
Messages
19,357
I had to RMA a Mobo at the start of the . month. Took about 8 business days for the authorization to ship. They are only 120mi from us and it took 3 more days after that to acknowledge they received the board. It had been 5 more business days before I left for vacation and still had not heard back on whether they were shipping a replacement back.

TLDR: Gigabyte is slow right now, but they are moving.
 

exilelrrp

Limp Gawd
Joined
Jun 11, 2010
Messages
325
Send them a tweet or Facebook post, if you use any social media. Twitter - https://twitter.com/gigabyteusa?lang=en Facebook - https://www.facebook.com/GIGABYTEofficial/

I buy EVGA products because I have yet to have a bad experience with it. I waited 2 weeks for ASUS to even respond, so I gave up.
I had issues with my Asus ROG Strix Z490-G and I put in the RMA it was approved pretty much instantly online, they sent me a printout RMA sheet to put on the package, but I didn't use that at all because of the whole "COVID-19 under staff" especially with USPS delays and missing packages - I made sure to send the board back FedEx overnight and the package got there Friday morning, I got my full refund within 3 business days.

Due to COVID-19 many of us have lots of time in our hands, things are not back to "normal" yet, so what you do is email, email, call them, and keep calling until you get in contact with someone... It's your money at the end.
 

Nimisys

Fully [H]
Joined
Jun 20, 2000
Messages
19,357
For what it's worth, my RMA repair was completed on the 28th and shipped on the 3rd.
 

D-EJ915

[H]ard|Gawd
Joined
Jan 31, 2003
Messages
1,405
I had to RMA a Mobo at the start of the . month. Took about 8 business days for the authorization to ship. They are only 120mi from us and it took 3 more days after that to acknowledge they received the board. It had been 5 more business days before I left for vacation and still had not heard back on whether they were shipping a replacement back.

TLDR: Gigabyte is slow right now, but they are moving.
Yeah I think everybody is slow now, took Newegg a week before they even looked at the box I sent them when I returned something last month.
 
Top