HICKERY Xcopy not working in windows 10

Discussion in 'Operating Systems' started by valorouswon, Oct 16, 2018.

  1. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014

    Attached Files:

    Last edited: Oct 16, 2018
  2. Ocellaris

    Ocellaris Ginger @le, an alcoholic's best friend.

    Messages:
    18,739
    Joined:
    Jan 1, 2008
    Are you running it with Admin privledges?
     
  3. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    Always do
     
  4. Executioner

    Executioner Limp Gawd

    Messages:
    287
    Joined:
    Apr 22, 2015
    What is your exact syntax for xcopy?
     
  5. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014

    I'm copying files from my internal (L) drive to my external (N) so my command is this:

    xcopy l:\ n:\ /h/i/c/k/e/r/y

    Also tried capitals which I don't think matters anyway.
     
  6. ryan_975

    ryan_975 [H]ardForum Junkie

    Messages:
    13,807
    Joined:
    Feb 6, 2006
    Frobozz likes this.
  7. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    In my case which one of those 3 commands am I using?
     
  8. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
  9. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    Still can't resolve this
     
  10. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    Robo copy also did not work

    robocopy L:\ N:\ /copyall

    Though tit was a permissions issue, changing that didn't solve anything.

    upload_2018-10-17_19-15-20.png
     
  11. Executioner

    Executioner Limp Gawd

    Messages:
    287
    Joined:
    Apr 22, 2015
  12. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    Sorry but I don't know what to do from here. I changed the file permissions to admin/full control. Everything except actual folders are being copied over.
     

    Attached Files:

  13. Tawnos

    Tawnos 2[H]4U

    Messages:
    3,806
    Joined:
    Sep 9, 2001
    You would need to add /s (include subdirectories with files) or /e (include all subdirectories, including empty ones). The /copyall flag relates to what flags are copied (attributes, acls, etc).

    If you want to mirror your internal hard drive to your external (removing any files that don't exist in L:\ but do exist in N:\), you could try the following (/zb is restartable and uses backup mode for access denied issues):
    robocopy L:\ N:\ /copyall /mir /zb

    If you don't want to delete any files on N:\, just use /e instead of /mir:
    robocopy L:\ N:\ /copyall /e /zb
     
  14. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014

    This also does not work. Must be another issue and xcopy should have worked in the first place. Windows 10 settings?
     
  15. Tawnos

    Tawnos 2[H]4U

    Messages:
    3,806
    Joined:
    Sep 9, 2001
    What doesn't work? Which files do you expect that aren't copied, etc?

    You _have_ to give a bit more info than you have when we're trying to help, right now it's like extracting teeth to figure out what's wrong.

    For example: what file wasn't copied, what are its attributes, what are its ACLs, can you open it, etc...
     
  16. valorouswon

    valorouswon [H]Lite

    Messages:
    82
    Joined:
    Apr 30, 2014
    No folders are copied, only notepad/text files, installers, pdfs, etc. I already set permissions for full control.

    Anyways I just selected everything manually and dragged it over. However I usually run into issues this way, or more space it utilized on the destination drive for no reason.. Xcopy is usually more efficient in that sense. I'll let you know how it pans out