Help With My First Dual Monitor Setup?

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
Hello all! I just recently (as in today) got my second monitor for my build to help with my programming classes. My build it exactly as it appears in my signature. What I need help with it this; after connecting my second monitor (both are via displayport btw), a lot of stuff has slowed down. Whereas before I could minimize Modern Warfare and cycle between windows pretty seamlessly, now whenever I have a videogame open on one monitor and something else on the other, cycling between said screens or windows causes both screens to freeze up and go black for about 60 seconds and THEN everything goes back to normal. Other issues include one annoying one where when my PC goes to sleep and shuts the monitors off it takes a while for them to actually turn back on when I move the mouse to wake it up. I know I may not be being specific enough but, if you may know what is wrong here, I am happy to provide any extra information. I just am not sure what would need to be known in order to solve this. It also may well be possible that this slowness and lag is the simple result of adding an entire other screen for my poor GPU to render. Either way, any closure or aid would be greatly appreciated!

Thank You!
 

sharknice

2[H]4U
Joined
Nov 12, 2012
Messages
2,974
Are you running the game at a different resolution than you're running your desktop? That's typically what causes very long delays when tabbing out. If you tab out of a full screen game running 1920x1080 to your desktop at 2560x1440 the monitor has to change resolutions and whatnot. There could be other issues too though.
 

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
Are you running the game at a different resolution than you're running your desktop? That's typically what causes very long delays when tabbing out. If you tab out of a full screen game running 1920x1080 to your desktop at 2560x1440 the monitor has to change resolutions and whatnot. There could be other issues too though.
No I am running the game at the same resolution. It is a really long time for those tab outs and it is the biggest issue on modern warfare. The wake up times for the monitors is also pretty bad lol
 

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
Is the refresh rate set the same too? Also have you tried other games?
Have you tried this for the wake up time ?

https://www.dell.com/community/Moni...Issue-Disable-Monitor-Deep-Sleep/td-p/4688915
disabling "Monitor Deep Sleep" in the "Menu" - "Others"

Seem to have some other step that can be tried (trying the hdmi port could be one)

The refresh rates are set the same yes. 144Hz. Other games are better but not quite as snappy as the previous one monitor setup. And deep sleep is disabled on both monitors. Both monitors are running via a display port cable.
 

sharknice

2[H]4U
Joined
Nov 12, 2012
Messages
2,974
Do you have the screen you game on set as your primary display in windows?
You could try setting the game to borderless fullscreen and see if it still happens, but that may add some input lag or decrease performance.
 

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
Do you have the screen you game on set as your primary display in windows?
You could try setting the game to borderless fullscreen and see if it still happens, but that may add some input lag or decrease performance.
I believe that I do have it set as such in windows. I mean, everything opens in this one by default and my toolbar appears on the screen I game on. The borderless thing is also a performance hit yeah. Is it possible that these issues are just the price that ya pay for driving a second monitor of this quality?
 

sharknice

2[H]4U
Joined
Nov 12, 2012
Messages
2,974
I believe that I do have it set as such in windows. I mean, everything opens in this one by default and my toolbar appears on the screen I game on. The borderless thing is also a performance hit yeah. Is it possible that these issues are just the price that ya pay for driving a second monitor of this quality?

It's not typical. I have 7 screens and most games it takes less than a second to alt-tab and the monitors to act normal. I played the COD MW battle royal free version and I don't remember how long it took but I do remember it behaved weird compared to other games. I have played some other games where it can take a few seconds when alt-tabbing too, but for most it's less than a second.
You could see if there is something in the monitor OSD like a power saving function or something that's messing with your PC making it think the monitors are powered off. You could also see what happens if you use HDMI.
 

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
It's not typical. I have 7 screens and most games it takes less than a second to alt-tab and the monitors to act normal. I played the COD MW battle royal free version and I don't remember how long it took but I do remember it behaved weird compared to other games. I have played some other games where it can take a few seconds when alt-tabbing too, but for most it's less than a second.
You could see if there is something in the monitor OSD like a power saving function or something that's messing with your PC making it think the monitors are powered off. You could also see what happens if you use HDMI.
There is nothing in the monitor OSD that would suggest that I am getting less performance than is to be expected. Now I am really confused XD. Could one of the DP outs in my RTX 2080 Super just be slower than the rest? Should I try a different port?
 

zandor

2[H]4U
Joined
Dec 14, 2002
Messages
3,860
I have no idea what's wrong but I haven't personally seen this and it's not normal. I've been running 2+ screens for around 20 years. Back in the old old days you kind of needed a Matrox card for that, so I got one. Not long after Windows picked up the ability to run two PCI graphics cards at the same time. I forget which version you needed. Maybe Win2k? Pretty sure it was one of the NT derivatives. At any rate a 60 second OMGBBQWTF sort of thing shouldn't happen even if you're using a mix of vid cards from different brands hooked up to a random assortment of displays. Or at least it never happened to me. Occasional BSODs sure, but not recently and never a routine wedged for a minute sort of thing.
 

VOID93

n00b
Joined
Apr 29, 2020
Messages
47
I have no idea what's wrong but I haven't personally seen this and it's not normal. I've been running 2+ screens for around 20 years. Back in the old old days you kind of needed a Matrox card for that, so I got one. Not long after Windows picked up the ability to run two PCI graphics cards at the same time. I forget which version you needed. Maybe Win2k? Pretty sure it was one of the NT derivatives. At any rate a 60 second OMGBBQWTF sort of thing shouldn't happen even if you're using a mix of vid cards from different brands hooked up to a random assortment of displays. Or at least it never happened to me. Occasional BSODs sure, but not recently and never a routine wedged for a minute sort of thing.
Thank you for your response! I actually just changed the DisplayPort out that I had the monitor plugged into...and it seems to have fixed the long wait times. Perhaps one of my DP outs is just...bad? I really have no idea what to say for that. A new problem has cropped up though and I want to keep it in this thread because it seems to be related...after all, it only cropped up after doing what I just said. Essentially, and I know this is weird, but CERTAIN applications lag the crap out of my displays now and screw with the colors. It isn't the PC that is actually lagging. For example, when I launch Zoom for school, the Ryzen master app, or Ccleaner the displays lag down to what FEELS like below 60 Hz and both monitors start to subtly ebb in and out their contrast and vibrancy, becoming slightly darker and lighter until, after an annoying amount of time, they settle in and behave """ok""". What in the WORLD could have done this? It is only certain apps. Chrome does not do this for example. It is really annoying and I am at a loss because nobody on the internet seems to have this issue.
 
Top