Help with google chrome please!

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,004
Just built a PC for a buddy.. older 6700k. I put google chrome on it and for whatever reason it wont hardly open a web page and will say lost connection often. Won't even run a speed test. I can go to edge and it works perfect. I tried reloading the PC thinking something I installed somewhere borked it and no luck. What can it be? Fresh install both times. This was a working PC with zero issues before. The only thing changed was the video card and OS drive.
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,004
Try installing Chrome beta.

I found this..

Turns out this is a common issue.. this fix is way more effort than I want or should have to put into this.. so frustrating I just need this PC finished and gone.
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,004
I could not get this to work.... still stuck trying to get chrome to work on this PC...
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,004
He agreed to use firefox... I just installed firefox on my own PC.. it moves pretty good.. may move back to it. Everyone used to be all over Chrome..
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
9,330
Chrome is much lighter on older/cheaper hardware. I just tried to restore a cheap laptop of my aunts. She bought it only a couple of years ago and I was shocked to see it had a 1Ghz AMD CPU and the slowest Seagate HDD I've ever seen. I think the Quantum Fireball was faster, honestly.

Firefox took 13 seconds to load where chrome took 'only' 7 seconds. Almost lightning fast! :D
 

Frobozz

[H]ard|Gawd
Joined
Feb 15, 2002
Messages
1,817
Off the cuff, this sounds like a lower level issue than the browser itself. Does everything else behave ok? Is your network otherwise stable? Could you do a "ping -n 200 www.google.com" without packets dropping?
 

Mazzspeed

2[H]4U
Joined
Dec 27, 2017
Messages
3,050
Chrome is much lighter on older/cheaper hardware. I just tried to restore a cheap laptop of my aunts. She bought it only a couple of years ago and I was shocked to see it had a 1Ghz AMD CPU and the slowest Seagate HDD I've ever seen. I think the Quantum Fireball was faster, honestly.

Firefox took 13 seconds to load where chrome took 'only' 7 seconds. Almost lightning fast! :D

Since the last beta update opening Firefox is now instantaneous.
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
9,330
Under Ubuntu Mate with uBlock Origin installed 64.0b9 opens immediately, a vastly noticeable improvement from before.
I'm fairly confident that absolutely nothing happens immediately on my aunts laptop. She bought it from her internet service provider for 300 bucks and it's made out of industrial waste and Chinese gutter oil.
 
Top