Help--Mystery Linux Connection Appears On My Machines

Axman

[H]F Junkie
Joined
Jul 13, 2005
Messages
12,873
A while back I had some trouble identifying a connection that showed up on my girlfriend's computer at home.

It showed up as:
Local Area Connection on Linux IGD
and went away when I updated her Windows XP firewall. I found this out when I'd shut off her computer, turn off my firewall, and let be connected for, oh, three seconds. An interesting thing I think is that it only appears on one machine at a time.

I even had Qwest (Qworst, without a doubt) roll a truck. It would even show up on the technician's laptop if no other machine was already available. He called the modem company, they said their routing software was Linux-based, and that was that.

I have now turned /off/ my Windows firewall in favor of my nVidia hardware firewall, and what do I see connected? IGD. I know it's not the router, because IGD is a Gentoo (and now BSD?) platform, and the modem doesn't do emulation for the network hardware.

This is all quite fishy. I'd like to just stop the connection, but of course, I don't have sufficent priveledge to disconnect it. It used to get automagically blocked, but that's no longer the case.

Anyway, help would be /great/.

Max S.
 

cell_491

2[H]4U
Joined
Oct 16, 2004
Messages
2,608
does your neighbor use linux...because if so he might be stealing internet from you, thats assuming your using a wireless router
 

Axman

[H]F Junkie
Joined
Jul 13, 2005
Messages
12,873
GT-701. If it's part of the modem's function, why does it only connect to one machine on the network at a time? And also, why does Windows Firewall kill the connection (without any side-effects)?

Not in wireless mode.

Also, shows up on clean installed machines, so it's nothing viral.
 

Captain Kirk

Limp Gawd
Joined
Dec 22, 2002
Messages
288
Axman said:
GT-701. If it's part of the modem's function, why does it only connect to one machine on the network at a time? And also, why does Windows Firewall kill the connection (without any side-effects)?

Not in wireless mode.

Also, shows up on clean installed machines, so it's nothing viral.
I've seen this before. Go into the Actiontec advanced setup and look for "Universal Plug and Play." When you find the setting, disable it and do a "save and restart." After it comes back, reboot the Windows box, IGD (Internet Gateway Device, BTW) should now be gone.
 

Axman

[H]F Junkie
Joined
Jul 13, 2005
Messages
12,873
Thank you. While I could not find the option to disable UPnP in the modem's config, I simply removed UPnP from my networking components. Everything seems to be running along just fine now, thanks again.

I still got Qwest to knock off two month's DSL for the hassle of it ; )

Max S.
 
Top