HD issue (Transfer/Response)


May 13, 2005
I am not sure where to begin with. Yesterday, I got new AMD 1090T, Asus Crosshair 4 Formula, and few other upgrades for my rig. Along with my new upgrade, I got WD Black Caviar 1 Tb 64 Mb cache Sata 3.0 HD.

I put all my new parts all together with my old HD from previous rig - WD Black Caviar 1 Tb 32 Mb cache Sata 2.0 HD and 500 Gb Samsung 16 Mb cache Sata 2.0. I booted up my computer, and reformatted 2 of my 1 Tb HD then installed OS on new Black Caviar HD. Everything was fine until my OS started to lock up (Clicking the file, and the cursor will turn into waiting ring for long time.) I rebooted again then it did the same thing after few minutes using Win 7 (Clicking start menu then the cursor turned into the same thing from previous one). I decided to reinstall Win 7 on my old Black Caviar HD instead. Thing is running so smooth without any problem for several of minutes.

I started to suspect that my new HD might be defective. I double check on what I did from previous installation. I recall that I installed all necessary driver for it. I decided to move all my file from 500 Gb HD to my new HD. I noticed that transfer rate is much slower than my old Black Caviar HD. I had to cancel it then try transfer again to my old HD this time. It is transferring at an average of 55 Mb/s compared to my new one at 25 Mb/s and dropping as the time goes by. I used cpuz to find out my mobo current verision, and it is the first release "5010". I went to Asus website to check on bios. There are couple of bios, and one of beta bios "7010" and "7070" were suppose to fix hard drive performance issue. Also, the latest offical bios is "8010". It is common knowledge is that any previous fixes should be included with latest bios. I downloaded it then flashed it on my mobo. I noticed one change on the bios under storage settings. It give you a choice to change the speed of sata - Auto, 3.0 Gbps, 6.0 Gbps. I left auto for this settings. I tested the file transfer again from 500 Gb to new 1 Tb. It is still reading at low speed 25 Mb/s, and dropping as the time goes by again. I rebooted and changed sata speed to 6.0 Mbps. Tested the file transfer again. Same thing.

Can anyone help me to figure out what is causing my new HD to act quirky on my new rig? Should I RMA it? :confused:
Last edited:
I'd guess its a bad drive. It would be very unusual for a driver issue or some bios setting to only affect a single hdd model, eg your new drive and not your old ones.

Download WDDIAG, westerndigital's diagnostic utility, run it off floppy/usbkey w/dos and see what it says.

Really tho, sounds like a bad drive.
I ran WDDIAG off from usb, and it showed no error for my new HD at all. I ran hddtach that my roommate suggested me to do so. It showed correct speed for my new hd...

Also, this morning my new hd icon just disappeared from my computer for some reason...
Check SMART values:
- current pending sector (bad sectors)
- udma crc error count (cabling errors)

Should both be zero (raw value)/
Check SMART values:
- current pending sector (bad sectors)
- udma crc error count (cabling errors)

Should both be zero (raw value)/

Current pending sector - 200
UltraDMA CRC error count - 200

Doesn't look good isn't it? :(
Last edited:
That is the threshold value; could you look at the raw value? HDTune's health tab displays this as "Data". It should be zero.

A threshold value of 200 sounds like a zero raw value for those two properties; meaning your disk it fine. You may want to check all your HDDs for these two values; with non-zero values there is a problem; while with a zero value the HDD should have no problems (anymore).

UDMA CRC Error Count occurs when transferring over the cable generates a checksum (CRC) error; it will simply try again but a high number would indicate bad cabling or some other issue during transfer.

In 99.9% cases this concerns a bad cable, but also bad power cables are said to cause this issue (no personal experience with this). There's a catch: you don't know for certain how long ago these cabling errors occured; it may be years ago. Still i suggest you replace the cables just to be certain.

Keep in mind that bending Serial ATA cables can also cause this; they need to be only slightly angled to operate correctly. I've experienced this myself with a cable that was still partly wrapped as it comes out of the factory; which generated UDMA CRC Errors for me. Simply unbending the cable resolved this. ;-)
Mmm... I have Corsair 800D case. It has HD cage with swappable tray. The power adapter on it is connected directly to one source of sata power connector from PSU. (Meaning all 3 HD are connected to the same power line.) Also, I recently replaced sata cable with asus one "out of the box". I will try straighten all of sata cable and etc... Hope I get better result out of it.

Pic of HD cage adapter:

Update: I isolated my new HD from HD cage, and the value of it remains the same. Still getting low transfer speed on it.

Update 2: Accroding to HDtunes pro, my 500 Gb is in perfect condition with 0 CRC error count and pending sector. My old 1 Tb HD is also 0 in pending sector, but got 1k for CRC error count. Lastly, my new HD is same what I showed you from above. I swapped new HD with 500 GB slot. Still getting same result. I tested all slots with my 500 Gb HD, and still getting good result on it. It is telling me that there are nothing wrong with my sata cable or power adapter at all. I narrow down the possiblity to bios issue where it might need another update to fix HD issue.

Later on tonight, I plan to test out my new HD on my friend's computer to see if it is giving different result. Man thank for your help sub.mesa. :)

Last update: It is confirmed that my new HD is defective. Tested it on my friend's computer by using USB HD dock and sata to his computer. Both give me same result from above. Transfer kept dropping below 25 Mb/s. Oh well thank for the help to everyone in this thread. :)
Last edited: