Hacker Evolution Duality - Free steam keys

donations above $3 get the game too. (unless i read that wrong)
Got one
I didn't think I would get it since I'm really slow with this type of stuff(so keep trying if you haven't yet).

Thanks for posting this OP!
Yay, got mine. Went out to dinner, came back home and noticed it was 9:04. Fired up steam, went to the page and did my copy/paste. Voila, I got it. Thanks for the heads up, OP!
I got one, I waited ~4.5 minutes after I failed the first one that I saw changed, then just started refreshing until it changed with my mouse cursor at the start of the key location. Once it changed I highlighted and copy pasted.
that's what i've been trying. i figure 3 dollars for 3 games, and less hassle was more worth it, lol
for a promo like this, donated $10! to them, worth it just for them having something like this
so when you get a key where the heck do you put it?

Right click the steam icon and select "library". Once there click "games" in the top and select "activate a product on steam". Then accept the agreement and then after that a box will pop so you can enter the game key. I just leave the cd key page up and make the browser window small. That way I have both open at the same time. Thanks
I've tried for the past 4 releases and I suck...

I keep getting an invalid product code message now. Something about the code not being correct at all.
Last edited:
If you donate $3 or more on their website, you get all three Hacker games free.
Once was enough times to prove to me that I am way too slow.
As an FYI to anyone else running into the same issue.. If you're getting the "Invalid product code" error message, it means that you've been temporarily banned from the steam activation servers or something. That happened to me after a couple failed attempts at this.

Just have to wait an hour or so for it to clear and try again.

Otherwise, I finally nabbed a copy; key #959. You seriously have to be a ninja to get this, or something. If you take longer than a second, forget it. These keys were going away in under a second each.
Thanks for the heads-up, OP!
took me about 3 attempts to grab one, granted I'm sure as the news spreads exponentially across the internet it'll be harder to manage to get one.. First try was all of about 5 seconds 3rd I had everything lined up, the webpage where the key would be, the enter steam key screen was up, even aligned it so that the box where you enter the key was at the same level as the webpage's key.. cursor was right at the beginning of the key, when the 5 minute mark started, F5 like crazy, as soon as I see the change
alt tab
click (the steam box)
hit enter (don't click next)
probably around 2 seconds
I donated, didnt get a key...

s;ok though I dont mind donating a few bucks just so small game devs keep doing stuff like this
For the slow (like myself), I've made an AHK script that will do it. Once I got it configured it worked perfect. You will need autohotkey, and you will probably have to change where the mouse clicks. Unless you are using 1920x1200 resolution, then it should work. Just need to have the exosyphen studios page open in firefox and the Product Activation window open and ready to type in a code. It basically refreshes the page, copies the code and pastes it in steam, then presses enter; in about half a second. Also you need to set it up in task scheduler to run at every 5 minute mark.
EDIT: yay me. I've uploaded the task scheduler file. Just import that into task scheduler and change where it runs the trigger from.
Last edited:
Ghost Mouse is anther good one. Just record all the movements and assign a hot key. Great little app for being free. I like Fire fox since you can drag the whole key and drop it in the key placement box. Stops you from having to use the copy and paste command. Don't forget to add enter to the recording. So it will put the key in and hit enter for you at the end. Thanks
they replied back to me and offered some copies for some friends!
how great is that.
Last edited:
That's pretty cool!

I'm not having any luck because now it says code not valid so I guess I've tried too many times :(
I tried twice, took less than 2 seconds each time and the keys were already taken.