GTX 770 weird issue

DULOTENGRE

n00b
Joined
Apr 24, 2020
Messages
3
Hello guys first I have weird problem with my graphics card it is GTX 770 MSI 2GB.
There is no output to monitors and doesn't post. The GPU is detected by the system when i use integrated video and i can install video drivers. And if I can selected it as a preferred GPU, i can play games, just from motherboard output. With other graphics card i don't have problems with the system.
If anyone knows something please help.
I searched information everywhere but i could find somebody with my problem.
Thank you.

P.S.
When i connect hdmi cable with monitor or TV it is shown in settings, but no picture. And the Display port doesn't respond when i connect monitor.
 
Last edited:

Wooshoo

Weaksauce
Joined
May 27, 2019
Messages
110
If you aren’t running from the GPU output you aren’t using it while playing games. It seems you may have a dead card on your hands but you need to put the rest of your system up in your post. This could be as simple as you don’t have enough power for the card from the PSU.
 

DULOTENGRE

n00b
Joined
Apr 24, 2020
Messages
3
My system bis working ok with RX 580, and it was working ok before with the Nvidia. Power supply is sufficient. I have tested on other system and doesn't work. About other output. I can select in few games which GPU to use, and it seems to work. Just no output.
 

DULOTENGRE

n00b
Joined
Apr 24, 2020
Messages
3
I tried all of them, 2 DVI and 1 hdmi are detected in Nvidia settings but no output, DP port doesn't show connection.
 
Top