GTX 680 bug in crysis 1 and 2

Joined
Apr 13, 2012
Messages
567
I am getting a wierd bug where whenever I move my mouse in crysis 1 and 2 I get wicked stuttering while turning, this phenomenon does not occur with movement via a gamepad or keyboard. Anyone else having a similar issue? I am going to see if changing my mouse has anything to do with it when I get home from work tonight. Also, it only happens in those two games so I dont think it has anything to do with my mouse. I use a microsoft X8 btw.
 

xorbe

Supreme [H]ardness
Joined
Sep 26, 2008
Messages
6,029
I found one spot in Crysis with a lot of terrain flickering, but it seems isolated so far. But otherwise both seem okay. C2 maxxed out is unplayable @ 2560 (hi rez, dx11, ultra, etc).
 

B!nd.

Gawd
Joined
Mar 14, 2012
Messages
757
I found one spot in Crysis with a lot of terrain flickering, but it seems isolated so far. But otherwise both seem okay. C2 maxxed out is unplayable @ 2560 (hi rez, dx11, ultra, etc).

I haven't tried Crysis 1 because I lost my copy :( so I am waiting for my new one to arrive.

Crysis 2 however is pretty much perfect performance at 1080p with text and DX11 tess pack. Some areas with a lot of water drop to high 20's especially when you shoot it repeatedly.

Also, what kind of monitor are you using? 120 or 60Hz?
 

FuzzyKittens

Weaksauce
Joined
Sep 7, 2011
Messages
77
sounds like a V-sync issue... have you tried playing around with the nvidia control panel(max frames rendered by CPU)
 

xorbe

Supreme [H]ardness
Joined
Sep 26, 2008
Messages
6,029
I haven't tried Crysis 1 because I lost my copy :( so I am waiting for my new one to arrive.

Crysis 2 however is pretty much perfect performance at 1080p with text and DX11 tess pack. Some areas with a lot of water drop to high 20's especially when you shoot it repeatedly.

Also, what kind of monitor are you using? 120 or 60Hz?

Just 60Hz (are there even any 2560x1600 120Hz screens?). 2560x1600 is about double the number of pixels of 1920x1080, it hurts lol.
 

Lord_Exodia

Supreme [H]ardness
Joined
Sep 29, 2005
Messages
7,008
Sounds like a vysnc issue, try looking at vsync settings and that new adaptive vsync setting.
 

Prophecy

Weaksauce
Joined
Jul 27, 2004
Messages
119
I was having this exact same issue, and for me I think it's related to having two monitors enabled at different refresh rates. I game on a 120Hz monitor and have a 60Hz IPS for normal browsing / desktop duties. I noticed that even on the desktop mouse movement has been sluggish, on both monitors. I disabled the second monitor, booted up Crysis 2, and it ran flawlessly.
 

BababooeyHTJ

Supreme [H]ardness
Joined
Jan 21, 2009
Messages
6,951

covertash

Gawd
Joined
Apr 24, 2006
Messages
991
I just wanted to say that this was also my problem as well and reducing the polling rate down to 125MHz fixed the problem! Thank you! :D
 
Top