Gigabyte z170x-gaming 7 m.2 pci-e install

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
hey folks,

Anything special i need to do in order install a 1tb Intel 600p pci-e SSD?

physically install, boot windows on existing SSD, image to m.2 SSD, then boot from m.2 SSD would be the plan.

Gigabyte z170x-gaming 7 motherboard.

Anything special I will have to enable in the BIOS etc to do this?
 

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
ah so there is a catch.
Doesn't WIN10 natively support NVME though?
 

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
ok so what i've read is that i'll need to actually change the bios to NVME boot mode, and have the IRTS drivers handy... as in, on the same USB stick as the win10 install files?
or is that only for windows 7?
/confused.
 

Pillars

Gawd
Joined
Jun 11, 2016
Messages
525
Where did you read that? I just used AHCI and the nvme was automatic as displayed in windows config.
 

bud1974

Weaksauce
Joined
Sep 12, 2015
Messages
90
I have the same board. Do a clean install like Pillars said on the NVME. In the boot options, disable "csm" and disable "secure boot". Set to windows 8/10 and you will be good. Make sure when your in the windows installation that there are 4 partitions "uefi".
 

Pillars

Gawd
Joined
Jun 11, 2016
Messages
525
I tried to disable CSM, wouldn't boot:( The switch to 8/10 worked though. Any ideas? I'm using 2x950 Pro(no raid), 1TB 850 Evo and a 1070.

When I disable CSM, or enable UEFI for storage devices both my 950 Pro's disappear from the bootable device list in the bios. F6 Bios.
 
Last edited:

Pillars

Gawd
Joined
Jun 11, 2016
Messages
525
Not a lot older.. my benchmark numbers however are spot on. I fear updating the bios will bork my OC/Setup, which is 4.6Ghz@1.33 (Realbench 24 Stable) and 3600Mhz C16 on ram. Solid.
 

Aluminum

Gawd
Joined
Sep 18, 2015
Messages
687
Windows 10 installs native on NVME with a default driver, any skylake board in UEFI mode should present the drive to the OS and be visible for the windows installer, I've built half a dozen systems with 600p already.

If the drive doesn't show up in the F12/boot menu or whatever either you did something wrong.
 

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
thanks Alu.

soo uuhhh.... what exactly am I looking for, in the latest bios, to change the 'mode' of the bios to UEFI?

.. if i change it into UEFI mode, will i still be able to boot my existing windows ssd if need be?
 

revenant

[H]F Junkie
Joined
Apr 10, 2005
Messages
14,505
Good thread. I am going to install my new system on a 600p on the z170x gaming 3 .... windows 10 from usb. I guess it should just "work". :)
 

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
yea ok so i just did the fresh install.
worked like a charm, very quick!
used the latest win10 install tool on a usb2 stick, took about 8 minutes to a usable desktop.
 

revenant

[H]F Junkie
Joined
Apr 10, 2005
Messages
14,505
I wanted to note something I saw in the manual for the gaming 3 and 5 (I think it applies to the 7 also). The top m.2 called "M2D_32G M.2" - if you use that one in nvme mode it would appear it will shut down a bunch of sata ports. The bottom m.2 is called "M2H_32G M.2" and it looks like if you want to use sata ports also that's the one to use in nvme mode. The bottom one (M2H) only absorbs one sata port it would appear but it might also cancel out the bottom 4x pci-e slots due to lane sharing on some boards. I will be testing this out next weekend on a gaming 5 board with an intel 600p in M2H and a crucial mx300 in M2D then some spinners raid1 and a DVD drive hanging off the sata ports.
 

Momo

Gawd
Joined
Mar 3, 2005
Messages
869
yeah, that's an important limitation to take note of when using this setup for sure.
 

revenant

[H]F Junkie
Joined
Apr 10, 2005
Messages
14,505
So I was at Frys... I had been eyeballing the MSI z170 m7/m5 mobos for a while due to the nice m.2 slot placement (one drive near the cpu and the other between the last two slots way down on the borad, so any video card in pci-e slot0 wouldn't be dumping heat on it. That and the killer black and red theme they have going. So I found the last gaming 7 board they had in stock right in front of me in the intel mobo section. So I thought to myself YOLO and dropped it in my cart. I got it all setup over the last couple days and I did have a bit of a time getting my Intel 600p working in m.2 slot_2 (closest to the cpu, the one that doesn't kill like 4 sata ports). I had issues being able to see the damn drive on the board but finally found the RST section of the bios and it saw the drive just fine. whew. BUT the windows installer didn't see it at all. I tried both m.2 slots, same thing. I tried the crucial sata m.2 in that slot and it worked fine. So I finally had to download and extract the RST raid inf files and browse to them on a flash drive during the windows install when it couldn't find a drive. The windows installer found the driver (as a compatible driver) and I hit "next" and then it was "installing" for quite a while. I thought it wasn't working then bingo, it finished and the drive showed up. Installed windows in about 8 minutes. Boot times are ridiculously fast.

Anyways, if you have issues seeing the drive just pop the RST raid/ahci controller drivers onto a flash drive and install them during the windows install.
 
Last edited:
Top