Gigabyte GA-AX370 Gaming 5 and Windows 7 [some usb ports don't work]

Discussion in 'AMD MoBos' started by spacedrone808, Apr 19, 2017.

  1. spacedrone808

    spacedrone808 [H]Lite

    Messages:
    96
    Joined:
    Mar 28, 2017
    Bios: F5
    OS: Windows 7 x64 SP1 with all updates till January 2017

    Successfully installed operating system and all appropriate drivers from Gigabyte site.
    But one device remains unknown: AMDUSB3\ROOT_HUB3&VID_1022&PID_145C&REV_0000&SID_50071458

    Obviously this is an USB 3.0 host controller. This is weird, because all drivers are installed and in place. Tried to manually point to drivers folder with no success. Tried driver pack solution, same results. Any ideas?
     
  2. spacedrone808

    spacedrone808 [H]Lite

    Messages:
    96
    Joined:
    Mar 28, 2017
    I stand corrected, updated Snappy driver pack to latest and ta-da, usb driver installed without hassels.
    Though it is quite strange, that usb host not detected after installation of official drivers.
     
    Last edited: Apr 19, 2017
    Pieter3dnow likes this.
  3. pchealth 2

    pchealth 2 Limp Gawd

    Messages:
    276
    Joined:
    Feb 10, 2011
    Hello... as I have checked Gigabyte website for this motherboard, it show if installing Window 7 , please use Gigabyte Window USB Installation tools.

    http://www.gigabyte.com/Motherboard/GA-AX370-Gaming-5-rev-10#sp
    You can download the tools on Gigabyte website.
    http://www.gigabyte.com/Motherboard/GA-AX370-Gaming-5-rev-10#support-dl

    Please use the appropiated Window USB Installation tools for AM4 as shown on the website link for this motherboard.
     

    Attached Files:

  4. spacedrone808

    spacedrone808 [H]Lite

    Messages:
    96
    Joined:
    Mar 28, 2017
    Windows 7 installation tool is useless, because it is simply don't work in Windows 7 (integration of drivers ends with error), it works only in Win8/10. So if you want to use it you must run it from Windows 10 or do VM install of Windows 10. That's kind of stupid.

    However, you can still integrate drivers manually via Dism utility or via NTLite app.

    This is last time I am dealing with Gigabyte.
     
  5. pchealth 2

    pchealth 2 Limp Gawd

    Messages:
    276
    Joined:
    Feb 10, 2011
    I did tested using Gigabyte Window Installation tools for AM4 and I can installed Window 7 64 bits SP1 successfully and all of my USB front and rear port works OK.
    1. Using another PC system, I download the Gigabyte USB INstallation tools for AMD AM4.
    http://www.gigabyte.com/Motherboard/GA-AX370-Gaming-K5-rev-10#support-dl
    I place my Window 7 64 bits OS disk on my DVD drive and attached my USB disk.
    I set Source to my DVD driver and destination on my USB disk.
    Note: You must not do the format of your USB disk, let the Window USB INstallation tools do the formatting for you.


    amd usb installation tools.jpg

    amd usb installation tools ok.jpg
    2. Then after I have created an Window 7 64 bits OS image from my USB disk.
    I boot to my UEFI USB disk to install the OS Window 7 on AX370-Gaming 5 motherboard.
    3. After OS installation, I can see my USB 3.0 controller on my device manager already.
    beforedriverinstall.jpg
    4. Then I downloaded all the other chipset driver from Gigabyte website and install the rest of the driver successfully.
    ax370g5 system.jpg
    5. I did check all my usb port front USB 3.0 and rear port and even USB 2.0 front and rear port all working.
    test usb 3.0 front and back.jpg

    Maybe you want to give it a shot for checking.
    Thanks.
     
  6. Nobu

    Nobu 2[H]4U

    Messages:
    2,756
    Joined:
    Jun 7, 2007
    The Gaming k5 has an external chipset for one usb 3.1 type A and one type C port, the Gaming 5 probably has a similar setup.

    I'd think it would be included on the driver CD, but for sure it wont be in the same package as the x370 chipset drivers.