Getting screen tearing with G-Sync 419.67 drivers

Discussion in 'nVidia Flavor' started by Flogger23m, May 10, 2019.

  1. Flogger23m

    Flogger23m [H]ardForum Junkie

    Messages:
    10,034
    Joined:
    Jun 19, 2009
    Noticed I have been getting some screen tearing as of late in a number of games. Frame rates are well within the range of G-Sync, around 60-80 or so when I see it. Have an Acer monitor with G Sync which worked flawlessly since I got it a few years back. Running a RTX 2070 with 419.67 drivers.

    Typically what I used to do if I am recalling correctly is that I enabled G Sync in the global setting for the Nvidia control panel and turn off V Sync in game, and cap frame rates at around 120 if the game allows it. That always seemed to work.

    Not sure if something changed with recent drivers though. Getting a error pop up in the Nvidia control panel G Sync section now though. Anything I should enable/disable to get rid of this?


    g-sync.jpg
     
  2. viivo

    viivo [H]ard|Gawd

    Messages:
    1,309
    Joined:
    Sep 7, 2005
    Is there a particular reason you're using that driver version? A lot can change in two months. The latest is 430.64 - have you tried them just in case there is a difference? It's not as though you'd be prevented from going back if not.
     
    Last edited: May 10, 2019
  3. Auer

    Auer Gawd

    Messages:
    769
    Joined:
    Nov 2, 2018
    It's the latest creator ready driver. I have no tearing with it, RTX2070, LG 4K Freesync.

    https://www.nvidia.com/Download/driverResults.aspx/145178/en-us
     
  4. eclypse

    eclypse 2[H]4U

    Messages:
    3,056
    Joined:
    Dec 7, 2003
    Download the latest or atleast 435.31.

    Download DDU https://www.wagnardsoft.com/forums/viewtopic.php?f=5&t=1707

    Boot into safe mode!

    Open ddu and select GPU and Nvdia. And select uninstall and reboot.

    This will flush your system of all former nvidia drivers. Perfect before installing a new driver to make sure theirs nothing to conflict with the new install.

    On the next boot quickly install the latest driver.
     
    acefightr, AlphaQup and Armenius like this.
  5. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    13,968
    Joined:
    Oct 7, 2000
    what they^^^ said. ddu and install newest driver. then id also turn on the g-sync indicator to make sure its working.
     
  6. Auer

    Auer Gawd

    Messages:
    769
    Joined:
    Nov 2, 2018
    nVidia has 2 sets of drivers and the one the OP is using is the latest for one set, the "Creative Ready". 419.67

    Creator Ready Driver releases are timed to key creative application updates, ensuring the best compatibility and performance for those who depend on PCs for their creative work.

    Creator Ready
    Provides the optimal experience for Autodesk Arnold, Unreal Engine 4.22, REDCINE-X PRO, Adobe Lightroom, and Substance Designer by Adobe

    Performance
    Increases performance in popular creative applications vs. the previous driver branch. Here are some examples of measured gains:

    GeForce RTX 2080

    • Up to 13% in Blender Cycles
    • Up to 9% in Adobe Photoshop CC
    • Up to 9% in Adobe Premiere Pro CC
    • Up to 8% in CINEMA 4D
     
  7. eclypse

    eclypse 2[H]4U

    Messages:
    3,056
    Joined:
    Dec 7, 2003
    :) Maybe he installed the wrong set then?

    Either way. DDU the drivers and start over fresh.
     
    Maddness, Armenius and pendragon1 like this.
  8. Auer

    Auer Gawd

    Messages:
    769
    Joined:
    Nov 2, 2018
    haha you ppl are funny
     
  9. pendragon1

    pendragon1 [H]ardForum Junkie

    Messages:
    13,968
    Joined:
    Oct 7, 2000
    use your big boy words and spit out the point youre trying to make.
     
  10. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    You have to check that checkbox (which is normally for G-Sync over FreeSync but maybe there is a detection problem).
     
    AceGoober and Armenius like this.
  11. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,383
    Joined:
    Jan 16, 2013
    OP I'm still using 419.35 because I know they work properly. There was a stretch there where gsync was not working correctly for me so I'm going to stick with these for a while. And you want Gsync ON and Vsync ON in nvidia CP. Vsync OFF in-game and cap fps 3 below refresh rate if possible.
     
  12. PhaseNoise

    PhaseNoise [H]ard|Gawd

    Messages:
    1,921
    Joined:
    May 11, 2005
    I have occasionally had GSYNC reset itself so it wasn't actually applied, but the control panel said it was. Toggling it off and on would fix it. I haven't seen it in a while, but it does happen sometimes.
     
  13. SvenBent

    SvenBent 2[H]4U

    Messages:
    3,129
    Joined:
    Sep 13, 2008
    are you sure what you are experince is tearing
    So many ppl are confussing tearing with microstutter
    does it appear like the pictue on the screen are torn in 2 half's ?
     
  14. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    To clarify, the box that says "enable settings for selected display" should be checked.
     
    AceGoober, Armenius and Auer like this.
  15. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    18,650
    Joined:
    Jan 28, 2014
    OP does not mention the Creative Ready driver, though. You wouldn't need it unless you need hardware acceleration in the productivity programs it lists.
    It would help if OP mentioned what monitor he was using.
     
  16. Auer

    Auer Gawd

    Messages:
    769
    Joined:
    Nov 2, 2018
    The monitor model # is in the op screenshot

    https://www.acer.com/ac/en/US/content/predator-model/UM.HX1AA.001
     
  17. gerardfraser

    gerardfraser Gawd

    Messages:
    911
    Joined:
    Feb 23, 2009
    Tear free gaming OP here is how to do just that.EDIT:Thanks cybereality

    G-SYNC instructions Nvidia/AMD for Tear Free Gaming

    Enable G-SYNC/G-SYNC Compatible Monitors(Freesync) in the Nvidia Control Panel
    * Open the Nvidia Control Panel
    * Open Display Section
    * Click Setup G-SYNC
    * Check Enable G-SYNC
    * Insert the dot to, "Enable G-SYNC for windowed and full screen mode"
    * Freesync Monitor check mark in box "Enable settings for the selected display model"
    * Click Apply
    * Open 3D Settings
    * Click Manage 3D Settings
    * Click the Global Settings tab
    * Open Monitor Technology
    * Choose G-SYNC/G-SYNC Compatible Monitors
    * Vertical sync choose "On for tear free gaming,Off and Fast can still having tearing even on high refresh rate monitors"

    Settings in Game when using G-SYNC/G-SYNC Compatible Monitors(Freesync)

    * Use “Fullscreen” or “Exclusive Fullscreen” mode (some games do not offer this option, or label borderless windowed as fullscreen,use appropriate G-Sync Mode )
    * Disable all available “Vertical Sync,” “V-SYNC” and “Triple Buffering” options.
    * If an in-game or config file FPS limiter is available, and framerate exceeds refresh rate:
    Set 3 FPS limit below display’s maximum refresh rate (57 FPS @60Hz, 97 FPS @100Hz, 117 FPS @120Hz, 141 FPS @144Hz, etc).
    * If an in-game or config file FPS limiter is not available and framerate exceeds refresh rate:
    Set 3 FPS limit below display’s maximum refresh rate(Via third party Software RTSS)

    Enable AMD’s FreeSync: You need a compatible Radeon card or APU and compatible driver(turning on freesync location may vary with driver)

    * Open Monitor’s OSD settings and turn on freesync mode of your choosing
    * Open AMD Radeon Settings
    * Click on the Radeon Settings
    * Select Radeon Settings from the Programs menu
    * Select Display
    * Confirm that the Radeon FreeSync turned ON(If not on click to turn on)
    * Click Apply
    * Radeon™ FreeSync™ can be adjusted on a per application profile basis
    * Enable VSync/Enhanced Sync in control panel(Note:AMD drivers, the force V-Sync On only works on OpenGL (which barely any games use on Windows). So you have to turn V-Sync on for each game.)
    Enhanced Sync does not replace Vsync, but rather works with it. “Enhanced Sync disables Vsync when frame rate drops below a monitor's refresh rate
    * Click Apply
    * Close the AMD Radeon Control Panel

    Settings in Game when using compatible Radeon card or APU(Freesync)

    * Use “Fullscreen” or “Exclusive Fullscreen” mode (some games do not offer this option, or label borderless windowed as fullscreen )
    * Enable all available “Vertical Sync,” “V-SYNC” and “Note:Enhance Sync is Triple Buffering in AMD settings” options.
    * If an in-game or config file FPS limiter is available, and framerate exceeds refresh rate:
    Set 3 FPS limit below display’s maximum refresh rate (57 FPS @60Hz, 97 FPS @100Hz, 117 FPS @120Hz, 141 FPS @144Hz, etc).
    * If an in-game or config file FPS limiter is not available and framerate exceeds refresh rate:
    Set 3 FPS limit below display’s maximum refresh rate(Via third party Software RTSS)

    Mouse setting for G-SYNC/G-SYNC Compatible Monitors(Freesync)

    * If available, set the mouse’s polling rate to 1000Hz,
    which is the setting recommended by Nvidia for high refresh rate G-SYNC/G-SYNC Compatible Monitors(Freesync),
    and will decrease the mouse-induced input lag and microstutter experienced with the lower 500Hz and 125Hz settings at higher refresh rates.
     
    Last edited: May 15, 2019
    Solhokuten, AceGoober, risc and 5 others like this.
  18. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    Nice guide.

    One thing that is not obvious: on AMD drivers, the force V-Sync On only works on OpenGL (which barely any games use on Windows). So you have to turn V-Sync on for each game.
     
  19. gerardfraser

    gerardfraser Gawd

    Messages:
    911
    Joined:
    Feb 23, 2009
    Wow thanks for the tip,man it proves I have not gamed on my AMD GPU's in a long time and I did not know vsync only working on openGl .
     
    AceGoober and cybereality like this.
  20. IdiotInCharge

    IdiotInCharge [H]ardForum Junkie

    Messages:
    11,661
    Joined:
    Jun 13, 2003
    Doesn't this impart input lag?
     
  21. Furious_Styles

    Furious_Styles [H]ard|Gawd

    Messages:
    1,383
    Joined:
    Jan 16, 2013
    I think I'm going to update because there are security vulnerabilities with those before the most recent. Just a PSA for anyone else who hasn't heard yet.
     
  22. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    I don't have any lag numbers, I just know it is needed to remove tearing.
     
  23. IdiotInCharge

    IdiotInCharge [H]ardForum Junkie

    Messages:
    11,661
    Joined:
    Jun 13, 2003
    It's framerate dependent, but V-Sync in general imparts framepacing issues, which is logical when you break it down. Essentially, you can render 60FPS, but if they're not all aligned with the refresh signal, you have up to one frame of lag- and that 'up to' part can vary which means that you have some persistent and unpredictable lag. Variable v-sync is designed to fix this; while you do wind up enabling v-sync in the driver for G-Sync, for example, this doesn't actually enable v-sync; you have to turn v-sync on in game to do that.

    Think: Variable V-Sync, i.e. G-Sync and FreeSync, are designed to eliminate (or significantly minimize) tearing with V-Sync off in game. No tearing and no input lag, that's the promise.

    The overriding point is this: if you're turning on V-Sync in game, you might as well not have Freesync / G-Sync.


    [I'll note that I do believe that you understand most if not all of this; I'm speaking for the thread and for users that may not :) ]
     
  24. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    That's an interesting point, I wasn't aware that was how it worked.

    I understand what V-Sync and G-Sync are, I just assumed that the driver would handle the correct behavior even if V-Sync was enabled in the game.
     
  25. IdiotInCharge

    IdiotInCharge [H]ardForum Junkie

    Messages:
    11,661
    Joined:
    Jun 13, 2003
    For Freesync, it may. I don't really know and can't really test it myself. However, for G-Sync, that's what I've been able to discern. I can also say that this is amplified far more at 60Hz than at 120Hz+, so even if that lag is present, it may not be noticeable.
     
    cybereality likes this.
  26. Shadowed

    Shadowed Limp Gawd

    Messages:
    496
    Joined:
    Mar 21, 2018
    iirc, Vsync enabled in NCVP + Gsync enabled does not act like Vsync; as long as vsync is disabled in game. As long as it is set up like that, Gsync will not add measurable input lag.

    https://www.blurbusters.com/gsync/gsync101-input-lag-tests-and-settings/14/ (reposted info)

    I was also on 419.67 and noticed Gsync will be occasionally be disabled. That message that appears for you saying your display is incompatible has happened to me before on 419. Thankfully, powering off, unplugging monitor and PC fixed the issue. I own 2 Gsync monitors and when this issue occurred, it effected all displays. Definitely get off 419. Not worth it.
     
  27. Comixbooks

    Comixbooks Ignore Me

    Messages:
    13,684
    Joined:
    Jun 7, 2008
    lol Pretty sure Battlefield V and Call of Duty won't run with those old drivers because I tried using that same set a while back until I found games wouldn't run at all.
     
  28. Hoover1979

    Hoover1979 n00b

    Messages:
    2
    Joined:
    Jul 22, 2018
    I recently bought an ASUS VG278QR monitor and connected it to my Gigabyte Xtreme Gaming GTX1080 Waterforce Rev 2 video card via a Displayport cable, set up G-Sync in Nvidia Control Panel and made sure it was enabled in the monitor's own GUI, but I still get tearing if I have G-Sync enabled, even if I cap the frame rate to 165FPS to be inline with the 165Hz refresh rate of the screen. The only way to kill the tearing is to also enable vsync and set it to adaptive.

    I thought G-Sync was an alternative to vsync so you can kill the god awful tearing without having to endure vsync input lag. Even when I set some games to use fast sync set to adaptive (D3D9, D3D10 and D3D11, as fast sync doesn't work on OpenGL, Vulkan or D3D12), and I still get some tearing and the overall smoothness of motion is still noticeably compromised. In effect, games are only tear-free and have smooth motion when vsync is used in conjunction with G-Sync.
     
  29. cybereality

    cybereality [H]ardness Supreme

    Messages:
    4,697
    Joined:
    Mar 22, 2008
    You must force V-Sync On in Nvidia 3D Settings (on this same page select G-Sync for monitor technology) and then select V-Sync Off in the in-game settings.

    Do not use FastSync or AdaptiveSync, they are unnecessary.

    Use RivaTuner to select a frame cap of 2 frames less than your refresh rate (e.g. 142 for a 144Hz monitor).
     
    kalston, Armenius, AceGoober and 3 others like this.
  30. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    18,650
    Joined:
    Jan 28, 2014
    Also, if you're setting up your games to run as fast as possible at or over the monitor's refresh rate then G-SYNC is useless to you. Turn up the game settings to get it to run at an average of 70% of your max refresh rate (115 FPS for 165 Hz) and you'll see better results.
     
    AceGoober and eclypse like this.
  31. eclypse

    eclypse 2[H]4U

    Messages:
    3,056
    Joined:
    Dec 7, 2003
    Above is nice info but for us that want best image quality and smoothness.. gsync is what we want.