G-Sync tearong above 144 FPS

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
In Grim Dawn, I am now getting framerates occasionally beyond 144. This is causing tearing. V-Sync is off in the games video options. If I turn it on this problem goes away, but is that the right approach to take? Are there other setting in the Nvidia Control Panel that I am not seeing that should be adjusted?

Thanks for helping with my questions the past couple of days.
 

skiddierow

Limp Gawd
Joined
Aug 1, 2013
Messages
300
In the most recent driver release, NV changed the nvcp global profile default to "Use application setting" when Gsync is active.

You should turn on Vsync in-game, or in the global profile set "Vsync on" or "Vsync fast" to stop tearing above 144Hz.


Vsync on will cap gpu output to max refresh, with a slight input lag penalty at max refresh.

Vsync fast will continue to draw beyond the max refresh, for an input lag reduction, but increase in power consumption / heat.
 

Odellus

[H]ard|Gawd
Joined
Dec 25, 2010
Messages
1,696
cap framerate to 138 using afterburner. if you turn vsync on in the nvidia control panel, gsync will behave exactly like vsync at the maximum refresh rate of your monitor. if you cap it to 138, you get the benefits of gsync and no additional input lag. fast sync is only advisable if you're getting extreme framerates (200+).
 

Stev3FrencH

Limp Gawd
Joined
Jan 2, 2015
Messages
334
cap framerate to 138 using afterburner. if you turn vsync on in the nvidia control panel, gsync will behave exactly like vsync at the maximum refresh rate of your monitor. if you cap it to 138, you get the benefits of gsync and no additional input lag. fast sync is only advisable if you're getting extreme framerates (200+).
This is how I handle it
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
In the most recent driver release, NV changed the nvcp global profile default to "Use application setting" when Gsync is active.

You should turn on Vsync in-game, or in the global profile set "Vsync on" or "Vsync fast" to stop tearing above 144Hz.


Vsync on will cap gpu output to max refresh, with a slight input lag penalty at max refresh.

Vsync fast will continue to draw beyond the max refresh, for an input lag reduction, but increase in power consumption / heat.
What was the nvcp global profile Vertical Sync default previously?

I tried this. Enabling V-Sync does help. However, it seems to add mouse lag, or something, even at 144 Hz. The mouse feels sluggish.

Edit: Setting Vertical Sync to Fast seems to help. I don't notice any mouse lag, and the tearing seem to have gone away.
 
Last edited:

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
cap framerate to 138 using afterburner. if you turn vsync on in the nvidia control panel, gsync will behave exactly like vsync at the maximum refresh rate of your monitor. if you cap it to 138, you get the benefits of gsync and no additional input lag. fast sync is only advisable if you're getting extreme framerates (200+).
This is how I handle it
How exactly do I cap the framerate? In MSI Afterburner, I tried Setting -> Monitoring -> Framerate, and set the Maximum limit. However, in game FPS are still going beyond that.

Also, why choose 138 instead of 144?

Thanks for your help.
 

Stev3FrencH

Limp Gawd
Joined
Jan 2, 2015
Messages
334
How exactly do I cap the framerate? In MSI Afterburner, I tried Setting -> Monitoring -> Framerate, and set the Maximum limit. However, in game FPS are still going beyond that.

Also, why choose 138 instead of 144?

Thanks for your help.
You need to set the cap in RTSS, an add on for MSI Afterburner. I would set it to some number under the max refresh rate so you don't experience the input lag induced by vsync.
 

Odellus

[H]ard|Gawd
Joined
Dec 25, 2010
Messages
1,696
How exactly do I cap the framerate? In MSI Afterburner, I tried Setting -> Monitoring -> Framerate, and set the Maximum limit. However, in game FPS are still going beyond that.

Also, why choose 138 instead of 144?

Thanks for your help.
Preview of NVIDIA G-SYNC, Part #2 (Input Lag) | Blur Busters

check comments at the bottom.

"fps_max 130 — works good
fps_max 135 — works good
fps_max 138 — works good
fps_max 140 — slight hints of extra lag
fps_max 142 — as bad as fps_max 143"

settings -> on-screen display -> more at the bottom right. set it globally or add individual exes using the + at the bottom left. framerate limit is on the right, hit enter after you type in a number to make it save.
 

evo2point0

n00b
Joined
May 18, 2016
Messages
53
Preview of NVIDIA G-SYNC, Part #2 (Input Lag) | Blur Busters

check comments at the bottom.

"fps_max 130 — works good
fps_max 135 — works good
fps_max 138 — works good
fps_max 140 — slight hints of extra lag
fps_max 142 — as bad as fps_max 143"

settings -> on-screen display -> more at the bottom right. set it globally or add individual exes using the + at the bottom left. framerate limit is on the right, hit enter after you type in a number to make it save.
That's an old and outdated article. It was written before Nvidia updated G-Sync.
 

Odellus

[H]ard|Gawd
Joined
Dec 25, 2010
Messages
1,696
That's an old and outdated article. It was written before Nvidia updated G-Sync.
doesn't matter, it still works this way. there is very obvious input lag when using gsync near or at the maximum refresh rate of the monitor.
 

kalston

[H]ard|Gawd
Joined
Mar 10, 2011
Messages
1,093
I haven't noticed any change either. Still hitting 144fps if I don't use a framerate cap. I haven't done extensive input lag testing lately (and the lag wouldn't be huge at 144fps either), but I still have the habit of capping my fps slightly below that in games where it matters to me.
 

Armenius

Fully [H]
Joined
Jan 28, 2014
Messages
22,822
In Grim Dawn, I am now getting framerates occasionally beyond 144. This is causing tearing. V-Sync is off in the games video options. If I turn it on this problem goes away, but is that the right approach to take? Are there other setting in the Nvidia Control Panel that I am not seeing that should be adjusted?

Thanks for helping with my questions the past couple of days.
Change from V-Sync to Fast Sync in the NVIDIA Control Panel, or DSR the resolution up to where you're no longer going above 144 FPS. Use that extra performance to your advantage.
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
Change from V-Sync to Fast Sync in the NVIDIA Control Panel, or DSR the resolution up to where you're no longer going above 144 FPS. Use that extra performance to your advantage.
I tried Fast Sync. It was much better than V-Sync. It is still noticeable though. I need to figure out how to cap the framerate.

I am unsure about DSR as the frame rates fluctuate quite a bit. Most of the time they are around 100 to 120. Sometime they are in the upper two hundreds, but if a lot is going on they can still go down to fifty or sixty.
 

Tup3x

[H]ard|Gawd
Joined
Jun 8, 2011
Messages
1,866
Dxtory will do the job too and it supports Vulkan too on top of DX12.
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
You need to set the cap in RTSS, an add on for MSI Afterburner. I would set it to some number under the max refresh rate so you don't experience the input lag induced by vsync.
I set it to 138 in RTSS for the .exe I want. However, it seems to have no effect in game.
 

MavericK

Zero Cool
Joined
Sep 2, 2004
Messages
29,459
Unless something has changed, you can use nVidia Inspector to globally limit the framerate. Just set it to 144 FPS or something and call it good.
 

schizo

[H]ard|Gawd
Joined
Nov 6, 2004
Messages
1,500
My understanding was that the right way to handle this was:

G-Sync in NV control panel: On
V-Sync in NV control panel: On
V-Sync in-game: Off

The way this was explained to me, assuming a 144Hz monitor, is that from 1-143 FPS g-sync would be active as normal. At >=144 FPS, g-sync would be disabled and v-sync active, so you don't see tearing. Is that info outdated?
 

Jumpem

Gawd
Joined
Dec 1, 2000
Messages
727
My understanding was that the right way to handle this was:

G-Sync in NV control panel: On
V-Sync in NV control panel: On
V-Sync in-game: Off

The way this was explained to me, assuming a 144Hz monitor, is that from 1-143 FPS g-sync would be active as normal. At >=144 FPS, g-sync would be disabled and v-sync active, so you don't see tearing. Is that info outdated?
When I turned V-Sync on in Nvidia Control Panel the input lag was noticeable at all times. Even below 144 Hz.
 

kalston

[H]ard|Gawd
Joined
Mar 10, 2011
Messages
1,093
My understanding was that the right way to handle this was:

G-Sync in NV control panel: On
V-Sync in NV control panel: On
V-Sync in-game: Off

The way this was explained to me, assuming a 144Hz monitor, is that from 1-143 FPS g-sync would be active as normal. At >=144 FPS, g-sync would be disabled and v-sync active, so you don't see tearing. Is that info outdated?
This is still correct and how I do it. Although v-sync in game setting doesn't matter, g-sync just overrides everything. In games where my framerate is frequently higher than 144 and I care about input lag, I just cap the fps at 135 or so.
 

schizo

[H]ard|Gawd
Joined
Nov 6, 2004
Messages
1,500
You could cap the framerate, or just allow it to switch to vsync at >=144 FPS to eliminate tearing. I suppose that would introduce a small amount of input lag at very high framerates, but as I'm not playing competitive CS:GO I don't find it noticeable. And if you are an esports gamer, that's what fast sync is for anyway.
 
Top