File Permissions file permissions

Shockey

2[H]4U
Joined
Nov 24, 2008
Messages
2,204
Ok so i copied a video to my NAS (from laptop) nas is running openIndiana zfs

I tried loading up the video on my HTPC and got access denied.

Also tried creating a folder on HTPC in the share. Can not access it from laptop

NAS ls command of the download directory shows all files belong to the same user and group.

sudo ls -l Downloads/
total 174
drwxrwxrw-+ 5 Jeremy staff 5 2013-02-23 00:14 xxxxxxxxxxxxxxxxxxxxx
drwxrwxr-x+ 12 Jeremy staff 12 2013-02-28 21:37 Comxxxxxxxxxxxxxxxxxxx
drwxrwxrw-+ 2 Jeremy staff 2 2013-02-23 00:14 In Progress
drwx------+ 2 Jeremy staff 2 2013-02-28 21:29 xxx
drwx------+ 2 Jeremy staff 2 2013-03-16 13:35 test folder
d---------+ 2 Jeremy staff 3 2013-03-15 17:02 Awesome movie i wanting to watch.
d---------+ 3 Jeremy staff 56 2013-03-16 13:33 Another Awesome movie i am wanting to watch on HTPC
Jeremy staff 3 2013-02-22 19:05 xxxxxxxxxxxxx


Anyone shed some light on what i am doing incorrectly here or what i should change or check?


Thanks
 

/dev/null

[H]F Junkie
Joined
Mar 31, 2001
Messages
15,190
Not positive about this. Maybe. Running OpenIndiana as OS. Know how i could check?

In openindiana I have no idea.

Try "setfacl -m -u:<someuser>:r <filename>" or whatever the equivalent is in openindiana.
 
Top