Experiencing ping spikes(lag) suddently after installing Windows update/Visual C++ 2012 Redistributa

Discussion in 'General Gaming' started by PontiacGTX, Jan 6, 2019.

  1. PontiacGTX

    PontiacGTX Gawd

    Messages:
    640
    Joined:
    Aug 9, 2013
    Well I remember I was playing just fine Tom Clancy's Rainbow Six Siege, there were No ping spikes, the ping was always around 100-120 and there wasnt lag, I remember I needed to install some application(I believe also updated MSVS) but after the installation of Visual C++ 2012 OR update KB4483232 the game had an increased ping from no where, I thought It would be the driver,the game or perhaps my internet connection then decided to try Titanfall 2 and and after installing the driver again, the game also has a lag spike, So I decided to do a system restore, I will see if it changed anything but the problem is that it restored to the date I installed the Visual C++ 2012 package.

    A note I had disabled the automatic updates and I do the updates manually probably skipped some of them but I didnt have a problem until 4-6days ago

    Do you have some advice I could try to find out why the connection has lag? some program to monitor the background?
     
  2. gamerk2

    gamerk2 [H]ard|Gawd

    Messages:
    1,440
    Joined:
    Jul 9, 2012
    Its *possible* that your ethernet driver is using whatever the latest installed MSVC code, and installing MSVC 2012 is a problem. You can try installing whatever the latest MSVC Redistributable package is and see if performance increases. Alternatively you can just uninstall the 2012 package; 99.9% of stuff runs fine with just the latest package installed anyways.
     
  3. Denpepe

    Denpepe Gawd

    Messages:
    841
    Joined:
    Oct 26, 2015
    All I can say is that after intalling the 1809 update to win10 my internet also has some strange lag at times, even with the latest intel drivers. Can be quite annoying when playing wow and dying because th game does not know you are miles away from where it thinks you are.
     
  4. PontiacGTX

    PontiacGTX Gawd

    Messages:
    640
    Joined:
    Aug 9, 2013
    I reinstalled the game and the game install its own Microsoft Visual C++ version 2012, and 2015 BUT it did not fix the problem Including the ports as ubisoft suggested BUT doesnt work..tried most of the ubisoft suggestion but doesnt work seems like Windows is the problem...
    I noticed this
    6G0ySET.jpg
    I use 1709