Edge blocking screensaver?

Pegi

Limp Gawd
Joined
May 31, 2005
Messages
229
I added a new (administrator) user to my old computer and gave it to my husband for his daily usage. When the machine first boots up, screen saver works normally. Once he actually opens Edge to browse, that effectively seems to block all future screen saver activity. Whether Edge is opened, closed, or minimized, it doesn't matter. No more screen saver, whether it is one of the Microsoft built-ins or Photos.

He does have CH Products flight sim yoke, pro pedals, and throttle quadrant installed, which I know from browsing so very many threads seems to cause problems. However, despite this, the screen saver does come on initially. It's just when Edge is opened that first time that this problem manifests itself.

It's been suggested that the combination of flight sim accessories *and* Geforce Experience causes this issue. I have uninstalled Geforce Experience. Still no joy.

I have used this computer for 3 years with no issues myself; the flight sim accessories are the only difference. He has no other program installed that I haven't used myself. It's not an earthshaking problem, but I would just like the screensaver working. I've been googling for days and haven't come up with any other thing to try. Any flight simmers out there who can offer guidance?
 

B00nie

[H]F Junkie
Joined
Nov 1, 2012
Messages
9,076
Do you really need another reason not to use Edge? I mean ffs.
 

Pegi

Limp Gawd
Joined
May 31, 2005
Messages
229
Do you really need another reason not to use Edge? I mean ffs.
Honestly, while I'm not even sure if Edge is the instigator of this particular problem just because it *seems* like it is, I like Edge and actually prefer it. The purpose of asking the question is not only to validate if this is the problem based on others' experiences but to see if anyone had a workaround; and, if not, it's a small thing to learn to live with.
 

defaultluser

[H]F Junkie
Joined
Jan 14, 2006
Messages
14,210
I have periodic problems running the screensaver on my HTPC, and I get around it by Restarting Windows Explorer.
 

Pegi

Limp Gawd
Joined
May 31, 2005
Messages
229
I have indeed tried restarting the browser, clearing the cache, all the usual suspects. I was just wondering if some flight simmers might have found newer products, maybe from Logitech, to play better with screen savers. Seems like this has been a longstanding problem, with some having various measures of success with tinkering with settings; and at this point, I'll try any suggestions. But I'd gladly buy my husband new components, but he's resistant (crazy, I know).
 
Top