Early 2011 macbook issue

ZrRock

Limp Gawd
Joined
Aug 31, 2011
Messages
396
I have an early 2011 13" macbook pro with an extremely odd issue. When it is plugged in, the power button doesn't function, but when it is unplugged, the button functions completely normally. Does anyone have any idea why this may be?
 

ZrRock

Limp Gawd
Joined
Aug 31, 2011
Messages
396
That is what 2 people said on the apple forums too, i will try this when I get home, but how would it explain the power button working when on ac power?
 

ZrRock

Limp Gawd
Joined
Aug 31, 2011
Messages
396
So the SMC reset works for a SINGLE power press to turn the unit on while plugged in, once in OSX the power button is non functional again, and after shutdown without another smc reset nothing works.
 

Cbshahji

[H]ard|Gawd
Joined
Jul 3, 2010
Messages
1,970
i've early MBP as well and i tried to see if i've that problem, but it works fine with my system (lucky me yay). i strongly believe it's your hardware problem. and for your shake i hope it's ODD and not MBP. anyway mind if i ask why do you need another ODD and also is it usb powered?
 

ZrRock

Limp Gawd
Joined
Aug 31, 2011
Messages
396
i've early MBP as well and i tried to see if i've that problem, but it works fine with my system (lucky me yay). i strongly believe it's your hardware problem. and for your shake i hope it's ODD and not MBP. anyway mind if i ask why do you need another ODD and also is it usb powered?

What are you talking about? Odd?
 

Cbshahji

[H]ard|Gawd
Joined
Jul 3, 2010
Messages
1,970
oh NM i got two thread mixed up (sorry about that(, but like i said for you it's most likely the hardware issue inside the machine.
 
Top