Drive won't boot after slave drive was removed


Jan 10, 2007
This is a long post, but it is a VERY strange problem

I have been having some major problems with the same PC. This is my mom's computer and it has the same problem, over and over and

Here is the system setup:

MSI K7N Delta2 Platinum MOBO
AMD Athlon 2800+
1Gb PC3200 RAM (2, 512 sticks)
1000/100/10 Mbps on-board LAN
160GB Western Digital IDE ATA100 (Primary Master) (NTFS)
120 GB WD IDE ATA100 (2 drives) (Primary Slave & Secondary Master) (NTFS)
8x Lite-On IDE DVD+-R/RW (Secondary Slave)
Linksys USB Wireless G network adapter (used because the built-in NIC won't work now..)
3.5” floppy W/ 9-in-1 USB Media Reader
17” LCD Monitor
XP Professional with all updates
Norton AV 2005

The original install did not have the 2 120GB drives, they were added after the setup was complete. The 160Gb drive is partitioned into 40Gb and 120Gb. The 40Gb being the system drive and the other for storage.

I installed XP Pro, then Norton AV 2005 (Google 6 month free version) then ran updates for XP. I then installed all the software that was needed (open office, GIMP, MS Money, etc). Next the 2 120GB drives were installed and shared on the network. I used these extra drives as backup for Office files and MS Money files. Everything seemed to be working well.

I then needed to re-flash my Linksys router (WRT54G). I installed an open source firmware, for more control. To flash the router, I disconnected all cables from the router and ran a direct cable to my PC. The flash worked great. I then hooked the patch cables back up as the were before (exactly as before, all cables going to a Gigabit switch, then an uplink from the switch to the router), my PC would not get back on line. I tried disabling the NIC, re-installing it, changing the IP addy, etc. I worked on this for 3+ hours.

After being disabled, the NIC, on the mobo, was enabling itself on reboot. It was also setting it's own IP addy to something unknown (It turned out to be an ICANN DNS in Philly, I think). No matter what I did, the IP address would not work and I couldn't get access to the net. I don't remember if I could email, as I used web-mail at that point. I do believe that I could ping..

The strange thing is that this is the second time I have had this NIC issue. It happened months before on this same PC and I thought it was a Virus/trojan/spyware because it was setting the IP addy to the same address all the time. Fearing the worse here, I backed up data on my PC and did a 7 pass DoD level wipe on my HDD.

I re-installed everything, the same as above, and had the NIC issue AGAIN. Not wanting to deal with this again, I installed a Linksys USB Wireless G network adapter and was able to get net access.

I found another 160GB drive & wanted to check its contents. I disconnected all the HD's from my machine (power and IDE cable), hooked the new drive up as Pri Master, and ran the OS that was on there. This drive was an old XP Install from a few months ago. I burned some files to DVD, re-booted with a DBAN CD (hard drive wiping utility), and wiped the only installed HD (which was the new HDD). I then removed the CD and powered down.

I then removed the “new HDD”, re-connected the 3 HDD's (all cables were place EXACTLY AS BEFORE!!), powered back up. The system hung. It finally booted after sitting there for 10 mins detecting the IDE HDD's. After this initial delay, all seemed ok.

I decided that I wanted to remove the 2 120GB drives and install the extra 160. I backed up the 120's across the network and powered down. I disconnected the IDE cable from the Primary Master HDD, placed the DBAN CD in the DVD drive and wiped the two 120's. I removed the 2 120 drives and the DBAN CD.

I then connected the original 160 (which had the OS on it), and tried to boot and the computer hung while looking for the IDE drives. After an unknown period of time, it came to a screen that said this:

Now I am stuck trying to figure out what is wrong with this PC. There are no words that come close to describing how angry I am. I would like to restore the dist and pull some data off of it. Any suggestions as to how to do this?