disappearing Surround Audio in Doom3 workaround...

thujone

Limp Gawd
Joined
Mar 13, 2003
Messages
203
i've seen a bunch of ppl having this problem and thought there should be a post on a workaround method a bunch of ppl have found... think it might cut down on the # of identical posts...

anyway... when the audio cuts out on you... just hit esc and go to the system menu... in there switch the Yes on Surround Audio to No and your sound should come back... you can then switch back to Yes and keep playing.

Hopefully there will be an official solution for this soon.

but i hope this helps some ppl for now.
 

Therac-25

n00b
Joined
Jul 28, 2004
Messages
14
thujone said:
i've seen a bunch of ppl having this problem and thought there should be a post on a workaround method a bunch of ppl have found... think it might cut down on the # of identical posts...

anyway... when the audio cuts out on you... just hit esc and go to the system menu... in there switch the Yes on Surround Audio to No and your sound should come back... you can then switch back to Yes and keep playing.

Hopefully there will be an official solution for this soon.

but i hope this helps some ppl for now.

A better solution is to bind a key to s_restart (which restarts the sound subsystem -- this is what you're doing in the case where you toggle the surround sound on and off).

At the console (Ctrl+Alt+~) type bind home s_restart and hit that whenever the sound dies.
 

thujone

Limp Gawd
Joined
Mar 13, 2003
Messages
203
even better.

i'll definitely have to set this up ASAP.

for a game that hinges on sound this much this is a pretty massive pain in the ass...
 
Top