Digital phone adapter + Router

MaMMa

Supreme [H]ardness
Joined
Aug 11, 2004
Messages
6,778
I just got digital phone service with SunRocket and since then, my net has been so slow and wifi signals are crap. When I remove the phone adapter, everything speeds up agian, connections are "excellent" and I can get connected with everyone on torrents.

I recieved the Linksys SPA2102 - Phone Adapter with Router and 2 free cordless phones in their package. This adapter gets hooked directly to my cable modem, then another cat5 cable to my wireless router (Linksys WRT54GX).

The phone adapter's IP is 192.168.0.1 and the wifi router is 192.168.1.1

I have my ports forwarded as I did before I got the digital phone and it worked fine. Now it does not. I checked out the settings and this is what I see:

phone%20adapter.jpg


wifi.jpg



The IPs are different in the 2 routers. The phone adapter has 192.168.0.1 and the wifi has 192.168.1.1, they do not match up when I forward my ports so its going through 2 routers :confused: I'm thinking that there is a conflict somewhere.

Is there anyway to disable the phone adapter's router and just go through my wifi router? If not, how can I fix this issue?

Once agian, after I disconnect the phone adapter, my wifi connection is excellent, speeds are awsome and I can connect to torrents. With the phone adapter in place, my net is fubar, wifi connection is poor and no torrent connections.

Please help me, I have a one year contract with this digital phone service :(
 

jpochedl

Limp Gawd
Joined
Jun 7, 2004
Messages
345
You really don't want to have two NAT routers back to back... As I see it, you have two options...

1) Ditch the WRT54GX router and go buy a simple wireless access point and switch (if you have wired clients that need to be hooked up). That's a good option if you're looking to upgrade to an 802.11n capable wireless access point. :)

2) Disable the DHCP and router features of the WRT54GX and hook a LAN port from the SPA2102 to a switch port of the WRT54GX (NOT to the WAN port).. This should essentially turn tthe WRT54GX into a switch/AP... I'm not sure if either of the routers support auto-crossover, so if at least one of them doesn't then you'd need a cross-over cable to make this work... (Easiest way to check is just plug them together and see if the link lights light...)

Hope that helps....
 

Jay_2

2[H]4U
Joined
Mar 20, 2006
Messages
3,583
what frequency do the phones run on? may interfere with the wireless signal
 

MaMMa

Supreme [H]ardness
Joined
Aug 11, 2004
Messages
6,778
The phones are GE 5.8 ghz. How do I find out what frequency they are on?

I'll try suggestion #2 right now, if that does not work then I guess I'll have to get some new hardware. They both sound promising, Thanks!
 

MaMMa

Supreme [H]ardness
Joined
Aug 11, 2004
Messages
6,778
You really don't want to have two NAT routers back to back... As I see it, you have two options...

1) Ditch the WRT54GX router and go buy a simple wireless access point and switch (if you have wired clients that need to be hooked up). That's a good option if you're looking to upgrade to an 802.11n capable wireless access point. :)

2) Disable the DHCP and router features of the WRT54GX and hook a LAN port from the SPA2102 to a switch port of the WRT54GX (NOT to the WAN port).. This should essentially turn tthe WRT54GX into a switch/AP... I'm not sure if either of the routers support auto-crossover, so if at least one of them doesn't then you'd need a cross-over cable to make this work... (Easiest way to check is just plug them together and see if the link lights light...)

Hope that helps....

Yes, it worked!!! Option #2. I did not need a crossover cable :D THank you!

Now I gotta mess with the phone frequencies... What can I do to get them on different frequencies? I changed the channel settings in the router, there is 12 i think. Is that the only thing I can do?
 
Top