DHCP server questions

jeffmoss26

2[H]4U
Joined
Aug 1, 2002
Messages
2,267
Trying to figure some stuff out at work-
Right now, we are using 128.1.1.x. 128.1.2.x, 128.1.4.x, and 128.1.5.x for static IP addresses and 128.1.3.x for DHCP. With our upcoming Cisco phone system, we are concerned about having enough IP addresses.
I was trying to add 128.1.6.x to the DHCP server to push addresses out to the phones, but it does not seem to be that simple. Is this doable, or am I opening up a can of worms?
 
128.x.x.x ! why are you using that range?

I assume you are using Cisco Switches? What is doing the L3 (what is your default gateway?)

You need to create a new VLAN and add a helper address to point to the DHCP server.
 
Last edited:
I couldn't tell you why we are using that range. It was done LONG before me.
The default gateway is our Watchguard firewall.
We are using Dell switches and no VLANs...I know, I know. Not my choice.
 
You will want VLANs for your VoIP setup. Choice won't have much to do with it. Are the switches POE enabled or are you planning on either POE injectors or the bricks plugged into each phone?

With what we saved in not buying the power bricks we were able to replace all of our switches so that we had POE switches.

We had to make sure our DHCP servers had a NIC for each DHCP scope. Though that was Windows servers handing out IP addresses.
 
We have 3 POE switches in the MDF which serve the majority of the phones, another 2 in IDFs around the building.
15-20 phones served by IDFs on the shop floor use power bricks. We currently have a 3COM NBX system which is also voip.
 
You need to remember that there are two parts to this.

Getting the DHCP server to ASSIGN an ip on that range,
and THEN making that range work, either expand your subnet or use a device to route between them. By default you can probably pretty easily make it assign IP's in the new range but you probably wont be able to talk to anything else.


Also I HIGHLY suggest you use a proper internal range. Get rid of all static assignments (turn them into DHCP Reservations) and just use a big subnet like a /21 (255.255.248.0) that would give you 8 ranges of 255, like 192.168.0.1 - 192.168.7.255 would all be on one subnet and could all use the same default gateway (or you could use 192.168.8.1 - 192.168.15.255, and so on)
 
Last edited:
You should look into fixing that IP scheme... wow. Also, VLANs are your best friends.
 
RE-IP.. Ya it sucks, but needs to be done

Also take a look at picking up a 6224 l3 switch from dell. easy to configure and I have example configs for VOIP if you ever wanted to see them
 
IP re-addressing is not gonna happen, 500+ devices...this was created long before my boss or myself.
We actually have 6248 switches for our data, but they are not POE.
 
IP re-addressing is not gonna happen, 500+ devices...this was created long before my boss or myself.
We actually have 6248 switches for our data, but they are not POE.

If you have a 6248 then use it for the vlan routing.. doesn't need to be POE for that.
 
IP re-addressing is not gonna happen, 500+ devices...this was created long before my boss or myself.
We actually have 6248 switches for our data, but they are not POE.

It can if you want.

My group (I'm not in network ops but) just finished resubmitting and re-iping a whole University 20,000 people and 50-60,0000 devices. It can be done but its a bitch :p

The scheme is what it is but I would be doing vlans to separate out the traffic.
 
I did not think about that...we have a stack of those as our main data switches.

In the event you want some config items from ours PM me. We have a couple of 6224 stacks and a couple of 6248 stacks acting as the core switches. Easy stuff to work with.

on another re-iping note. You could be creating vlans to do it right from here forward. anything new gets added to those vlans and slowly over time you could migrate a few at a time.
 
you will want to QOS your voice traffic. Best way to do that is vlan's and then QOS the RTM stream.

You do not want your bosses VoIP conversation to take a drive because you (or anyone on the same switch) started to download an ISO

Create your voice vlan, keep the data vlan how it is now. Once configured correctly the phone will pass the data vlan off to the computer / device connected too it.
 
IP re-addressing is not gonna happen, 500+ devices...this was created long before my boss or myself.
We actually have 6248 switches for our data, but they are not POE.

Why not? A good IT person will convince any management, as long as you are not the one that implemented it, that their network is jacked and in need of heavy attention. Remember IT is an employee (the network is the employee in this example). If that employee does not work effectively or efficiently you fire them and get a replacement. IT must be a good employee or else what good is it to the company? I would even recommend bringing in a few high level network engineers to work as a team to resolve the reengineering of your network. Trust me when your IT infrastructure is very well oiled and running at peak physique you will be thanked heavily for it. SOOOOOOOO many IT people try to do everything solo. I have learned I get more done and get more recognition when I build teams of techs, contractors, and outside help to get stuff done the right way.

Who chose those IP ranges?

Subnetting is not about picking your lucky number that day, it is about picking the number of hosts you want one network to support factored in with how much broadcast traffic you are willing to allow on that particular network.

Vlan and QoS is your friend. If your supervisors start getting bad voice quality and dropped calls and you cant fix it, unemployment is really high and there are a lot of IT people with resumes waiting at the door.

If you are using Cisco switches that are of recent age and model they have a built in Voice VLAN function that automatically raises QoS priority and all you have to do is turn it on and plug stuff up. (a little more than that of course)
 
Last edited:
This IP address range was chosen probably 20+ years ago by people who have long since retired. My boss is the IT manager and he has been here for 13 years, it was done before him.
We don't have any VLANs at all...everything is one big network.
Everything from phones to CNC machines that are connected to our network would have to be changed.
 
This IP address range was chosen probably 20+ years ago by people who have long since retired. My boss is the IT manager and he has been here for 13 years, it was done before him.
We don't have any VLANs at all...everything is one big network.
Everything from phones to CNC machines that are connected to our network would have to be changed.

That could be the project that puts you in the spotlight and a HUGE resume bullet.

From the way it sounds to me.... you have one massive broadcast domain with over 500 hosts which means you are able to get about 10-20% total network efficiency out of the whole thing when a re-networking of the whole topography would you get back up into the 90th percentile.
 
Well I guess we can quit pissing over the politics...

Code:
vlan database
vlan 10,30,80

vlan routing 10 1
vlan routing 30 2
vlan routing 80 3

ip route 0.0.0.0 0.0.0.0 192.168.0.1
ip helper-address 192.168.0.6 dhcp
interface vlan 10
name "IP_Camera"
routing
ip address 192.168.10.254 255.255.255.0
ip ospf area 0.0.0.0
ip ospf cost 10
exit

interface vlan 30
name "Management_Network"
routing
ip address 192.168.30.254 255.255.255.0
ip ospf area 0.0.0.0
ip ospf cost 10
exit

interface ethernet 1/g1
classofservice trust ip-dscp
switchport access vlan 10
exit
!
interface ethernet 1/g2
switchport access vlan 10
exit

interface ethernet 1/g45
classofservice trust ip-dscp
description 'trunk'
spanning-tree cost 2048
spanning-tree guard root
switchport mode trunk
switchport trunk allowed vlan add 10,30,80
exit

If your going to add the vlans at least add RFC1918 space when you do it.
 
Back
Top