Dell U2713H Inexplicably Develops Masses of Stuck Subpixels

Discussion in 'Displays' started by Oubadah, Apr 5, 2018.

  1. Oubadah

    Oubadah [H]ard|Gawd

    Messages:
    1,564
    Joined:
    Apr 16, 2009
    I stopped using a U2713H for ~3 months, and upon turning it back on yesterday, I discovered that it's now covered in stuck/bright subpixels. I had scrutinized this monitor very closely before I stopped using it, so I know for certain that the defects weren't present then. It's just been sitting on the floor of my spare room since then. What could have caused this?
     
  2. Kamainae

    Kamainae [H]Lite

    Messages:
    72
    Joined:
    May 3, 2009
    The same thing happened to my U2312Hm not so long ago, same setting, brief period of storage of the panel after being used dialy since purchase, and now has a small cluster of stuck pixels near the bottom right corner. Judging by the position and shape I am guessing that the panel was banged during storage.
     
  3. mnewxcv

    mnewxcv [H]ardness Supreme

    Messages:
    6,470
    Joined:
    Mar 4, 2007
  4. bigbluefe

    bigbluefe Gawd

    Messages:
    662
    Joined:
    Aug 23, 2014
    That's a nice monitor manufacturing industry you've got there.
     
  5. Oubadah

    Oubadah [H]ard|Gawd

    Messages:
    1,564
    Joined:
    Apr 16, 2009
    The only thing I can think of is that there's a treadmill on the other side of the room, so maybe the vibrations caused it. However, the treadmill was barely used in that time. Also, there was a U2711 sitting right next to the U2713H the whole time and that has no stuck pixels.

    You want a photo of the pixels? It's going to be impossible for me to get anything better than some blurry close-ups of individual pixels, because I don't have a camera that can capture tiny specks of light floating in the milky glow that is an LCD's excuse for black.