Deal: $20 2GB OCZ Gold PC6400 (40 MIR) Free shipping

jhartono0002

2[H]4U
Joined
Dec 4, 2003
Messages
2,828
OCZ part# [FONT=Verdana,Arial,Helvetica]OCZ2G800R22GK
Frys OCZ Link: click me

attn: 11/23-24 only

sorry if somebody already post this
[/FONT]
 

Moto450fyz

Limp Gawd
Joined
Sep 20, 2005
Messages
426
I just grabed a set of the Plat Rev 2 last week for $25 bucks and I thought that was cheap, YIKESSSSSSSS they are giving it away now.
 

posterChild

Weaksauce
Joined
Jun 10, 2004
Messages
68
Just a heads up, this deals seems to be good only today, so hurry if you want it. This from the rebate pdf:

3. A copy of the sales receipt with the purchase date on
November 23, 2007 ONLY**.

Rebate Link

posterChild
 

ziddey

Supreme [H]ardness
Joined
Dec 24, 2002
Messages
5,392
damn. was it advertised as being 23-24? maybe there's going to be another rebate for today. :(

the ride with d9gkx was fun, but I don't really need it. Keep stepping down lower and lower. Got some patriot ram which uses I'm not sure what, powerchip? elpida? Looks like it's going to be cas5 from now on. Could sure use another 2gb for my heavy firefox usage patterns
 

skifreak

n00b
Joined
Mar 3, 2007
Messages
24
My OCZ is shown as on backorder, ordered Sat evening. Is anybody else in this situation ? Any notification on a expected shipping date ? OCZ rebate time frame sucks, they only give you 2 weeks from purchase date to postmarked date on rebate letter. Thanks !
 

M@iden

n00b
Joined
Dec 24, 2004
Messages
44
Mine shipped and should arrive here by Friday (FL) my set and another set for a friend ;)

Hope me and my friend can both get our rebates

I ordered Friday night
 

Brucey69

n00b
Joined
Nov 24, 2007
Messages
56
I also ordered last Friday, I checked it yesterday and it said back ordered. So I call them up and they said they might get it in stock in a week and an half, So I should have it in 2-3 weeks. Thats to long for me, so I'm canceling my order.
 

madcoder

Limp Gawd
Joined
Oct 30, 2005
Messages
288
Hi all. FYI, I obtained 2 of these last Friday in store when they were on sale along with the IP35 motherboard deal. None would boot on my test bench having just cpu, memory, motherboard, and a video card. No it was not the power supply, as it is a 600 watt Silverstone strider. No it was not the video cards because I have 2 confirmed test ones that work. No, it wasn't the bios, as I finally got one to boot with a single stick of the memory and did a bios update (after boosting memory voltage). Yes, it WAS the fact that this is very cheap memory, and that motherboard (and many others) default to 1.8 volts on the memory. For the one board I finally got to boot with one of the sticks (I tried them all and took a few hours trying to get POST), I immediately boosted the voltage to 1.9 and it worked. So, I took them back, and got some Corsair on basically the same special. It booted fine on both of my new motherboards on the first go.
 
Top