Crosshair VI Hero problem with PCIe slots

Discussion in 'AMD MoBos' started by Crystoff, Jun 4, 2017.

  1. Crystoff

    Crystoff [H]Lite

    Messages:
    111
    Joined:
    Jun 3, 2017
    New Asus Crosshair VI Hero mobo with v1201 (latest) BIOS. My graphics card is in the PCIEX16_1 slot as usual. I have two identical 4-port USB3 PCIe adapter cards (NEC Renesas controller) that I want to run in the other PCIE slots.

    If I put either of these in the second large slot PCIEX8_2, it works fine. So these USB cards are physically OK. In fact they both worked together for years in my ROG Formula Rampage, lately under Win10 x64.

    --> However, neither USB card will work in any of the other four slots on the CH6. Not in the PCIEX4_3, and not in any PCIEX1 slot. In all of these, Windows Device Manager shows that the device has a problem, and "Cannot start" (Error code 10). Attempting a driver update just finds that the best driver is already installed - which is the same driver that works fine on the installed (first) USB card in PCIEX8_2. So it isn't a Windows driver problem.

    I have tried everything obvious (install / disable / reinstall device; swap cards & slots etc). I have tried all the BIOS options relating to the PCIEX4_3 slot bandwidth, since these can affect multiple slots, but none of them helped.

    I don't think my CH6 mobo is broken - I believe it's a problem with the BIOS setup of the PCIE slots. But there must be some special factor here, because if only two slots on this board are usable there would be reports of it.

    IF anyone has more ideas I'd like to hear them.

    --> OR does anyone has a graphics card and two other PCIe cards in this mobo? Please let me know what slots you used and if any BIOS tweaks were needed.

    Thanks
     
    Last edited: Jun 4, 2017
  2. zerogg

    zerogg Limp Gawd

    Messages:
    199
    Joined:
    Jan 26, 2017
    I have had similar issues with the CH6, and I am now at 1201 I am populating all three 16x slots, and manually set the 4_3 slot to 1x. It seems to ignore the manual setting, runs 4_3 with four lanes, so my other pcie slots are unusable.
     
  3. noko

    noko [H]ardness Supreme

    Messages:
    4,321
    Joined:
    Apr 14, 2010
    Have you guys tried using the ASUS chipset driver? AMD driver? Since these slots are controlled by the X370 chipset.
     
  4. zerogg

    zerogg Limp Gawd

    Messages:
    199
    Joined:
    Jan 26, 2017
    Yeah, using the AMD drivers, but even using the gpu post, it show 4x lanes being given to the card, despite the setting supposedly restricting it to 1x.
     
  5. noko

    noko [H]ardness Supreme

    Messages:
    4,321
    Joined:
    Apr 14, 2010
    I wonder if there are any ASUS reps here yet? You might have to contact ASUS. If you bought it from NewEgg you probably can work with Nestor:
    On a number of Newegg reviews he gave out his contact information for the CH6: cl-nestor@asus.com

    At least he would know who to talk to to get good answers and possible solution.