connect mac to server 2008

Discussion in 'Networking & Security' started by booyaa, Oct 6, 2009.

  1. booyaa

    booyaa Limp Gawd

    Messages:
    335
    Joined:
    Apr 4, 2001
    Server is SBS 2008
    Mac is OSX 10.4.11
    Mac can ping server no problem.
    I'm 100% sure login/password are correct

    Open Apple K
    smb://Username@ServerName/share
    Enter credentials and I get: "name or password is not correct"

    from console:
    mount_smbfs //user@server/share share
    Enter password and I get: "tree connect phase failed: syserr = permission denied"

    I read that changing policy on server for "Microsoft network client: Digitally sign communications (always): DISABLE" would potentially fix it but no such luck.

    I can run the same exact mount_smbfs command on my bsd box and it connects just fine.

    Any ideas?
     
  2. greengolftee87

    greengolftee87 Limp Gawd

    Messages:
    274
    Joined:
    Oct 15, 2008
    Not on my mac right now to test the difference but try connecting without the username@ and see if you get the same rejection.

    "smb://xxx.xxx.xxx.xxx"
     
  3. MistrWebmastr

    MistrWebmastr Limp Gawd

    Messages:
    279
    Joined:
    Feb 24, 2008
    You have to disable forced encryption in windows file sharing. Server 2003/2008 force encryption, and it causes a problem with connecting from mac. It's in group policy, but where, I forget. I'll log into my DC and poke around a bit. We ran into this problem at work when we needed to access shares from our mac presentation computer but couldn't because the server was too secure. I'm sure you're hitting the same issue.
     
  4. MistrWebmastr

    MistrWebmastr Limp Gawd

    Messages:
    279
    Joined:
    Feb 24, 2008
    Here's the setting, it's the 2 enabled ones and one disabled one. Let me know if you have any questions. If you're not in a domain, you can access this via administrative tools > local computer policy.

    [​IMG]

    EDIT: I guess it was taken down, so here's what I believe it was:

    These were the options in the GPO:

    Computer Configuration>Policies>Windows Settings>Security Settings>Local Policies>Security Options

    Microsoft Network Client & Microsoft Network Server (set both):

    Digitally Sign Communications always and if that doesn't work also set if client agrees.
     
    Last edited: Feb 10, 2014
  5. booyaa

    booyaa Limp Gawd

    Messages:
    335
    Joined:
    Apr 4, 2001
    awesome, made the change on DC last night and now the mac can connect

    thanks for the help!
     
  6. MistrWebmastr

    MistrWebmastr Limp Gawd

    Messages:
    279
    Joined:
    Feb 24, 2008
    It bugged the hell out of me for a good few months, but they got tired of using sneakernet to get the files to the presentation computer. It's a handy tidbit to keep handy. OSX can't handle Server's encryption :)