Cisco 3550, dscp marking for QoS

bealzz

Gawd
Joined
Jun 4, 2003
Messages
545
:confused:I don't know what I'm doing wrong but I have been going through our archaic QoS setup and re-writing a new one to be a lot more streamlined and my dscp markings don't seem to be working.I'll post the relevant stuff below to see if anyone can help me with some ideas as to why its not working

Code:
mls qos
 
class-map match-any BESTEFFORT
  match access-group 10
 
policy-map BESTEFFORT-MARKING
  class BESTEFFORT
    set ip dscp 10
    police 15000000 24000 exceed-action drop
 
access-list 10 permit 10.0.0.0 0.255.255.255
 
interface FastEthernet0/24
 description to EC-3750 G1/0/5
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport trunk allowed vlan 2-99,109,225,260,925
 switchport mode trunk
 spanning-tree guard root
 service-policy input BESTEFFORT-MARKING

Our computers reside on the 10.0.0.0 network, specified in ACL10. I am doing this in baby step and will do more markings for VOICE and VIDEO as I go on, but theres no use right now since I can't even get this bit working

Code:
NET-EC-3550(config-if)#show policy-map int f0/24
 
 FastEthernet0/24
 
  service-policy input: BESTEFFORT-MARKING
 
    class-map: BESTEFFORT (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      match: access-group 10
        0 packets, 0 bytes
        5 minute rate 0 bpsqm_police_inform_feature: CLASS_SHOW
 
 
    class-map: class-default (match-any)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      match: any 
        0 packets, 0 bytes
        5 minute rate 0 bps
 
Judging by my logs;
Code:
%QM-4-CLASS_NOT_SUPPORTED: Classification is not supported in classmap BESTEFFORT

It doesn't like my match access-group 10, but how else should I be matching my 10 network if not like that???
 
Back
Top